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IMPORTANT NOTICE 

All statements, technical information and recommendations in this document which relate to the 

products supplied by Meggitt Sensing Systems are based on information believed to be reliable, but 

unless otherwise expressly agreed in writing with Meggitt SA, the accuracy or completeness of such 

data is not guaranteed. Before using this product, you must evaluate it and determine if it is suitable 

for your intended application. Unless otherwise expressly agreed in writing with Meggitt SA, you 

assume all risks and liability associated with such use. Meggitt Sensing Systems takes no 

responsibility for any statements related to the product which are not contained in a current English 

language Meggitt Sensing Systems publication, nor for any statements contained in extracts, 

summaries, translations or any other documents not authored and produced by Meggitt Sensing 

Systems. 

 

 

 

EXPORT CONTROL 

The information contained in this document may be subject to export control regulations of the 

European Community, USA or other countries. Each recipient of this document is responsible for 

ensuring that the transfer or use of any information contained in this document complies with all 

relevant export control regulations. ECN N /A. 
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PREFACE 

 

About these release notes 

This document provides important information about the VibroSight ® software from Meggitt Sensing 

Systems. It is applicable to all VibroSight-based condition monitoring and machinery protection 

systems using the versions of software described by this document, namely: 

 VibroSight software version 2.12.4 (CD part number 609-004-000-032). 

This document contains information about changes to the software since the previously released 

version (VibroSight 2.12.3), such as new features and improvements, solved problems and bug fixes, 

and hardware and software compatibility. 

For more general information on the actual software, or the entire condition monitoring system (CMS), 

refer to the following Meggitt Sensing Systems (MSS) documentation: 

 VibroSight software data sheet 

        (MSS document ref. 660-020-005-218A) 

 Getting started with VibroSight installation guide 

        (MSS document ref. 660-010-006-216A) 

 VibroSight help 

 XMV16 / XIO16T extended vibration monitoring card pair data sheet 

        (MSS document ref. 660-020-010-208A) 

 VibroSight application notes and technical notes. 

 

Users who are familiar with VibroSight may also find it useful to refer to the release notes included in 

earlier versions of the software: 

 VibroSight 2.9.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.1 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.2 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.4 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.5 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.6 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.7 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.1 (MSS document ref. 660-010-013-201A) 

 VibroSight 2.11.0 (MSS document ref. 660-010-013-203A) 

 VibroSight 2.11.1 (MSS document ref. 660-010-013-204A) 

 VibroSight 2.11.2 (MSS document ref. 660-010-013-205A) 
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 VibroSight 2.11.3 (MSS document ref. 660-010-013-206A) 

 VibroSight 2.11.4 (MSS document ref. 660-010-013-207A) 

 VibroSight 2.11.5 (MSS document ref. 660-010-013-208A) 

 VibroSight 2.11.6 (MSS document ref. 660-010-013-209A) 

 VibroSight 2.12.0 (MSS document ref. 660-010-013-210A) 

 VibroSight 2.12.1 (MSS document ref. 660-010-013-211A) 

 VibroSight 2.12.2 (MSS document ref. 660-010-013-212A). 

 VibroSight 2.12.3 (MSS document ref. 660-010-013-213A). 

 

Structure of the release notes 

This document presents information in the following order: general items first, then in terms of the 

software modules that constitute VibroSight, such as  Configurator,  Event Viewer,  Mimic, 

 Scope,  Server,  System Manager and  Vision. 

You should read those sections that are most relevant to you and then keep the document for future 

reference. 

 

Version identifiers 

A complete VibroSight software version number has four components that provide the following 

information: 

 Major release identifier: x.x.x.x 

 Minor release identifier: x.x.x.x 

 Update release identifier: x.x.x.x 

 Maintenance (build) release identifier: x.x.x.x 

For each scheduled release of VibroSight, at least one of the first three digits changes (x.x.x.x). 

For unscheduled releases, that are occasionally required to solve urgent problems, only the fourth 

digit changes (x.x.x.x). 

The version identifiers for installed software appear in the Help About box (obtained using 

Help > About … in any VibroSight software module). 
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Terminology 

To distinguish between the different Meggitt Sensing System products that can be used with the 

VibroSight software, the following terminology is used in this document: 

 VM600 card – to refer to the VibroSight-software compatible cards that are installed in a VM600 

rack. The currently available VM600 cards that are designed for operation with the VibroSight 

software are the XMx16 card pairs (XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T). 

Where XMx16 card is used in this document, it refers to XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T cards, unless otherwise stated. 

 VibroSmart DMS module or VibroSmart DMS device – to refer to VibroSight-software 

compatible modules or devices that are used in a distributed monitoring system. The currently 

available VibroSmart DMS modules and devices that are designed for operation with the 

VibroSight software are the VSI010, VSN010 and VSV300. 

Where VibroSmart DMS module is used in this document, it refers to VSI010 and VSV300 

modules, unless otherwise stated. 

Where VibroSmart DMS device is used in this document, it refers to the VSN010 device, unless 

otherwise stated. 
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1 Licensing 

In general, the licence key required to enable purchased product options remains unchanged between 

update or maintenance level releases. For example, from version 2.12.3 to version 2.12.4. 

However, a new licence key is required for upgrades between major or minor level releases. 

For example, from version 2.11.x to version 2.12.x. 

To obtain a new VibroSight licence key file or for further information on licence keys, contact Meggitt 

Sensing Systems customer support. See 7 Customer support. 

 

 

2 Features 

 General 

There are no new features in VibroSight 2.12.4 as this version was released to solve specific existing 

problems and bugs. See 3 Solved problems and bug fixes. 
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3 Solved problems and bug fixes 

 General 

3.1 Improvements and bug fixes 

General stability improvements across the various VibroSight 2.12.4 software modules. 

 

3.2 Errors related to regional and language settings 

The format used by Windows® to display information (such as dates, times, currency, and 

measurements) can be changed on a computer in order to match the language or standards used in a 

particular region or country. 

Amongst others, these Windows settings change the decimal mark (symbol) used as the separator 

between the integer part and the fractional part of a decimal number. In general, most countries use 

either a decimal point (for example, Switzerland, UK and US) or a comma (for example, France and 

Germany) as the separator. 

Depending on the underlying Windows regional and language settings (Region and Language), 

VibroSight could experience errors such as unhandled exceptions when working with decimal (non-

integer) numbers, particularly when a comma was used as the decimal separator. 

For example, this bug was seen in VibroSight Configurator when working with various configuration 

parameters that accept decimal numbers and in VibroSight Vision when working with the x-axis and 

y-axis parameters (Plot Properties) to change the displayed plot. 

 

  VibroSight Configurator 

3.3 VM600 XMx16 card: Dynamic input channel with current signal 
transmission 

When configuring a VM600 XMX16 card’s dynamic input channel for current signal transmission 

(Signal Transmission Mode: Current), the value configured for the Sensitivity of the channel was 

effectively ignored as when the configuration was activated and saved to a VibroSight Server 

database, the database always used a value of 1 for the sensitivity. 

 

  VibroSight Server 

3.4 VibroSight Server as a Windows service 

When running the VibroSight software in demonstration mode (that is, without a valid licence), it was 

not possible to run a VibroSight Server as a Windows service. 
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4 Known issues 

4.1 Changing a VibroSight Server’s maximum RAM cache size when DSNs are 
not used 

Since VibroSight 2.9.7, a VibroSight Server database no longer requires a data source name (DSN), 

so it is no longer required to use the ODBC Data Source Administrator to manage the underlying 

connection to the Sybase SQL Anywhere 11 database (which provided convenient access to the start 

line command that is used to start the SQL Anywhere 11 server). 

NOTE: dbeng11.exe -ch 600m is the default command used to start the SQL 

Anywhere 11 server, where the -ch 600m option specifies that a maximum RAM 

cache size of 600 MB should be used. (This option limits the underlying SQL 

Anywhere’s database server cache during automatic cache growth.) 

However, for more complex machinery monitoring applications and larger 

databases, it is recommended that a maximum RAM cache size of 2000 MB 

(-ch 2000m) is used, in order to improve the overall performance of the VibroSight 

machinery monitoring system. 

 

When a DSN is not used with a VibroSight Server database, the settings usually written to the DSN 

using the ODBC Data Source Administrator are managed by the VibroSight Server itself and stored in 

the VibroSight Server configuration file (*.vssrvcfg). However, this means that the specification of 

the maximum cache size to be used by the VibroSight Server database is not as convenient to access 

by the user. 

Presently, the default command used to start the SQL Anywhere 11 server will be used unless: 

 In VibroSight Configurator, when saving the configuration as a server / database, the Configure 

advanced settings option is used to enter a different SQL database start line command. 

 In VibroSight System Manager, when copying the database, the Configure advanced settings 

option is used to enter a different SQL database start line command. 

So when DSNs are not used with a VibroSight Server database, the VibroSight Server configuration 

file (*.vssrvcfg) must be edited manually if it is necessary to change the SQL database start line 

command after a VibroSight Server database has been created or copied: 

1. Exit all VibroSight software modules (clients and servers) that use the VibroSight Server 

database to be modified. 

2. Use a text editor program to open the VibroSight Server configuration file (*.vssrvcfg) and 

search for the text string dbeng11.exe. 

3. Edit the StartLine="dbeng11.exe -ch 600m" command in the configuration file to use the 

new required maximum cache size. 

For example, StartLine="dbeng11.exe -ch 2000m", then save the file. 

4. Restart the VibroSight Server. 

 

If the StartLine="dbeng11.exe -ch 600m" command cannot be found in the VibroSight Server 

configuration file being used, then a “dummy” copy of the VibroSight Server database should be 
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created using VibroSight System Manager’s Database Copy command with the Configure advanced 

settings option selected. A “dummy” VibroSight Server configuration file created in this way will include 

the SQL database start line command and can be used as an example to edit the VibroSight Server 

configuration file being used. (After which, the “dummy” files should be deleted.) 

NOTE: It is highly recommended to make a backup copy of the VibroSight Server 

configuration file being used before manually editing it. 

Such manual edits must be done carefully in order to ensure that the tags and 

delimiters used in the VibroSight Server configuration file are used correctly. 

 

4.2 Display of timestamps in VibroSight Vision 

In VibroSight Vision, when the timestamps (date and time) are configured to be displayed as Site time 

or Local computer time and the site time or local computer time is subsequently changed on the 

relevant computer (for example, using Windows > Control Panel > Date and Time), this change is not 

reflected in the VibroSight Vision user interface until the user clicks on the Timestamp displayed in 

the VibroSight Vision status bar. 

 

4.3 Small “holes” in plotted data for larger VibroSight Vision projects when 
viewing live data 

Depending on the complexity of a VibroSight application and the performance of the computer running 

the VibroSight software, the responsiveness of VibroSight Vision can decline under certain situations 

and affect the display of plots when viewing live data. 

In particular, this performance issue has been seen with larger VibroSight Vision projects containing 

many open plots using live data. It is typically characterised by plots being displayed with small “holes” 

in the data, corresponding to when the computer has reached its performance limits. 

If this behaviour is seen, the recommended workaround is to: 

 Reduce the number of active plots in the VibroSight Vision project in order to reduce the 

computational load, as only the currently displayed (foreground) plots are constantly 

refreshed. Plots that are hidden or minimized (background) are not active and will only be 

refreshed when they become visible again. 

 If it is necessary to view historical data at the same time, consider using a separate VibroSight 

Vision session to work with the historical data, preferably on a different computer. 

 

4.4 Missing data for XMV16 and XMVS16 cards 

When the order-tracked sampling mode is being used, XMV16 and XMVS16 cards have been seen to 

disappear (drop out) and produce no data for periods of 10, 20 or 30 seconds. After which, the card 

usually reappears without any intervention and normal operation resumes. 

This issue is being investigated and appears to be an XMV16 and XMVS16 card firmware problem 

that is related to transitions in the input speed signal from “zero speed” to “non-zero speeds”. 
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4.5 VibroSight Server and Host Service restart required after changes to 
network adapter 

If the configuration of a network adapter is changed (for example, enabled or disabled, connected or 

disconnected) on a computer running VibroSight, then the VibroSight Servers and Host Services 

running on the computer must be restarted in order for the network adapter to be recognized by the 

VibroSight discovery mechanism. 

 

4.6 Length limitation of VibroSight Server instance names 

Since VibroSight 2.9.6, VibroSight Server instance names are limited to 18 characters, whereas up to 

27 characters were allowed in previous versions. This constraint is enforced during the creation of new 

server instances with VibroSight 2.9.6 or later. 

NOTE: VibroSight allows only alphanumeric characters (A to Z, a to z, 0 to 9), the 

hyphen-minus character ( - ) and the underscore character ( _ ) to be used for 

VibroSight Server names. 

 

However, existing server instances may be non-compliant (too long) and no longer run after an 

upgrade of the VibroSight software. In such cases, the file names used for the VibroSight Server 

database file (*.vssrvdb or *.db) and the VibroSight Server configuration file (*.vssrvcfg or 

*.config) should be updated (and manually edited in the VibroSight configuration file) to be 

18 characters or less. Changes may also be required in any VibroSight software that references the 

server instance name, such as VibroSight Vision projects. 

Where used, the automated database copies append a timestamp (_yyyyMMddHHmmss) to the 

Server instance name which reduces the number of file name characters that remain available for 

VibroSight Server instance names to three. Alternatively, the server instance name can be shorted 

after the database copy is complete. 

Also, depending on the VibroSight Server database file names used and any truncation performed by 

VibroSight, it is possible that servers are created with names that contain non-allowed characters 

(such as spaces), with the result that these servers will not be accessible by VibroSight software 

clients. Similarly, duplicate VibroSight Server names are also possible. 

NOTE: Choose appropriate VibroSight Server names in order to avoid name conflicts 

arising due to truncation and/or additional databases being created during 

automatic data management. 

This is particularly important for systems with automated data management and 

system backup procedures that use script files containing database commands 

(such as copy and backup) that can automatically generate VibroSight Server 

database files. 
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4.7 VibroSight client connections to local and remote VibroSight Servers are 
mutually exclusive 

When a VibroSight Server is running on a (local) computer, a VibroSight client, such as VibroSight 

Configurator or VibroSight Vision running on the same (local) computer cannot connect to a VibroSight 

Server running on a different (remote) computer. 

 

4.8 VibroSight Servers listen to a single IP address 

A VibroSight Server uses one specific IP address for connections to VibroSight clients and all 

communications is directed through this VibroSight Server IP address. This IP address can be set to 

any of the available network adapters or logical addresses on the host computer running the 

VibroSight Server. On a computer with a single network adapter, the IP address of the single network 

adapter is used by default. 

In typical applications, the network adapter of the host computer running the VibroSight Server is 

connected to a dedicated control (industrial) Ethernet network that contains the VibroSight-compatible 

hardware such as VM600 XMx16 cards and VibroSmart DMS devices. 

However, as a VibroSight Server uses one specific IP address (network adapter), this prevents 

concurrent connections from VibroSight clients running on other separate networks, such as a 

business (corporate) Ethernet network. 

 

4.9 Display of timestamps in VibroSight clients other than VibroSight Vision 

Although VibroSight Vision now supports the display of timestamps (date and time) as either Site time, 

UTC time or Local computer time, all other VibroSight client software modules continue to display 

timestamps in local computer time only (that is, the date and time according to the local clock of the 

computer running the VibroSight software module). 

 

4.10 Display of devices in VibroSight System Manager 

In the System Explorer window of VibroSight System Manager, the Devices tree-view does not always 

update correctly to show all of the devices (VM600 cards and VibroSmart DMS devices) available on 

the network. 

In particular, this has been seen when changing the firmware of a device, and can persist even after a 

refresh (using the Refresh toolbar button or View > Refresh). 

If this behaviour is seen, the recommended workaround is to: 

 Wait a few minutes and refresh again. 

 Restart VibroSight System Manager. 

 

4.11 VibroSight Mimic backwards compatibility 

VibroSight 2.10.0 contained significant improvements and changes, including a separate VibroSight 

Mimic client software module for mimics (that were previously available in VibroSight Vision). As a 
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result, VibroSight Vision mimics created with VibroSight 2.9.7 or earlier are not compatible with 

VibroSight 2.10.0 or later. 

VibroSight 2.11.0 contained significant improvements and changes to the VibroSight Mimic client 

software module. As a result, VibroSight Vision mimics created with VibroSight 2.10.1 or earlier are 

not compatible with VibroSight 2.11.0 or later. 

VibroSight 2.11.5 contained significant improvements to the VibroSight Mimic project framework to 

include version information, in order to improve the compatibility between projects created with 

different versions of VibroSight Mimic and eliminate the requirement for the recreation of Mimics. 

Starting with VibroSight 2.11.5, Mimic projects automatically detect any changes in the VibroSight 

Mimic software that affect project compatibility, inform the user and update the project as required. 

NOTE: VibroSight 2.11.5 is also able to open and work with Mimic projects created with 

VibroSight 2.11.0 or later, if the corresponding database had been updated as 

required. 

 

4.12 VibroSight OPC Clients not recovering 

When a VibroSight OPC Client is being used to import information from an external OPC server into a 

VibroSight system and the external OPC server becomes unavailable, the VibroSight OPC Client may 

not always recover automatically when the OPC server becomes available again. 

This is typically characterised by the VibroSight OPC Client continuing to show connection error 

messages even when OPC server is available and can result in permanent loss of the imported data if 

not noticed. 

NOTE: The external OPC data can be permanently lost if it is not imported into VibroSight 

as expected. 

Any VibroSight system feature or configuration element relying on the imported 

OPC data will not behave as expected, for example, alarms, machinery operating 

conditions and data logging rules. 

 

If this behaviour is seen, the recommended workaround is to: 

 Stop and restart the VibroSight OPC Client from either the VibroSight Server 

(Data > Acquisition > OPC Device Driver) or VibroSight System Manager. 

 Stop and restart the VibroSight Server, if required. 

 

4.13 Duplicate events 

For VibroSight systems using VM600 XMx16 cards, VibroSight Event Viewer retrieves all of the event 

information available from the data buffers on the cards. 

For VibroSight systems using VibroSmart DMS modules, VibroSight Event Viewer retrieves the event 

information available from the current time only (no buffered events). 
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Accordingly, for a VibroSight system using VM600 XMx16 cards, there is the possibility of duplicate 

events being listed in the Event Viewer, particularly for VibroSight systems being operated without an 

NTP server (where events are not recognised as duplicates due to time drift). 
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5 Compatibility 

NOTE: Refer also to the latest version of the  Getting started with VibroSight 

installation guide or the  VibroSight software data sheet for further information 

on VibroSight’s prerequisites and compatibility. 

 

As part of the VibroSight software installation process, the installation wizard will automatically check 

to see if the “Microsoft Visual C++ Redistributable Package” (see section 5.1.6) and the “OPC Core 

Components Redistributable (x86)” (see section 5.1.7) are available on the computer. 

If these items have not previously been installed and they are required by the VibroSight installation’s 

application, then the VibroSight installation wizard can be used to install them. 

 

5.1 VibroSight software 

VibroSight 2.12.4 is an update level release in the 2.x.x series and replaces VibroSight 2.12.3. 

Compatibility with existing databases is achieved using the database  Update tool (from 

VibroSight System Manager’s  Database tools) which supports the continued used of 

configurations and data from previous versions. See 6.2.1 Updating the internal structure of a 

VibroSight database. 

 

5.1.1 Microsoft Windows operating systems 

VibroSight 2.12.4 is compatible with 32-bit versions and 64-bit versions of Microsoft ® Windows ® 

operating systems. 

NOTE: Since VibroSight 2.9.0, VibroSight can run on 64-bit versions of Windows in order 

to help eliminate memory and performance issues that can occur due to the 

limitations of the 32-bit memory space. 

VibroSight 2.12.x remains 32-bit software that runs on x64 Windows in the same 

manner as it does on 32-bit windows, that is, VibroSight is "x64-compatible" 

software (not "native x64" software). 

 

See the appendix of this document for detailed information on VibroSight software and Windows 

operating system compatibility. 
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5.1.2 Microsoft .NET Framework 

For most Windows operating systems, VibroSight 2.12.4 requires that Microsoft .NET Framework 4.5 

and .NET Framework 2.0 are installed on the computer. 

However, since Microsoft .NET Framework 3.5 includes .NET Framework 2.0 and .NET 

Framework 3.0, installing Microsoft .NET Framework 4.5 and .NET Framework 3.5 Service Pack 1 is 

the recommended solution for most computers. 

NOTE: Microsoft .NET Framework 4.5 is required since VibroSight 2.9.4. 

Microsoft .NET Framework 4 (Standalone Installer) is required for VibroSight 2.9.2 

and 2.9.3. 

Microsoft .NET Framework 3.5 SP1 is required for VibroSight 2.9.1 or earlier. 

(Microsoft .NET Framework 3.5 SP1 is a full cumulative update that contains many 

new features building incrementally upon .NET Framework 2.0, 3.0, 3.5, and 

includes cumulative servicing updates to the .NET Framework 2.0 and .NET 

Framework 3.0 subcomponents.) 

Microsoft .NET Framework 2.0 is required by the OPC Core Components 

Redistributable that is installed by VibroSight (see 5.1.7 OPC Foundation OPC 

Core Components Redistributable). 

 

See the appendix of this document for detailed information on VibroSight software’s Microsoft .NET 

Framework requirements. 

 

5.1.3 Sybase SQL Anywhere 11 software 

VibroSight uses the Sybase ® SQL Anywhere 11 database software in its standard configuration. 

VibroSight 2.12.4 remains compatible with the previously deployed version of SQL Anywhere, namely 

SQL Anywhere version 11.0.1.2044. 

NOTE: VibroSight requires the 32-bit version of SQL Anywhere 11 on both 32-bit and 64-

bit Windows operating systems. 

It is strongly recommended that only the 32-bit version of SQL Anywhere 11 is 

installed on the computer running VibroSight. 

NOTE: Updating SQL Anywhere to version 11.0.1.2867 is mandatory in order to avoid 

potential memory issues (fixed by Sybase). A software update (patch) included on 

the Sybase CD must be run in order to update Sybase SQL Anywhere from version 

11.0.1 to version 11.0.1.2867: SA11_Full_Win32+x64.1101_2867_EBF.exe. 

See 6.3 Upgrading the Sybase SQL Anywhere 11 software. 

 

5.1.4 VM600 CMS software 

The VM600 CMS software from Meggitt Sensing Systems uses Sybase SQL Anywhere 8. Both 

Sybase SQL Anywhere 8 (VM600 CMS) and Sybase SQL Anywhere 11 (VibroSight) can be installed 

on the same computer. 
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However, while SQL Anywhere 8 and SQL Anywhere 11 can be installed on the same computer and 

run at the same time for standard database operations, certain administrative tasks are mutually 

exclusive and may block one another. 

More specifically, all operations that refer to Sybase ISQL (a command-line Interactive SQL utility) in 

the background could be directed to the wrong version of Sybase SQL Anywhere. For example, this 

impacts all user operations and system operations involving the creation, copying and updating of 

databases. 

NOTE: It is recommended to install and use VibroSight on a computer that does not have 

the VM600 CMS software installed. 

 

5.1.5 SIMATIC Step 7 software 

The SIMATIC Step 7 software from Siemens typically uses Sybase SQL Anywhere 9. Both Sybase 

SQL Anywhere 9 (SIMATIC Step 7) and Sybase SQL Anywhere 11 (VibroSight) can be installed on 

the same computer. 

However, while SQL Anywhere 9 and SQL Anywhere 11 can be installed on the same computer, they 

cannot run at the same time. 

More specifically, if SIMATIC Step 7 and VibroSight are both installed, certain administrative tasks, 

such as all user operations and system operations involving the creation, copying and updating of 

databases, may not work correctly. If this behaviour is seen, the recommended workaround is to 

manually change or remove the SQLANY environmental variable in order to allow VibroSight to work 

correctly. 

Note: The SQLANY environment variable is used to contain the directory where Sybase SQL 

Anywhere is installed. 

NOTE: It is recommended to install and use VibroSight on a computer that does not have 

the SIMATIC Step 7 software installed. 

 

5.1.6 Microsoft Visual C++ Redistributable Package 

The Microsoft Visual C++ Redistributable Package is required in order to install and register the Visual 

C++ libraries required by a VibroSight OPC Server. 

If this package does not already exist on the computer, then the VibroSight installation wizard will 

install it automatically. (The package is included in the ISSetupPrerequisites folder on the 

VibroSight CD.) 

NOTE: The Microsoft Visual C++ Redistributable Package is required since 

VibroSight 2.9.4, if VibroSight OPC Servers are being used. 

The 32-bit version of the package (“vcredist_x86.exe”) is installed on both 32-bit 

and 64-bit Windows operating systems, as the VibroSight OPC Server is a 32-bit 

application. 
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5.1.7 OPC Foundation OPC Core Components Redistributable 

The OPC Core Components Redistributable is installed by VibroSight in order to configure and run 

VibroSight OPC Clients and VibroSight OPC Servers correctly: the redistributable must be installed on 

OPC client computers in order to allow connections to remote OPC servers and it must be installed on 

OPC server computers in order to allow OPC clients to browse for running OPC servers. 

If this redistributable does not already exist on the computer, then the VibroSight installation wizard 

will install it automatically. (The redistributable is included in the ISSetupPrerequisites folder on the 

VibroSight CD.) 

NOTE: The OPC Core Components Redistributable is required since VibroSight 2.9.4, if 

OPC clients or OPC servers are being used. 

The 32-bit version of the package (“OPC Core Components Redistributable (x86)”) 

is installed on 32-bit Windows operating systems and the 64-bit version of the 

package (“OPC Core Components Redistributable (x64)”) is installed on 64-bit 

Windows operating systems. 

The OPC Core Components Redistributable that is installed as part of the 

VibroSight software installation process requires that the Microsoft 

.NET Framework 2.0 is available on the computer. (However, since Microsoft .NET 

Framework 3.5 includes .NET Framework 2.0 and .NET Framework 3.0, installing 

Microsoft .NET Framework 3.5 Service Pack 1 is the recommended solution for 

most computers.) See also 5.1.2 Microsoft .NET Framework. 

 

 

5.2 VM600 cards 

5.2.1 Firmware 

There are no firmware updates for VM600 cards corresponding to VibroSight 2.12.4. 

NOTE: Starting with VibroSight 2.12.0, support for the existing VM600 CPUR card was 

deprecated. 

 

The latest firmware for the XMC16, XMV16 and XMVS16 remains: 

 Base System: base-system-640-003-001-011.tgz 

 Applications:  applications-640-010-001-011.tgz. 

Therefore, for current versions of the VibroSight-compatible VM600 cards, firmware upgrades are not 

required. 
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5.3 VibroSmart DMS devices 

5.3.1 Firmware 

There are no firmware updates for VibroSmart DMS modules and devices corresponding to 

VibroSight 2.12.4. 

The latest firmware for the VSI010 module remains: 

 642-002-000-008.xmsifw. 

The latest firmware for the VSN010 device remains: 

 642-004-000-010.redboxfw. 

The latest firmware for the VSV300 module remains: 

 642-001-000-012.xtranfw. 

Therefore, for current versions of the VibroSmart DMS modules and devices, firmware upgrades are 

not required. 
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6 Upgrade procedure 

This section describes the procedure for upgrading a VibroSight system from a previous version. 

Perform the steps in the given sequence in order to complete a system upgrade. 

NOTE: It is strongly recommended to verify the version of firmware running in the related 

hardware (XMx16 cards and VibroSmart DMS modules and devices) before 

starting a VibroSight system upgrade, in order to establish if any firmware updates 

are also required. 

See 6.4.3 Updating the firmware using VibroSight System Manager. 

 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart DMS is available before updating the firmware of any of the VibroSmart 

DMS modules used in the DMS. See 6.4.3 Updating the firmware using VibroSight 

System Manager. 

 

6.1 VibroSight software user settings 

The VibroSight Software generates and uses some files on the hard disk of the computer running 

VibroSight to keep track of user-configurable settings, so that these settings are remembered and 

applied for the VibroSight installation. 

These settings files have an .xmssettings file name extension and on a computer running 

Windows 7, can be found here: 

C:\Users\username\AppData\Roaming\Meggitt\VibroSight 2, where username is the Windows 

account name. 

For example, the VibroSightVision.xmssettings file records the user-configurable default 

settings for VibroSight Vision, such as default settings for plots. 

NOTE: VibroSight software updates and upgrades do not replace these settings files, so: 

• For a computer on which VibroSight was previously installed, an update, upgrade 

or a re-installation of VibroSight will continue to use the previous defaults recorded 

in the .xmssettings files. 

• For a computer on which VibroSight was not previously installed, the installation 

of VibroSight will generate and use new .xmssettings files, which use the latest 

VibroSight software defaults. 

If a settings file is deleted for any reason, VibroSight will generate and use a new 

settings file, which uses the latest VibroSight software defaults. 
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6.2 Upgrading the VibroSight software 

NOTE: Since VibroSight 2.9.6, VibroSight Server instance names are limited to 

18 characters (previously, it was 27). So VibroSight installations with VibroSight 

Server instance names of more than 18 characters will experience problems with 

VibroSight 2.12.x until the existing VibroSight Server instance names (and any 

references to them) are manually edited to be 18 characters or less. 

See also 4.6 Length limitation of VibroSight Server instance names. 

 

1. If it is not necessary for the VibroSight-based system to remain operational during the upgrade 

procedure, back up any important (required) VibroSight databases in the following way: 

 Exit all VibroSight software modules (clients and servers) – no VibroSight software modules, 

such as Vision, Configurator or Server, should be running. 

 Copy the files (*.vssrvdb, *.vssrvcfg and optionally, *.log) from the directory 

where your database files are located to another location, for example, to a specific backup 

directory. 

 NOTE: The default data (data path) directory is C:\VibroSight Data 

Or if it is necessary for the VibroSight-based system to remain operational for as long as 

possible during the upgrade procedure, back up any important (required) VibroSight databases 

in the following way: 

 Exit all VibroSight software modules (clients) – no VibroSight software modules, such as 

Vision or Configurator, should be running. 

 Start VibroSight System Manager and use the database  Backup tool from VibroSight 

System Manager’s  Database tools, and follow the instructions presented by the 

Database Backup Wizard. 

 

 NOTE: It is necessary to be logged in to System Manager as ‘Admin’ in order to have the 

user rights to access the database tools: 

Select your  VibroSight Host (computer) in the System Explorer tree structure 

and click  Login (from VibroSight System Manager’s  Access Rights 

tools). 

Refer also to the Backing up a database topic in the  VibroSight help. 
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2. Make backup copies of any important (required) VibroSight Vision projects in the following way: 

 Create an archive file (for example, *.zip) containing all of the files (*.xml and 

*.xmsproj) in the directory where your project files are located. 

 NOTE: The default project directory is: 

C:\Documents and settings\username\My Documents 

\VibroSight\Projects 

 

3.  Ensure that no VibroSight software modules are running. 

4. Remove the currently installed version of the VibroSight software (for example,  

 VibroSight Standard Edition) using Windows Add or Remove Programs, in one of the 

following ways: 

 Click Start > Settings > Control Panel and then double-click Add or Remove Programs. 

 Or click Start, click Control Panel and then double-click Add or Remove Programs. 

5. Install the latest version of the VibroSight software by inserting the VibroSight CD into the 

CD/DVD drive of the computer and follow the instructions presented by the VibroSight 

installation wizard. 

NOTE: Refer to the  Getting started with VibroSight installation guide for detailed 

information on installing the VibroSight software – including prerequisites and 

compatibility. 

 

6. Restart VibroSight Server and ensure that the required communications are enabled. For 

example, enable card and module device drivers according to the hardware in the system: 

 For example, click Data > Acquisition > XMC16/XMV16 Card Driver or 

Data > Acquisition > VibroSmart Module Driver. 

7. Restart VibroSight Vision and ensure that live data is being received from the hardware and 

displayed in Vision. 

8. The VibroSight system is now up and running. 

 

6.2.1 Updating the internal structure of a VibroSight database 

When VibroSight Server is started, it checks the status of the database and will automatically inform 

the user if any internal structures of the database need to be updated before proceeding. 

1. Update a VibroSight database in the following way: 

 Start VibroSight System Manager and use the database  Update tool from VibroSight 

System Manager’s  Database tools, and follow the instructions presented by the 

Database Update Wizard. 
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 NOTE: It is necessary to be logged in to System Manager as ‘Admin’ in order to have the 

user rights to access the database tools: 

Select your  VibroSight Host (computer) in the System Explorer tree structure 

and click  Login (from VibroSight System Manager’s  Access Rights 

tools). 

Refer also to the Updating a database topic in the  VibroSight help. 

 

 

6.3 Upgrading the Sybase SQL Anywhere 11 software 

VibroSight software is compatible (and extensively tested) with Sybase SQL Anywhere versions 

11.0.0 and 11.0.1. 

However, with the release of SQL Anywhere version 11.0.1.2867, Sybase has fixed some previously 

known memory issues. Therefore, it is mandatory to upgrade all VibroSight systems to this version of 

SQL Anywhere 11. 

 

Determine the version of the SQL Anywhere 11 database engine installed on a computer in the 

following way: 

1. From the Start menu, click Start > All Programs > SQL Anywhere 11 > Sybase Central. 

The Sybase Central window appears. Sybase Central is a GUI-based management tool for 

Sybase products. 

2. Click Help > About Sybase Central. 

The About Sybase Central windows appears, displaying the version information for SQL 

Anywhere 11 (and any other installed Sybase products). 

 

 NOTE: Refer also to the Determining the version of SQL Anywhere 11 installed on a 

computer topic in the  VibroSight help. 

 

If SQL Anywhere 11 version 11.0.0 is installed on the computer, it is necessary to first remove 

version 11.0.0, then install version 11.0.1 from the Sybase CD. 

If SQL Anywhere 11 version 11.0.1 is installed on the computer, simply update to version 11.0.1.2867 

by running the software update (patch) included on the Sybase CD. 
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When SQL Anywhere 11 software version 11.0.0 is installed on the computer: 

NOTE: Do not use the SQL Anywhere 11.0.1 setup to upgrade directly to software version 

11.0.1 from software version 11.0.0. Instead, it is necessary to upgrade the Sybase 

database software as follows: 

1. Remove SQL Anywhere 11.0.0, using the Windows Add or Remove Programs 

tool. 

2. Install SQL Anywhere 11.0.1, using the Sybase SQL Anywhere 11.0.1 CD. 

Refer also to the  Getting started with VibroSight installation guide for 

information on installing the Sybase software. 

 

1. Exit all VibroSight software modules (clients and servers) – no VibroSight software modules, 

such as Vision, Configurator or Server, should be running – as this also stops the SQL 

Anywhere 11 database engine. 

The  lightning icon that appears in the notification area (at the far right of the task bar) to 

indicate that a Sybase database engine is running should no longer be shown. 

2. Remove the currently installed version of Sybase SQL Anywhere 11 using Windows Add or 

Remove Programs, in one of the following ways: 

 Click Start > Settings > Control Panel, then double-click Add or Remove Programs 

 Or click Start, click Control Panel and then double-click Add or Remove Programs. 

And remove  SQL Anywhere 11. 

3. Restart the computer. 

4. Install Sybase SQL Anywhere VibroSight 11.0.1.2044 by inserting the Sybase CD into the 

CD/DVD drive of the computer and following the instructions presented by the 

SQL Anywhere 11 installation wizard. 

5. Restart the computer. 

Without this final computer restart, VibroSight Server may not be able to start the 

SQL Anywhere 11 database engine. 

 

When SQL Anywhere 11 software version 11.0.1 is installed on the computer: 

1. Update to Sybase SQL Anywhere VibroSight 11.0.1.2867 by inserting the Sybase CD into the 

CD/DVD drive of the computer, running the SA11_Full_Win32+x64.1101_2867_EBF.exe 

software update (patch) and following the instructions presented by the SQL Anywhere 11 

installation wizard. 

2. Restart the computer. 
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6.4 Updating the VibroSight hardware 

Appropriate files and tools are included in the installation package to allow VM600 cards (XMx16) and 

VibroSmart DMS devices (VSI010, VSN010 and VSV300) to be updated to the latest firmware, in 

order to take advantage of improvements to the VibroSight software. 

Updating the firmware VM600 cards or VibroSmart DMS devices is a special task that can, if used 

unintentionally or incorrectly, lead to malfunctioning of the device and affect proper function of data 

acquisition. 

During the firmware update of a device, the card or module being updated cannot provide its normal 

machinery monitoring functions because its outputs (alarms and relays) can go to undetermined 

states, irrespective of how they have been configured. 

For VibroSmart DMS modules, the machinery being monitored is not protected for the duration of a 

firmware update and the restart (reboot) that is triggered automatically after the firmware update 

(which can take up to 5 minutes). 

NOTE: It is highly recommended that firmware updates are only performed in accordance 

with the operating procedures for the machinery being monitored and that 

appropriate precautions are taken at the control system level (such as DCS 

or PLC). 

For example, alarms and relay outputs should be ignored (bypassed or inhibited) in 

order to avoid false trips of the machinery being monitored. 

 

6.4.1 VM600 card firmware 

The latest VM600 card firmware files are copied to a directory on your computer as part of the 

VibroSight software installation process. 

NOTE: For example, the default firmware directory for VM600 cards is: 

C:\Program Files\Meggitt\VibroSight 2\Firmware\VM600 

 

The firmware files for a VM600 card can be found in the appropriate subfolder and identified by their 

.tgz file name extension. For example, the XMV16 subfolder contains the applications and base 

system firmware for use by XMV16 cards. Any additional firmware updates received from Meggitt 

Sensing Systems should also be stored in these directories. 

Table 1 shows the compatibility between VibroSight software and VM600 XMx16 card hardware (that 

is, XMC16, XMV16 and XMVS16 card pair firmware). 

NOTE: It is strongly recommended to use the most recent version of the VM600 XMx16 

card firmware that is compatible with the version of VibroSight software being used. 
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Table 1: VibroSight software and VM600 XMx16 card firmware compatibility 

 VM600 XMx16 firmware (see note 1) 

VibroSight 

software version 

CD part number 

Base-system (*.tgz) 

640-003- 

001-008 

640-003- 

001-009 

640-003- 

001-010 

640-003- 

001-011 

Applications (*.tgz) 

640-010- 

001-007 

640-010- 

001-008 

640-010- 

001-009 

640-010- 

001-010 

640-010- 

001-011 

2.10.1 

609-004-000-019 
 

See note 2
   

  

2.11.0 

609-004-000-020 
 

 See 

notes 2 and 3 
 

  

2.11.1 

609-004-000-021 
   

See note 4
 

  

2.11.2 

609-004-000-022 
   

  

2.11.3 

609-004-000-023 
   

  

2.11.4 

609-004-000-024 
   

  

2.11.5 

609-004-000-025 
   

  

2.11.6 

609-004-000-026 
   

  

2.12.0 

609-004-000-027 
    

See note 5
 

 

2.12.1 

609-004-000-028 
     

See note 6
 

2.12.2 

609-004-000-029 
     

2.12.3 

609-004-000-030 
     

2.12.4 

609-004-000-032 
     

 

Notes for Table 1 (see the next page) 
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Notes for Table 1 

1. VM600 XMx16 card firmware is packaged and distributed as a .tgz file (a compressed archive file format) with PNRs such as 

640-003-001-xxx for the Base System and 640-010-001-xxx for the (Applications) Firmware. In these PNRs, the xxx-xxx-001-

xxx denotes the firmware is packaged in the tgz file format. 

After the .tgz file is unpacked by VibroSight System Manager and the firmware is uploaded to a VM600 XMx16 card, the dialog 

box displayed by the VibroSight System Manager’s Change Firmware command shows the current version of firmware using 

PNRs such as 640-010-000-xxx for the Firmware and 640-003-000-xxx for the Base System, which correspond to the actual 

unpacked firmware that is running on the card. 

 

2. Updating to these versions of VM600 XMx16 card firmware requires a two-step process: 

(i) VibroSight System Manager’s Change Firmware command should be used to update the base-system 

firmware (640-003-001-00*.tgz) only. 

(ii) Then the Change Firmware command should be used again to update the applications 

firmware (640-010-001-00*.tgz) only. 

 

3. This version of VM600 XMx16 card firmware introduces support for the direct measurement mode that is used to acquire 

direct data (digitised waveform) before an event. 

 

4. This version of VM600 XMx16 card firmware introduces support for the operation of a VibroSight system without an NTP 

server (NTP-free). 

 

5. This version of VM600 XMx16 card firmware introduces support for hydro air-gap monitoring. 

 

6. This version of VM600 XMx16 card firmware introduces support for 1 s time-boxed peak-hold processing (that is, spectral 

data aggregation). 
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6.4.2 VibroSmart DMS device firmware 

The latest VibroSmart DMS device firmware files are copied to a directory on your computer as part of 

the VibroSight software installation process. 

NOTE: The default firmware directory for VibroSmart DMS devices is: 

C:\Program Files\Meggitt\VibroSight 2\Firmware\VibroSmart 

 

The firmware files for a VibroSmart DMS device can be found in the appropriate subfolder and 

identified by their .*fw file name extension. For example, the VSV300 subfolder contains the firmware 

for use by VSV300 modules. Any additional firmware updates received from Meggitt Sensing Systems 

should also be stored in these directories. 

Table 2 shows the compatibility between VibroSight software and the VibroSmart VSI010 module 

firmware. 

Table 3 shows the compatibility between VibroSight software and the VibroSmart VSN010 device 

firmware. 

Table 4 shows the compatibility between VibroSight software and the VibroSmart VSV300 module 

firmware. 

 

NOTE: It is strongly recommended to use the most recent version of the VibroSmart DMS 

firmware that is compatible with the version of VibroSight software being used. 
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Table 2: VibroSight software and VibroSmart VSI010 module firmware compatibility 

 VibroSmart VSI010 firmware (see note 1) 

VibroSight 

software version 

CD part number 

642-002-001-

004.xmsifw 

642-002-001-

005.xmsifw 

642-002-000-

006.xmsifw 

642-002-000-

007.xmsifw 

642-002-000-

008.xmsifw 

2.10.1 

609-004-000-019 

See note 2 2.11.0 

609-004-000-020 

2.11.1 

609-004-000-021 

2.11.2 

609-004-000-022 


 See note 3
 

    

2.11.3 

609-004-000-023 
 

    

2.11.4 

609-004-000-024 
  

   

2.11.5 

609-004-000-025 
  

   

2.11.6 

609-004-000-026 
  

 See note 4
 

  

2.12.0 

609-004-000-027 
   

  

2.12.1 

609-004-000-028 
   

 See note 4
 

 

2.12.2 

609-004-000-029 
    

 

2.12.3 

609-004-000-030 
    

 See note 4
 

2.12.4 

609-004-000-032 
     

 

Notes for Table 2 

1. VibroSmart VSI010 module firmware is distributed as a single .xmsifw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart DMS device firmware using PNRs such as 

642-xxx-000-xxx, which correspond to the actual firmware that is running on the device. 
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2. VibroSight 2.10.1, 2.11.0 and 2.11.1 included features that were activated in order to ensure compatibility with development 

versions of VibroSmart DMS device firmware. However, only the later versions of each should now be used, that is, 

VibroSight 2.12.4 and the VSI010 642-002-000-008 firmware. 

 

3. Updating to this version of VibroSmart VSI010 firmware requires a two-step process: 

(i) All VSI010 devices in the DMS should be upgraded to the latest .xmsifw firmware and all VSV300 devices in the DMS 

should be upgraded to the latest .xtranfw firmware. 

Note: It is necessary to wait until these VibroSmart DMS modules have automatically restarted after the firmware update 

before continuing, that is, for up to 10 minutes (up to 5 minutes for the firmware update and up to 5 minutes for the 

duration of the restart (reboot)). 

(ii) Then all VSN010 devices in the DMS should be upgraded to the latest .redboxfw firmware.  

As this version of VibroSmart DMS device firmware enables the rapid spanning tree protocol (RSTP), this sequence is 

necessary in order to avoid broadcast storms on the network. 

 

4. Updating to this version of VibroSmart VSI010 firmware requires a specific process: 

Notes: 

For a VibroSmart DMS consisting of different types of device, the devices should be updated in the following order: first VSN010 

real-time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. 

In addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart DMS devices should be re-

activated and the VibroSmart DMS devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart DMS is available before updating any device firmware. For 

example, using the currently installed version of VibroSight (that is, before any updates to the VibroSight software 

corresponding to updates to VibroSmart DMS devices), VibroSight Configurator can be used to obtain a copy of the 

configuration as follows: 

• For a VibroSmart DMS using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart DMS not using a VibroSight Server (that is, a “stand-alone” VibroSmart DMS), the File > Open > Device 

command can be used to read the configuration directly from the VibroSmart DMS modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart DMS. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSI010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart DMS devices of the same type to use the same firmware, CTRL+click or SHIFT+click can 

be used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 
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under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSN010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart DMS (see step (1)), then activate the configuration. 

(If required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart DMS off and wait for a few seconds. Then turn the power supply back on and verify 

that the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart DMS devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 3: VibroSight software and VibroSmart VSN010 device firmware compatibility 

 VibroSmart VSN010 firmware (see note 1) 

VibroSight 

software version 

CD part number 

642-004-001-

006.redboxfw 

642-004-001-

007.redboxfw 

642-004-000-

008.redboxfw 

642-004-000-

009.redboxfw 

642-004-000-

010.redboxfw 

2.10.1 

609-004-000-019 

See note 2 2.11.0 

609-004-000-020 

2.11.1 

609-004-000-021 

2.11.2 

609-004-000-022 


 See note 3
 

    

2.11.3 

609-004-000-023 
 

    

2.11.4 

609-004-000-024 
  

   

2.11.5 

609-004-000-025 
  

   

2.11.6 

609-004-000-026 
  

 See note 4
 

  

2.12.0 

609-004-000-027 
   

  

2.12.1 

609-004-000-028 
   

 See note 4
 

 

2.12.2 

609-004-000-029 
    

 

2.12.3 

609-004-000-030 
    

 See note 4
 

2.12.4 

609-004-000-032 
     

 

Notes for Table 3 

1. VibroSmart VSN010 device firmware is distributed as a single .redboxfw file (a proprietary file format) with a PNR such as 

642-xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart DMS device firmware using PNRs such as 

642-xxx-000-xxx, which correspond to the actual firmware that is running on the device. 
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2. VibroSight 2.10.1, 2.11.0 and 2.11.1 included features that were activated in order to ensure compatibility with development 

versions of VibroSmart DMS device firmware. However, only the later versions of each should now be used, that is, 

VibroSight 2.12.4 and the VSN010 642-004-000-0010 firmware. 

 

3. Updating to this version of VibroSmart VSN010 firmware requires a two-step process: 

(i) All VSI010 devices in the DMS should be upgraded to the latest .xmsifw firmware and all VSV300 devices in the DMS 

should be upgraded to the latest .xtranfw firmware. 

Note: It is necessary to wait until these VibroSmart DMS modules have automatically restarted after the firmware update 

before continuing, that is, for up to 10 minutes (up to 5 minutes for the firmware update and up to 5 minutes for the 

duration of the restart (reboot)). 

(ii) Then all VSN010 devices in the DMS should be upgraded to the latest .redboxfw firmware.  

As this version of VibroSmart DMS device firmware enables the rapid spanning tree protocol (RSTP), this sequence is 

necessary in order to avoid broadcast storms on the network. 

 

4. Updating to this version of VibroSmart VSN010 firmware requires a specific process: 

Notes: 

For a VibroSmart DMS consisting of different types of device, the devices should be updated in the following order: first VSN010 

real-time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. 

In addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart DMS devices should be re-

activated and the VibroSmart DMS devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart DMS is available before updating any device firmware. For 

example, using the currently installed version of VibroSight (that is, before any updates to the VibroSight software 

corresponding to updates to VibroSmart DMS devices), VibroSight Configurator can be used to obtain a copy of the 

configuration as follows: 

• For a VibroSmart DMS using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart DMS not using a VibroSight Server (that is, a “stand-alone” VibroSmart DMS), the File > Open > Device 

command can be used to read the configuration directly from the VibroSmart DMS modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart DMS. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSN010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart DMS devices of the same type to use the same firmware, CTRL+click or SHIFT+click can 

be used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 
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under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart DMS (see step (1)), then activate the configuration. 

(If required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart DMS off and wait for a few seconds. Then turn the power supply back on and verify 

that the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart DMS devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 4: VibroSight software and VibroSmart VSV300 module firmware compatibility 

 VibroSmart VSV300 firmware (see note 1) 

VibroSight 

software version 

CD part number 

642-001-001-

007.xtranfw 

642-001-

001-

008.xtranfw 

642-001-

001-

009.xtranfw 

642-001-

000-

010.xtranfw 

642-001-

000-

011.xtranfw 

642-001-

000-

012.xtranfw 

2.10.1 

609-004-000-019 

See note 2 2.11.0 

609-004-000-020 

2.11.1 

609-004-000-021 

2.11.2 

609-004-000-022 


 See note 3
 

 See note 3
 

    

2.11.3 

609-004-000-023 
  

    

2.11.4 

609-004-000-024 
   

   

2.11.5 

609-004-000-025 
   

   

2.11.6 

609-004-000-026 
   

 See note 4
 

  

2.12.0 

609-004-000-027 
    

  

2.12.1 

609-004-000-028 
    

 See note 4
 

 

2.12.2 

609-004-000-029 
     

 

2.12.3 

609-004-000-030 
     

 See note 4
 

2.12.4 

609-004-000-032 
      

 

Notes for Table 4 

1. VibroSmart VSV300 device firmware is distributed as a single .xtranfw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart DMS device firmware using PNRs such as 

642-xxx-000-xxx, which correspond to the actual firmware that is running on the device. 
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2. VibroSight 2.10.1, 2.11.0 and 2.11.1 included features that were activated in order to ensure compatibility with development 

versions of VibroSmart DMS device firmware. However, only the later versions of each should now be used, that is, 

VibroSight 2.12.4 and the VSV300 642-001-000-012 firmware. 

 

3. Updating to these versions of VibroSmart VSV300 firmware requires a two-step process: 

(i) All VSI010 devices in the DMS should be upgraded to the latest .xmsifw firmware and all VSV300 devices in the DMS 

should be upgraded to the latest .xtranfw firmware. 

Note: It is necessary to wait until these VibroSmart DMS modules have automatically restarted after the firmware update 

before continuing, that is, for up to 10 minutes (up to 5 minutes for the firmware update and up to 5 minutes for the 

duration of the restart (reboot)). 

(ii) Then all VSN010 devices in the DMS should be upgraded to the latest .redboxfw firmware.  

As these versions of VibroSmart DMS device firmware enable the rapid spanning tree protocol (RSTP), this sequence is 

necessary in order to avoid broadcast storms on the network. 

 

4. Updating to this version of VibroSmart VSV300 firmware requires a specific process: 

Notes: 

For a VibroSmart DMS consisting of different types of device, the devices should be updated in the following order: first VSN010 

real-time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. 

In addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart DMS devices should be re-

activated and the VibroSmart DMS devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart DMS is available before updating any device firmware. For 

example, using the currently installed version of VibroSight (that is, before any updates to the VibroSight software 

corresponding to updates to VibroSmart DMS devices), VibroSight Configurator can be used to obtain a copy of the 

configuration as follows: 

• For a VibroSmart DMS using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart DMS not using a VibroSight Server (that is, a “stand-alone” VibroSmart DMS), the File > Open > Device 

command can be used to read the configuration directly from the VibroSmart DMS modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart DMS. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSV300 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart DMS devices of the same type to use the same firmware, CTRL+click or SHIFT+click can 

be used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 
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under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSN010 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart DMS (see step (1)), then activate the configuration. 

(If required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart DMS off and wait for a few seconds. Then turn the power supply back on and verify 

that the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart DMS devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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6.4.3 Updating the firmware using VibroSight System Manager 

When performing VibroSight software upgrades, it is strongly recommended to systematically upgrade 

the firmware of VM600 XMx16 cards and VibroSmart DMS devices to the latest compatible version. 

Failure to perform a necessary VibroSight-compatible VM600 card firmware update may lead to 

incoherent system behaviour and affect the proper functioning of data acquisition in a system. It is only 

in systems where the firmware running on the XMx16 cards and VibroSmart DMS devices already 

corresponds to the latest available version that no firmware update is required. Therefore, it is strongly 

recommended to verify the version of firmware running on the hardware before starting a VibroSight 

system upgrade, in order to establish if a firmware update is also required. 

NOTE: Changing the firmware of the VibroSight hardware is a special administrative task 

that can – if performed unintentionally – affect the proper functioning of data 

acquisition in a system. 

It is therefore strongly recommended to change the firmware of the VibroSight 

hardware only when it is necessary. For example, when the devices must be 

updated to be compatible with a VibroSight software upgrade. 

 

For VibroSmart DMS modules, each module can be selected and its firmware updated individually. 

Alternatively, multiple modules of the same type (for example, VSV3x0) can be updated to the same 

version of firmware at the same time. 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart DMS is available before updating the firmware of any of the VibroSmart 

DMS modules used in the DMS. 

For example, using the currently installed version of VibroSight (that is, before any 

updates to the VibroSight software corresponding to updates to VibroSmart DMS 

modules), VibroSight Configurator should be used to obtain a copy of the 

configuration as follows:  

For a VibroSmart DMS using a VibroSight Server, the File > Open > Server / 

Database command can be used to read the configuration from the VibroSight 

Server. 

For a VibroSmart DMS not using a VibroSight Server (that is, a “stand-alone” 

VibroSmart DMS), the File > Open > Device command can be used to read the 

configuration directly from the VibroSmart DMS modules. 

Then the File > Save As > File command should be used to store a copy of the 

configuration for the VibroSmart DMS. 

 

Update the firmware on a VibroSight device using the  Change Firmware tool (from VibroSight 

System Manager’s Maintenance tools): 

1. Ensure that the computer running the VibroSight software is on the same network as the 

hardware (XMx16 card or VibroSmart DMS module or device) to be updated. 



     

 
 

   

     

 

     
 Release Notes VIBROSIGHT-RN/E (660-010-013-214A) 

Release 2.12.4 – June 2015 41 / 46  

     
 

2. Start VibroSight System Manager and navigate to the Devices tree structure in the System 

Explorer window. 

The Devices tree lists all of the VibroSight compatible hardware that VibroSight can see on the 

network. If there are no XMx16 cards or VibroSmart DMS devices in the tree structure or some 

cards are missing, verify your network connections. 

3. Select the card or device that requires its firmware to be changed. 

The Actions tool window updates to show the available tools. 

To change multiple VibroSmart DMS to use the same version of firmware at the same time, use 

CTRL+click or SHIFT+click to select multiple devices from the Devices tree-view. (Then, when 

the Change Firmware command is run, all of the devices that were selected will be updated at 

the same time.) 

4. Click  Change Firmware in the Maintenance tools group of the Actions window. 

The Change Firmware dialog box appears. 

5. Click the Add button and select the new firmware files for the card or new firmware file for the 

device. 

 NOTE: The Change Firmware dialog box automatically opens the firmware folder 

corresponding to the VibroSight-compatible VM600 card or VibroSmart DMS 

device selected. 

.tgz files are for VM600 cards and .*fw files are for VibroSmart DMS devices. 

 

6. Click the Finish button to start the firmware upgrade process. 

For XMx16 cards and VibroSmart DMS devices, the firmware upgrade process can take up to 

5 minutes, during which: 

 The IP address beside the device’s serial number in the Devices tree structure can 

disappear. 

 The LEDs on the front panel of the device can change to reflect the status of the upgrade. 

7. Repeat steps 3 to 6 for each device that requires a firmware update. 

 NOTE: Although the firmware for each VibroSight device must be changed individually 

using the  Change Firmware tool, as each device updates its firmware 

independently of the VibroSight software (once the process has started), firmware 

updates can be performed on several devices in parallel. 

 

8. After the firmware upgrade, verify that the VibroSight system is acquiring data from the cards. 

 NOTE: Refer also to the Changing the firmware topics in the  VibroSight help. 
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The  Change Firmware tool can be used to load a VibroSight device with any version of 

firmware. It is therefore possible to change a device’s firmware to any previously available version, as 

well as the latest update. 

This feature can be useful in certain situations, for example, swapping spare VibroSight hardware 

between different VM600 racks or VibroSmart DMSs, where systems are operating with different 

versions of VibroSight. 

 

6.5 Final checks 

After upgrading the VibroSight software, the following checks are recommended to ensure that 

VibroSight has not been inadvertently modified and that it continues to operate as expected: 

 Use VibroSight Configurator to run a consistency check on the configuration in order to ensure 

that the configuration has not been modified by any changes to the VibroSight software, 

internal database structure and firmware for the hardware (VM600 cards and VibroSmart DMS 

modules). 

 Use the VibroSight Server window to check that the data acquisition, data post-processing and 

data logging settings are as expected. (Click Data > Acquisition, Data > Post-processing 

and Data > Logging and disable/enable the drivers, processing managers and logging as 

required.) 
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7 Customer support 

7.1 Contacting us 

Meggitt Sensing Systems worldwide customer support network offers a range of support including 

Technical support and Sales and repairs support. For customer support, please contact your local 

Meggitt Sensing Systems representative. Alternatively, contact our main office: 

Customer support 

Meggitt SA 

Route de Moncor 4 

PO Box 1616 

CH-1701 Fribourg 

Switzerland 

 

Telephone: +41 (0) 26 407 11 11 

Email: energysupport@ch.meggitt.com 

Web: www.meggittsensingsystems.com 

 

7.2 Technical support 

Meggitt Sensing Systems technical support team provide both pre-sales and post-sales technical 

support, including: 

 General advice 

 Technical advice 

 Troubleshooting 

 Site visits. 

 

7.3 Sales and repairs support 

Meggitt Sensing Systems sales team provide both pre-sales and post-sales support, including advice 

on: 

 New products 

 Spare parts 

 Repairs. 

 

mailto:energysupport@ch.meggitt.com
http://www.meggittsensingsystems.com/
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 VibroSight software and Windows operating system compatibility 

 
Windows XP and 

Windows Server 2003 R2 

Windows Vista and 

Windows Server 2008 

Windows 7 and 

Windows Server 2008 R2 

Windows 8 and 

Windows Server 2012 

VibroSight software 

compatible? 

Yes, but not recommended for 

new installations as Microsoft 

support for Windows XP SP3 

ended on 08 June 2014 

Yes, but not recommended. 

Windows Server 2008 R8 

should be used instead of 

Windows Server 2008 

Yes – recommended for new 

installations 
To be announced 

 

 Microsoft .NET Framework versions pre-installed on Windows operating systems 

 
Windows XP and 

Windows Server 2003 R2 

Windows Vista and 

Windows Server 2008 

Windows 7 and 

Windows Server 2008 R2 

Windows 8 and 

Windows Server 2012 

Microsoft .NET Framework 

pre-installed on Windows 

operating system 

None on XP. 

.NET Framework 2.0 on 

Server 2003 R2 

.NET Framework 3.0 .NET Framework 3.0 SP1 .NET Framework 4.5 
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 VibroSight software’s Microsoft .NET Framework requirements 

VibroSight software version 
Windows XP and 

Windows Server 2003 R2 

Windows Vista and 

Windows Server 2008 

Windows 7 and 

Windows Server 2008 R2 

Windows 8 and 

Windows Server 2012 

VibroSight 2.9.1 or earlier .NET Framework 3.5 SP1 .NET Framework 3.5 SP1 .NET Framework 3.5 SP1 .NET Framework 3.5 SP1 

VibroSight 2.9.2 and 2.9.3 .NET Framework 4 .NET Framework 4 .NET Framework 4 .NET Framework 4 

VibroSight 2.9.4 or later .NET Framework 4 .NET Framework 4.5 .NET Framework 4.5 .NET Framework 4.5 

VibroSight 2.12.0 or later 
.NET Framework 4 and 

.NET Framework 2.0 
See note

 

.NET Framework 4.5 and 

.NET Framework 2.0
 See note

 

.NET Framework 4.5 and 

.NET Framework 2.0
 See note

 

.NET Framework 4.5 and 

.NET Framework 2.0
 See note

 

Note: Since Microsoft .NET Framework 3.5 includes .NET Framework 2.0 and .NET Framework 3.0, installing Microsoft .NET Framework 3.5 SP1 is the recommended solution 

for most computers (rather than installing Microsoft .NET Framework 2.0). 
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