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IMPORTANT NOTICE 

All statements, technical information and recommendations in this document which relate to the 

products supplied by Meggitt Sensing Systems are based on information believed to be reliable, but 

unless otherwise expressly agreed in writing with Meggitt SA, the accuracy or completeness of such 

data is not guaranteed. Before using this product, you must evaluate it and determine if it is suitable 

for your intended application. Unless otherwise expressly agreed in writing with Meggitt SA, you 

assume all risks and liability associated with such use. Meggitt Sensing Systems takes no 

responsibility for any statements related to the product which are not contained in a current English 

language Meggitt Sensing Systems publication, nor for any statements contained in extracts, 

summaries, translations or any other documents not authored and produced by Meggitt Sensing 

Systems. 

 

 

 

EXPORT CONTROL 

The information contained in this document may be subject to export control regulations of the 

European Community, USA or other countries. Each recipient of this document is responsible for 

ensuring that the transfer or use of any information contained in this document complies with all 

relevant export control regulations. ECN N /A. 

 

 

 

COPYRIGHT 
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All rights reserved 

Published and printed by Meggitt SA in Fribourg, Switzerland 

The names of actual companies and products mentioned  

herein may be the trademarks of their respective owners. 

The information contained in this document is subject to change without notice.  

This information shall not be used, duplicated or disclosed, in whole or in part,  

without the express written permission of Meggitt Sensing Systems. 
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PREFACE 

About these release notes 

These release notes provide important information about the VibroSight ® software from 

Meggitt Sensing Systems. They are applicable to all installations using the versions of 

VibroSight software described by this document, namely: 

 VibroSight 2.9.0. 

The release notes contain information about changes from previous versions, such as new 

features and improvements, solved problems, bug fixes, and compatibility (hardware and 

software). 

For more general information on the actual software, or the entire condition monitoring 

system (CMS), please refer to the following Meggitt Sensing Systems (MSS) documentation: 

 VibroSight software data sheet (MSS document ref. 660-020-005-206A) 

 Getting started with VibroSight installation guide (MSS document 

       ref. 660-010-006-209A) 

 VibroSight help 

 VibroSight application notes and technical notes. 

Users who are familiar with previous versions of VibroSight may also find it useful to refer to 

the respective release notes included in their installation. 

Structure of the release notes 

This version of the VibroSight release notes presents the information in the following order: 

general items first, then in terms of the software modules that constitute VibroSight, such as 

 Configurator,  Server,  Vision and so on. 

You should read those sections that are most relevant to you and then keep the document 

for future reference. 
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1. Licensing 

In general, the licence key required to enable purchased product options remains unchanged 

for upgrades between patch level releases (for example, from version 2.0.x to version 2.0.5). 

However, a new licence key is required for upgrades between minor version releases (for 

example, from version 2.8.x to 2.9.0). 

NOTE: Upgrading to VibroSight 2.9.0 from any previous version of VibroSight 

requires a new licence key. 

 

To obtain a new VibroSight licence key file or for further information on licence keys, contact 

Meggitt Sensing Systems customer support (see section 6). 

 

2. New features 

General 

2.1. Support for 64-bit Windows operating systems 

Support for the 64-bit versions of Windows ® operating systems has been added to 

VibroSight, as shown in the table below. 

  VibroSight 2.8.1 

(or earlier) 

VibroSight 2.9.0 

Windows 98 

Windows ME 

Windows 2000 

Not supported 

Windows XP 
32-bit (x86) Supported 

Supported 
64-bit (x64) Not supported 

Windows Server 2003 

Windows Server 2008 

32-bit (x86) Supported 
Supported 

64-bit (x64) Not supported 

Windows 7 
32-bit (x86) Supported 

Supported 
64-bit (x64) Not supported 

 

32-bit versions of Windows have a limited memory space (< 4 GB) that must be shared 

between all software running on the computer. 

However, 64-bit Windows can address much more memory and allows separate programs 

running on the computer to use up to 4 GB. When VibroSight runs on 64-bit Windows, the 

individual software modules such as Server and Vision, and SQL Anywhere can all use up to 

4 GB each, which helps to eliminate memory and performance issues that can occur due to 

the limitations of the 32-bit memory space. 
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2.2. Unit preferences 

A separate new window has been added for viewing and editing the unit preferences. To 

access the Unit Preferences window, click Tools > Unit Preferences on the menu bar. 

Previously, the unit preferences were available from the Options window (Tools > Options). 

 

 

 VibroSight Configurator 

2.3. Data logging based on alarm severity levels 

Alarm severity levels can now be added as conditions to the following data logging rules: 

 Time base 

 Value based 

 Step changed. 

 

2.4. Improved support for data aging 

Data aging rules have been extended to include the following data types stored on a 

VibroSight Server: full spectra, orbits, post-processed data spectra and waveforms. 

Previously, the data aging rules were limited to scalar data types only. 

 

2.5. Support for XMV-S16 cards 

Support for the new XMV-S16 card has been added. 

An XMV-S16 card can be added to a configuration by right-clicking on a Vm600 Rack in the 

Hardware view and clicking New XMV-S16 card. 

NOTE: The XMV-S16 card has the same capabilities and features as the XMV16 

card, except that the XMV-S16 card cannot access and therefore cannot 

configure anything on the raw bus. 

Like the XMV16 card, the XMV-S16 card uses the XIO16T input/output card 

to form a card pair. 

 

When configuring a XMV-S16 card using VibroSight Configurator, the Raw Bus Routing 

field in the Dynamic Input Channel parameters window is not available, thereby preventing 

users from internally routing the signal through the raw bus. 
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 VibroSight Server 

2.6. Activating a configuration 

It is no longer necessary to restart VibroSight Server (that is, exit and restart the server) after 

a configuration has been activated, as any changes to the configuration are now 

automatically updated in the server upon activation. 

 

 

 VibroSight Vision 

2.7. Addition of a Mimic menu 

A Mimic menu has been added to the menu bar for easier access to Mimic documents. 

Mimics can still be created by right-clicking on the Project Explorer in VibroSight Vision and 

clicking New > Mimic, as before. 

 

2.8. Simplification of the dual configuration tree 

The tree structure view of the configuration displayed in the Data Pool Explorer has been 

simplified, for both the Hardware view and the Machinery view. 

For example, in the Hardware view, the upper pane shows the hardware (rack, cards and 

processing block) and the lower pane shows the processed outputs and data extractions. 

 

2.9. Simplification of the project wizard 

The New Project Wizard (File > New Project) has been simplified for faster project 

generation. 

Additional project information can still be added to a project by double-clicking on Properties 

in the tree structure view of the Project Explorer and entering data in the Project Properties 

dialog box that appears. 

 

 

 VibroSight Event Viewer 

2.10. Redesign of the Event Details dialog box 

The Event Details dialog box has been redesigned to present the event information more 

clearly. 

The Event Details dialog box for an event is displayed by double-clicking on an event (row) in 

VibroSight Event Viewer. 
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2.11. Pre-loading of historical data when working with live data 

The event filter can be used to pre-load a buffer of historical events when working with live 

data. 

This buffer can be used to load either a fixed number of events or the events from a fixed 

time period. 

 

 

 VibroSight System Manager 

2.12. Copying a database 

It is now possible to copy a database in one of the following two ways: 

 Using System Manager 

 Using a command-line tool. 

2.13. Purging a database 

It is now possible to purge (truncate) a database in one of the following two ways: 

 Using System Manager 

 Using a command-line tool. 

 

2.14. Backing up a database 

It is now possible to back up a database in one of the following two ways: 

 Using System Manager 

 Using a command-line tool. 

 

The introduction of these command-line tools enables a task scheduler (such as Windows 

Task Scheduler) to automate the management of VibroSight databases on your computer. 
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3. Solved problems and bug fixes 

 VibroSight Server 

3.1. Stabilisation and bug fixes 

 Modbus driver (data acquisition) 

 NTP settings 

 Combustion monitoring post-processing. 

 

 

 VibroSight Vision 

3.2. Stabilisation and bug fixes 

 Plots (bode, correlation, orbit, polar, spectrum, waterfall, waveform) 

 Alarm state list 

 Cursors 

 Project on network drives. 

 

 

 VibroSight Event Viewer 

3.3. Stabilisation and bug fixes 

 General. 
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4. Compatibility 

4.1. VibroSight software 

VibroSight 2.9.0 is a minor version release in the 2.x.x series and replaces VibroSight 2.8.x. 

Compatibility with existing databases is achieved using the database  Update tool (from 

VibroSight System Manager’s  Database tools) which supports the continued used of 

configurations and data from previous versions (see section 5.1.1). 

NOTE: Refer also to the latest version of the  VibroSight software data sheet or 

the  Getting started with VibroSight installation guide for further 

information on VibroSight’s compatibility and prerequisites. 

 

4.1.1. Microsoft Windows operating systems 

VibroSight 2.9.0 is now compatible with the 64-bit versions of Microsoft ® Windows ® 

operating systems (as discussed in section 2.1). 

 

4.1.2. Apple Bonjour 

VibroSight uses Apple ® Bonjour to discover and locate network-enabled devices from 

Meggitt Sensing Systems, such as VM600 cards. 

VibroSight 2.9.0 remains compatible with the previously deployed version of Bonjour, namely 

Bonjour version 3.0. 

NOTE: Only Apple Bonjour for Windows version 1.0.106 should be used with 

VibroSight 2.7.x or earlier. 

Only Apple Bonjour for Windows version 3.0 or later should be used with 

VibroSight 2.8.x or later. 

 

4.1.3. Sybase SQL Anywhere software 

VibroSight uses the Sybase ® SQL Anywhere database software in its standard 

configuration. VibroSight 2.9.0 remains compatible with the previously deployed version of 

SQL Anywhere, namely SQL Anywhere version 11.0.1. 

For VibroSight systems that have been installed and running with previous versions, 

upgrading or reinstallation of the database software is not mandatory when upgrading to 

VibroSight 2.9.0. However, if you are still using SQL Anywhere 11.0.0, Meggitt Sensing 

Systems recommends upgrading to version 11.0.1 (see section 5.2). 
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4.2. VibroSight hardware 

There is a firmware (embedded software) update for the VibroSight cards (XMV16 / XIO16T 

and XMC16 / XIO16T card pairs) corresponding to VibroSight 2.9.0. 

The latest firmware for the XMC16 and XMV16 cards is: 

 Applications: applications-640-010-001-003.tgz 

 Base System: base-system-640-003-001-004.tgz. 

Therefore, for earlier versions of the XMC16 or XMV16 cards, a firmware upgrade is 

recommended (see section 5.3). 
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5. Upgrade procedure 

This section describes the procedure for upgrading a VibroSight system from a previous 

version. Perform the steps in the given sequence in order to complete a system upgrade. 

NOTE: It is strongly recommended to verify the version of firmware running in the 

XMV16 / XMC16 cards before starting a VibroSight system upgrade, in 

order to establish if a firmware update is also required (see section 5.3). 

 

5.1. Upgrading the VibroSight software 

1. Exit all VibroSight software modules (clients and servers) – no VibroSight applications 

(such as Vision, Configurator or Server) should be running. 

2. Back up any important (required) VibroSight databases in one of the following ways: 

 Start VibroSight System Manager and use the database  Backup tool from 

VibroSight System Manager’s  Database tools, and follow the instructions 

presented by the Database Backup Wizard. 

 NOTE: It is necessary to be logged in to System Manager as ‘Admin’ in order to 

have the user rights to access the database tools: 

Select your  VibroSight Host (computer) in the System Explorer tree 

structure and click  Login (from VibroSight System Manager’s 

 Access Rights tools). 

 NOTE: Refer also to the Backing up a database topic in the  VibroSight help. 

 

 Create an archive file (for example, *.zip) containing the three files (*.config, 

*.db, *.log) in the directory where your database files are located. 

 NOTE: The default data (data path) directory is C:\VibroSight Data 

 

3. Make backup copies of any important (required) VibroSight Vision projects in the 

following way: 

 Create an archive file (for example, *.zip) containing all of the files (*.xml, *. 

xmsproj) in the directory where your project files are located. 

 NOTE: The default project directory is: 

C:\Documents and settings\username\My Documents 

\VibroSight\Projects 
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4.  Remove the currently installed version of the VibroSight software using Windows Add 

or Remove Programs, in one of the following ways: 

 Click Start > Settings > Control Panel and then double-click Add or Remove 

Programs. 

 Or click Start, click Control Panel and then double-click Add or Remove 

Programs. 

And remove  VibroSight Standard Edition. 

5. Install the latest version of the VibroSight software by inserting the VibroSight CD into 

the CD/DVD drive of the computer and follow the instructions presented by the 

VibroSight installation wizard. 

NOTE: Refer to the  Getting started with VibroSight installation guide for 
information on installing the VibroSight software. 

 

6. Restart VibroSight Server and ensure that the required communications are enabled. 

For example, select the XMC16 / XMV16 card driver for communications with XMC16 

and XMV16 cards, the OPC device driver for systems using OPC and so on:  

 For example, click Data > Acquisition > XMC16/XMV16 Card Driver Panel, click 

Data > Acquisition > OPC Device Driver and so on. 

7. Restart VibroSight Vision and ensure that live data is received from the cards and 

displayed in Vision. 

8. The VibroSight system should now be up and running. 

 

5.1.1. Updating the internal structure of a VibroSight database 

When VibroSight Server is started, it checks the status of the database and will automatically 

inform the user if any internal structures of the database need to be updated before 

proceeding. 

1. Update a VibroSight database in the following way: 

 Start VibroSight System Manager and use the database  Update tool from 

VibroSight System Manager’s  Database tools, and follow the instructions 

presented by the Database Update Wizard. 

 

 NOTE: It is necessary to be logged in to System Manager as ‘Admin’ in order to 

have the user rights to access the database tools: 

Select your  VibroSight Host (computer) in the System Explorer tree 

structure and click  Login (from VibroSight System Manager’s 

 Access Rights tools). 
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 NOTE: Refer also to the Updating a database topic in the  VibroSight help. 

 

 

5.2. Upgrading the SQL Anywhere software 

VibroSight software is compatible (and extensively tested) with SQL Anywhere versions 

11.0.0 and 11.0.1. 

However, there are two known issues (an exception when loading historical data and the 

database update tool not working correctly) which might occur in isolated (rare) 

circumstances. The correction for these issues is available in SQL Anywhere 11.0.1.2044. 

Therefore, it is recommended to upgrade all VibroSight systems to this version of SQL 

Anywhere. 

 

Determine the version of the SQL Anywhere database engine installed on a computer in the 

following way: 

1. From the Start menu, click Start > All Programs > SQL Anywhere 11 > 

Sybase Central. 

The Sybase Central window appears. Sybase Central is a GUI-based management 

tool for Sybase products. 

2. Click Help > About Sybase Central. 

The About Sybase Central windows appears, displaying the version information for 

SQL Anywhere (and any other installed Sybase products). 

 NOTE: Refer also to the Determining the version of SQL Anywhere installed on a 

computer topic in the  VibroSight help. 

 

Upgrade the SQL Anywhere 11 software by first removing the existing version of 

SQL Anywhere and then installing the new version, as follows: 

WARNING: Do not use the SQL Anywhere 11.0.1 setup to upgrade directly to software 

version 11.0.1 from software version 11.0.0. Instead, it is recommended to 

upgrade the Sybase database software as follows: 

1. Remove SQL Anywhere 11.0.0, using the Windows Add or Remove 

Programs tool. 

2. Install SQL Anywhere 11.0.1, using the Sybase SQL Anywhere 11.0.1 

CD. 

Refer also to the  Getting started with VibroSight installation guide for 

information on installing the Sybase software. 
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1. Exit all VibroSight software modules (clients and servers) – no VibroSight applications 

(such as Vision, Configurator or Server) should be running – as this also stops the 

SQL Anywhere database engine. 

The  lightning icon that appears in the notification area (at the far right of the task 

bar) to indicate that a Sybase database engine is running should no longer be shown. 

2. Remove the currently installed version of Sybase SQL Anywhere using Windows Add 

or Remove Programs, in one of the following ways: 

 Click Start > Settings > Control Panel, then double-click Add or Remove 

Programs 

 Or click Start, click Control Panel and then double-click Add or Remove 

Programs. 

And remove  SQL Anywhere 11. 

3. Restart the computer. 

4. Install Sybase SQL Anywhere VibroSight 11.0.1.2044 by inserting the Sybase CD into 

the CD drive of the computer and follow the instructions presented by the 

SQL Anywhere 11 installation wizard. 

5. Restart the computer. 

Without this final computer restart, VibroSight Server may not be able to start the 

SQL Anywhere database engine. 

 

 

5.3. Updating the VibroSight hardware – XMC16 and XMV16 card firmware 

Appropriate files and tools are included in the installation package to allow VibroSight cards 

to be updated to the latest standard, in order to take advantage of improvements to the 

VibroSight software. 

The latest firmware files are copied to a directory on your computer as part of the VibroSight 

installation process. 

NOTE: The default firmware directory is: 

C:\Program Files\Meggitt\VibroSight 2\Firmware\XMC16 

 

The firmware files for any VM600 card can be identified by their .tgz file name extension. Any 

additional firmware updates received from Meggitt Sensing Systems should also be stored in 

this directory. 

NOTE: The XMC16 directory contains the applications and base system firmware 

for use by XMC16, XMV16 and XMV-S16 cards. 
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The table below shows the compatibility between VibroSight software and hardware (that is, 

XMC16 / XMV16 card pair firmware). 

 

 VibroSight card firmware 

VibroSight client-

server software 

(VibroSight version 

CD part number) 

applications-

640-004-001-

003.tgz 

base-system-

640-003-001-

001.tgz 

applications-

640-010-001-

001.tgz 

base-system-

640-003-001-

002.tgz 

applications-

640-010-001-

002.tgz 

base-system-

640-003-001-

003.tgz 

applications-

640-010-001-

003.tgz 

base-system-

640-003-001-

004.tgz 

1.0.0 

609-004-000-001 
✓ ✗ ✗ ✗ 

2.0.0 

609-004-000-003 
✗ ✓ ✗ ✗ 

2.0.5 

609-004-000-004 
✗ ✓ ✗ ✗ 

2.0.6 

609-004-000-005 
✗ ✓ ✗ ✗ 

2.5.0 

609-004-000-006 
✗ ✓ ✗ ✗ 

2.7.5 

609-004-000-008 
✗ ✓ ✓ ✗ 

2.8.0 

609-004-000-007 
✗ ✓ ✓ ✗ 

2.9.0 

609-004-000-010 
✗ ✗ ✗ ✓ 
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When performing VibroSight software upgrades, it is strongly recommended to systematically 

upgrade the firmware of XMV16 / XMC16 cards to the latest compatible version. 

Failure to perform a necessary VibroSight card firmware update may lead to incoherent 

system behaviour and affect the proper functioning of data acquisition in a system. It is only 

in systems where the firmware running on the XMV16 / XMC16 cards already corresponds to 

the latest available version that no firmware update is required. Therefore, it is strongly 

recommended to verify the version of firmware running on the cards before starting a 

VibroSight system upgrade (see section 5.1), in order to establish if a firmware update is also 

required. 

 

WARNING: Changing the firmware of a VibroSight card is a special administrative task 

that can – if performed unintentionally – affect the proper functioning of data 

acquisition in a system. 

It is therefore strongly recommended to change the firmware of VibroSight 

cards (XMV16 / XMC16) only when it is necessary. For example, when the 

cards must be updated to be compatible with a VibroSight software 

upgrade. 

 

Update the firmware on a VibroSight card using the  Change Firmware tool (from 

VibroSight System Manager’s Maintenance tools): 

1. Ensure that the computer running the VibroSight software is on the same network as 

the VM600 rack(s) containing the VibroSight cards. 

2. Start VibroSight System Manager and navigate to the Devices tree structure in the 

System Explorer window. 

The Devices tree lists all of the cards that VibroSight can see on the network. If there 

are no cards in the tree structure or some cards are missing, please verify your network 

connections. 

3. Select the  card that requires its firmware to be changed. 

The Actions tool window updates to show the available card options. 

4. Click  Change Firmware in the Maintenance tools group of the Actions window. 

The Change Firmware dialog box appears. 

5. Click the Add button and select the new firmware files (*.tgz) for the card. 

 NOTE: On a Windows XP computer, the default directory for the VibroSight card 

firmware is: 

C:\Program Files\Meggitt\VibroSight 2\Firmware 
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6. Click the Finish button to start the firmware upgrade process. 

The firmware upgrade process can take up to 5 minutes per card, during which: 

 The IP address beside the card’s serial number in the Devices tree structure 

disappears. 

 The STATUS LED on the card becomes orange, while intermittently, there will be 

some short phases where the LED turns red and blinks. 

Once the upgrade process has finished:  

 The IP address is reappears in the Devices tree structure. 

 The STATUS LED on the card becomes green again. 

7. Repeat steps 3 to 6 for each card that requires a firmware update.  

 NOTE: Although the firmware for each VibroSight card must be changed 

individually using the  Change Firmware tool, as each card updates 

its firmware independently of the VibroSight software (once the process 

has started), firmware updates can be performed on several cards in 

parallel. 

 

8. After the firmware upgrade, verify that the VibroSight system is acquiring data from the 

cards. 

 

NOTE: Refer also to the Changing the firmware topic in the  VibroSight help. 

 

The  Change Firmware tool can be used to load a VibroSight card with any version of 

card firmware. It is therefore possible to change a card’s firmware to any previously available 

version, as well as the latest update. 

This feature can be useful in certain situations, for example, swapping spare VibroSight 

cards between different racks, when the racks are operating with different versions of 

VibroSight. 
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6. Customer support 

6.1. Contacting us 

Meggitt Sensing Systems’ worldwide customer support network offers a range of support 

including Technical support and Sales and repairs support. For customer support, please 

contact your local Meggitt Sensing Systems representative. Alternatively, contact our main 

office: 

Customer support 

Meggitt SA 

Route de Moncor 4 

PO Box 1616 

CH-1701 Fribourg 

Switzerland 

 

Telephone: +41 (0) 26 407 11 11 

Email: energysupport@ch.meggitt.com 

Web: www.meggittsensingsystems.com 

 

6.2. Technical support 

Meggitt Sensing Systems’ technical support team provide both pre-sales and post-sales 

technical support, including: 

 General advice 

 Technical advice 

 Troubleshooting 

 Site visits. 

 

6.3. Sales and repairs support 

Meggitt Sensing Systems’ sales team provide both pre-sales and post-sales support, 

including advice on: 

 New products 

 Spare parts 

 Repairs. 

 

mailto:energysupport@ch.meggitt.com
http://www.meggittsensingsystems.com/

