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IMPORTANT NOTICE 

All statements, technical information and recommendations in this document which relate to the 

products supplied by Meggitt Sensing Systems are based on information believed to be reliable, but 

unless otherwise expressly agreed in writing with Meggitt SA, the accuracy or completeness of such 

data is not guaranteed. Before using this product, you must evaluate it and determine if it is suitable 

for your intended application. Unless otherwise expressly agreed in writing with Meggitt SA, you 

assume all risks and liability associated with such use. Meggitt Sensing Systems takes no 

responsibility for any statements related to the product which are not contained in a current English 

language Meggitt Sensing Systems publication, nor for any statements contained in extracts, 

summaries, translations or any other documents not authored and produced by Meggitt Sensing 

Systems. 
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PREFACE 

 

About these release notes 

This document provides important information about the VibroSight ® software from Meggitt Sensing 

Systems. It is applicable to all VibroSight-based condition monitoring and machinery protection 

systems using the versions of software described by this document, namely: 

 VibroSight software version 3.1.0 (CD part number 609-004-000-038). 

This document contains information about changes to the software since the previously released 

version (VibroSight 3.0.0), such as new features and improvements, solved problems and bug fixes, 

and hardware and software compatibility. 

For more general information on the actual software, or the entire condition monitoring system (CMS), 

refer to the following Meggitt Sensing Systems (MSS) documentation: 

 VibroSight software data sheet 

        (MSS document ref. 660-020-005-218A) 

 Getting started with VibroSight installation guide 

        (MSS document ref. 660-010-006-218A) 

 VibroSight help 

 XMV16 / XIO16T extended vibration monitoring card pair data sheet 

        (MSS document ref. 660-020-010-208A) 

 VibroSight application notes and technical notes. 

 

Users who are familiar with VibroSight may also find it useful to refer to the release notes included in 

earlier versions of the software: 

 VibroSight 2.9.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.1 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.2 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.4 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.5 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.6 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.7 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.1 (MSS document ref. 660-010-013-201A) 

 VibroSight 2.11.0 (MSS document ref. 660-010-013-203A) 

 VibroSight 2.11.1 (MSS document ref. 660-010-013-204A) 

 VibroSight 2.11.2 (MSS document ref. 660-010-013-205A) 
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 VibroSight 2.11.3 (MSS document ref. 660-010-013-206A) 

 VibroSight 2.11.4 (MSS document ref. 660-010-013-207A) 

 VibroSight 2.11.5 (MSS document ref. 660-010-013-208A) 

 VibroSight 2.11.6 (MSS document ref. 660-010-013-209A) 

 VibroSight 2.12.0 (MSS document ref. 660-010-013-210A) 

 VibroSight 2.12.1 (MSS document ref. 660-010-013-211A) 

 VibroSight 2.12.2 (MSS document ref. 660-010-013-212A) 

 VibroSight 2.12.3 (MSS document ref. 660-010-013-213A) 

 VibroSight 2.12.4 (MSS document ref. 660-010-013-214A) 

 VibroSight 2.12.5 (MSS document ref. 660-010-013-215A) 

 VibroSight 2.12.6 (MSS document ref. 660-010-013-216A) 

 VibroSight 2.12.7 (MSS document ref. 660-010-013-217A) 

 VibroSight 3.0.0 (MSS document ref. 660-010-013-218A). 

 

Structure of the release notes 

This document presents information in the following order: general items first, then in terms of the 

software modules that constitute VibroSight, such as  Configurator,  Event Viewer,  Mimic, 

 Scope,  Server,  System Manager and  Vision. 

You should read those sections that are most relevant to you and then keep the document for future 

reference. 

 

Version identifiers 

A complete VibroSight software version number has four components that provide the following 

information: 

 Major release identifier: x.x.x.x 

 Minor release identifier: x.x.x.x 

 Update release identifier: x.x.x.x 

 Maintenance (build) release identifier: x.x.x.x 

For each scheduled release of VibroSight, at least one of the first three digits changes (x.x.x.x). 

For unscheduled releases, that are occasionally required to solve urgent problems, only the fourth 

digit changes (x.x.x.x). 

The version identifiers for installed software appear in the Help About box (obtained using 

Help > About … in any VibroSight software module). 
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Terminology 

To distinguish between the different Meggitt Sensing System products that can be used with the 

VibroSight software, the following terminology is used in this document: 

 VM600 card – to refer to the VibroSight-software compatible cards that are installed in a VM600 

rack. The currently available VM600 cards that are designed for operation with the VibroSight 

software are the XMx16 card pairs (XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T) and the new CPUR/IOCR card pair. 

Where CPUx card is used in this document, it refers to CPUM and CPUR cards, and where 

IOCx card is used in this document, it refers to IOCN and IOCR cards, unless otherwise stated. 

Where XMx16 card is used in this document, it refers to XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T cards, unless otherwise stated. 

 VibroSmart module or VibroSmart device – to refer to VibroSight-software compatible modules 

or devices that are used in a distributed monitoring system. The currently available VibroSmart 

modules and devices that are designed for operation with the VibroSight software are the 

VSI010, VSN010 and VSV300. 

Where VibroSmart module is used in this document, it refers to the VSI010 and VSV300 

modules, unless otherwise stated. 

Where VibroSmart device is used in this document, it can refer to the VSN010 device only, or to 

the VSI010 and VSV300 modules and the VSN010 device, unless otherwise stated. 
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1 Licensing 

In general, the licence required to enable purchased product options remains unchanged between 

update and/or maintenance level releases, for example, from version 2.12.6 to version 2.12.7. 

However, a new licence is always required for upgrades between major level releases, for example, 

from version 2.x.x to version 3.x.x. 

NOTE: VibroSight 3.1.0 is a minor level release and a new licence key file is not required 

for upgrades from VibroSight 3.0.0. 

However, a new licence key file is required for upgrades from VibroSight 2.x.x. 

 

To obtain a new VibroSight licence key file or for further information on licence keys, contact Meggitt 

Sensing Systems customer support. See 7 Customer support. 

 

 

2 Features 

 VibroSight Configurator 

2.1 Option to use a 2-byte data format for dynamic data logging 

VibroSight Configurator has been updated to include an option that can be used to configure a 

VibroSight Server to use a 2-byte data format for all dynamic data logging instead of the default 4-byte 

data format. 

By default, a VibroSight Server uses a 4-byte data format for all dynamic measurement data such as 

waveforms, spectra and orbits in order to maximise the dynamic range of the measurements. 

However, using 2 bytes for each measurement point can significantly reduce the size of the required 

VibroSight data repository (*.vshdf) and reduce disk drive usage, at the expense of the dynamic 

range of the measurement data. 

In a VibroSight Configurator, at the top-level (“root node”) of a VibroSight Server Configuration, the 

configurable parameters now includes a Use 2 bytes format for dynamic data logging control: 

 When the Use 2 bytes format for dynamic data logging control check box is cleared, the 

VibroSight Server will use a 4-byte data format to log all dynamic data (this is the default 

behaviour). 

 When the Use 2 bytes format for dynamic data logging control check box is selected, the 

VibroSight Server will use a 2-byte data format to log all dynamic data. 
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NOTE: Alternatively, the Data Repositories Copy command in VibroSight System Manager 

can be used to perform data reduction when copying a VibroSight data repository 

(*.vshdf or *.vssrvdb) to a VibroSight historical data archive (*.vshda): 

• The Perform data reduction (for variables only) control can be used to copy 

the Minimum value and/or the Maximum value and/or the First value for the time 

period specified. 

Note: This data reduction option affects affect static measurement data (such as 

variables) only. 

• The Use 2 bytes format for dynamic data control can be used to reduce the 

size of the copied data repository. 

Note: This data reduction option affects affect dynamic measurement data (such as 

waveforms, spectra and orbits) only. 

 

 

2.2 Configuration information displayed by VibroSight Configurator 

VibroSight Configurator has been updated to display information about the currently open 

configuration on the status bar of the VibroSight Configurator user interface. 

 

When working with a VibroSight Server configuration from a VibroSight Server (*.vshdf): 

 The VibroSight Configurator status bar (bottom) uses Configuration Revision to display 

information about the configuration that is open in VibroSight Configurator, in the following format: 

Configuration Revision : Rn (Saved dd.mm.yyyy hh:mm:ss), 

where Rn is the revision (version) of the configuration (starting from 0) that is open in VibroSight 

Configurator, and dd.mm.yyyy and hh.mm.ss give the date and time of when this configuration 

was last changed and saved in VibroSight Configurator. 

 The VibroSight Configurator status bar (bottom) uses Running Revision to display information 

about the configuration that is running on the associated VibroSight Server, in the following format: 

Running Revision : Rn (Activated dd.mm.yyyy hh:mm:ss), 

where Rn is the revision (version) of the configuration (starting from 0) that is running in VibroSight 

Server, and dd.mm.yyyy and hh.mm.ss give the date and time of when this configuration was last 

activated on the VibroSight Server. 

 

For example: 

When a new VibroSight Server configuration is created and saved as a file, no configuration 

information is displayed on the VibroSight Configurator status bar. 

When a VibroSight Server configuration is saved as a VibroSight Server (*.vshdf), using 

File > Save as > Server / Database, updated configuration information is displayed on the status bar. 

For example, Configuration Revision : R0 (Saved 13.02.2017 16:20:00) 

and Running Revision : None. 
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When the VibroSight Server configuration is activated on the VibroSight Server (*.vshdf), using the 

Activate toolbar button, updated configuration information is displayed on the status bar. 

For example, Configuration Revision : R0 (Saved 13.02.2017 16:22:00) 

and Running Revision : R0 (Saved 13.02.2017 16:22:00). 

If the VibroSight Server configuration is subsequently edited and saved in VibroSight Configurator, 

using File > Save, updated configuration information is displayed on the status bar. 

For example, Configuration Revision : R1 (Saved 13.02.2017 16:25:00) 

and Running Revision : R0 (Saved 13.02.2017 16:22:00). 

Note: This indicates that VibroSight Configurator must be used to activate the configuration in order to 

apply the changes made to the configuration on the VibroSight Server. 

 

Similarly, when a VibroSight Server configuration is opened from a VibroSight Server (*.vshdf), 

using File > Open > Server / Database, updated configuration information is displayed on the status 

bar. For example, 

Configuration Revision : R3 (Saved 14.02.2017 09:00:00) and 

Running Revision : R3 (Saved 14.02.2017 09:00:00) for a VibroSight Server with a configuration that 

is activated, or Configuration Revision : R3 (Saved 14.02.2017 09:00:00) and 

Running Revision : None for a for a VibroSight Server with a configuration that is not activated. 

Note: The first example here indicates that there are no differences between the configuration open in 

VibroSight Configurator and the configuration running on the VibroSight Server. The second example 

here indicates that the VibroSight Server has no active configuration and VibroSight Configurator must 

be used to activate the configuration in order for the VibroSight Server to start handling and logging 

data. 

 

In addition, when a VibroSight Server configuration is opened from a VibroSight historical data archive 

file (*.vshda), using File > Open > Historical data archive, updated configuration information is 

displayed on the status bar. For example, 

Revision : R1 (Saved 24.11.2016 08:30:00). 

Note: This reduced configuration information simply indicates the revision of the configuration used by 

the VibroSight historical data archive. 

Finally, when a VibroSight Server configuration is opened directly from a VibroSight device, using 

File > Open > Device, no configuration information is displayed on the status bar, as such 

configuration information depends on a VibroSight Server being available, which is not the case for 

configurations that are activated directly on devices. 

See also 2.3 Configuration information displayed by VibroSight Server. 
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 VibroSight Server 

2.3 Configuration information displayed by VibroSight Server 

VibroSight Server has been updated to display information about the configuration activated on the 

VibroSight Server on the Status tab of its user interface. 

 

The VibroSight Server Status tab has a general information area (upper left) that uses 

Config. Revision to display information about the active configuration on the VibroSight Server, in the 

following format: 

Config. Revision : Rn (dd.mm.yyyy hh:mm:ss), 

where Rn is the revision (version) of the configuration (starting from 0) that is active on the VibroSight 

Server, and dd.mm.yyyy and hh.mm.ss give the date and time of when this configuration was 

activated on the VibroSight Server using VibroSight Configurator. 

 

For example: 

When a VibroSight Server configuration is saved as a VibroSight Server (*.vshdf), using 

File > Save as > Server / Database, after the VibroSight Server is automatically created and started, 

configuration information is displayed in the general information area. 

For example, Config. Revision : No active configuration. 

Note: No active configuration indicates that there is no active configuration running on the 

VibroSight Server. 

 

When the VibroSight Server configuration is activated on the VibroSight Server (*.vshdf), using the 

Activate toolbar button, updated configuration information is displayed in the general information area. 

For example, Config. Revision : R0 (13.02.2017 16:22:00). 

If the VibroSight Server configuration is subsequently edited and saved in VibroSight Configurator, 

using File > Save, updated configuration information is displayed on the status bar in VibroSight 

Configurator. However, the configuration information displayed by the VibroSight Serve will not be the 

same until VibroSight Configurator is used to activate the configuration in order to apply the changes 

made to the configuration on the VibroSight Server. 

See also 2.2 Configuration information displayed by VibroSight Configurator. 

 

 

2.4 VibroSight Server user interface Data management tab 

The VibroSight Server user interface has been updated to include a Data management tab that 

displays information about the VibroSight System Manager Data Repositories Copy and Purge 

commands that have accessed the data repository being used by the VibroSight Server (that is, the 

VibroSight historical data folder (*.vshdf)). 

The new Data management tab is displayed as a separate tabbed document after the Status and 

Log messages tabs. 
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Data management tab 

As shown in Figure 1, the Data management tab consists of a list of information for each Data 

Repositories Copy command or Purge command that was run on the data repository, with controls for 

clearing or exporting the information that is displayed. 

 

Figure 1: VibroSight Server user interface – Data management tab 

 

The list of information displayed provides detailed information on the VibroSight System Manager Data 

Repositories Copy and Purge commands (or command-line equivalents) that have accessed the data 

repository. 

Each row corresponds to a particular Data Repositories Copy command or Purge command (or 

command-line equivalents): 

 The Enqueued since column displays the time when the command was received by the 

VibroSight Server. 

 The Execution start column displays the time when the command was run (started) by the 

VibroSight Server. 

 The Execution duration column displays how long the command took to run on the VibroSight 

Server. 

 The Type column displays the type of the command: Copy or Purge. 
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 The Status column displays the status of the command (job): 

o Not queued – The command has been created on the VibroSight Server and will be added 

to the list (queue). This status has a very brief duration and probably won’t be seen. 

o Queued – The command is in the list (queue) and will run when earlier commands are 

finished. 

o Running – The command is running. 

o Finished – The command is finished running and was successfully completed. 

o Error – The command is finished running but was not successfully completed. 

Note: If an error is displayed, the Log messages tab of the VibroSight Server user 

interface can be referred to for additional information. 

o Cancelled – The command was cancelled by the user. 

o Thrashed – The command was dropped from the list (queue). 

Note: The maximum number of commands (jobs) that can be queued is 30. If more than 

30 commands are added to the list (queue), the earlier commands are automatically 

dropped (thrashed) to make space for the later commands. 

 The Range from and Range to columns display the time range of the data affected by the 

command: 

o For a Copy command, the Range from and Range to columns display the time range of 

the data copied to the new data repository. 

Note: If a Copy command is configured to copy All data, the data is always copied starting 

from 01.01.0001 00:00:00 so the Range from column is simply left blank. 

o For a Purge command, the Range from and Range to columns display the time range of 

the data purged from the existing data repository. 

 The Additional information column displays any additional information about the operation of the 

command. 

For example, the location and file name of the data repository affected by the command are 

typically displayed. In addition, incremental copy number information is also displayed for a Copy 

command using incremental copies. 

 

Under the list of information displayed, the Clear all button can be used to clear (delete) all of the 

currently displayed information. 

Under the list of information displayed, the Export button can be used to export all of the currently 

displayed information to a CSV file. 

 

Like the Status and Log messages tabs, the information displayed on the new Data management 

tab does not persist. That is, when a VibroSight Server is closed/exited (File > Quit), the information is 

lost. 
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 VibroSight System Manager 

2.5 Data repositories Copy command 

The Data Repositories Copy command and its command-line equivalent have been updated to more 

fully support the VibroSight historical data repositories (VibroSight historical data folders (*.vshdf) 

and VibroSight historical data archives (*.vsdha)) introduced in VibroSight 3.0.0. 

The VibroSight System Manager Copy command can now be used to selectively: 

 Copy data in any VibroSight historical data folder (*.vshdf) to a VibroSight historical data archive 

(*.vshda). 

 Copy data in a running VibroSight historical data folder (*.vshdf) to a VibroSight historical data 

archive (*.vshda) using incremental copies. 

 Copy data in a VibroSight database (*.vssrvdb) to a VibroSight historical data archive 

(*.vshda) or to a VibroSight historical data folder (*.vshdf). 

(Previously, it was not possible to copy data to a VibroSight historical data folder (*.vshdf).) 

 

As a result of this improvement, existing machinery monitoring projects created with versions of 

VibroSight earlier than VibroSight 3.0.0 can now be migrated directly from a VibroSight database to a 

VibroSight historical data folder by copying the VibroSight database (*.vssrvdb) to a VibroSight 

historical data folder (*.vshdf) in VibroSight System Manager. 

(Previously, it was only possible to migrate from a VibroSight database to a VibroSight historical data 

folder by (1) copying the VibroSight database (*.vssrvdb) to a VibroSight historical data archive 

(*.vshda) in VibroSight System Manager, then (2) opening and saving the VibroSight historical data 

archive (*.vshda) as a new server/database (*.vshdf) in VibroSight Configurator.) 

 

Importantly, projects migrated directly to a VibroSight historical data folder (*.vshdf) in this way allow 

continuity of data in VibroSight Vision and VibroSight Mimic: 

 In VibroSight Vision – all of the historical data is available from the same data repository. 

That is, the existing data from the VibroSight database (*.vssrvdb) is migrated to and becomes 

available from the new VibroSight historical data folder (*.vshdf). 

(Previously, the new data repository had to be created by copying the VibroSight database to a 

VibroSight historical data archive and then opening and saving the VibroSight historical data 

archive as a new server/ database (*.vshdf), with the result that the new data repository did not 

contain any existing data.) 

 In VibroSight Mimic – the links between the Mimic objects (controls and indicators) and the data 

repository are maintained. 

That is, if the existing VibroSight database (*.vssrvdb) and the new VibroSight historical data 

folder (*.vshdf) have the same server file name, existing VibroSight Mimics will work with the 

new data repository. 

(Previously, the new data repository had to be created by copying the VibroSight database to a 

VibroSight historical data archive and then opening and saving the VibroSight historical data 

archive as a new server/ database (*.vshdf), with the result that the links between the Mimic 

objects (controls and indicators) and the new data repository were not maintained and had to be 

corrected manually). 
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NOTE: When updating existing machinery monitoring projects created with 

VibroSight 2.12.x to VibroSight 3.1.0, a new data repository created by copying a 

VibroSight database (*.vssrvdb) to a VibroSight historical data folder (*.vshdf) 

must use the same server file name as the existing server in order for existing 

VibroSight Mimics to maintain links with the data repository and continue to work 

(without manual corrections). 

In addition, the VibroSight Server using the new the new data repository must be 

running before the existing VibroSight Mimics are run for the first time, after the 

update. 

 

NOTE: Because of the changes to the VibroSight System Manager Data Repositories 

Copy command, it is highly recommended that any existing data management and 

system backup procedures for a VibroSight machinery monitoring system are 

checked and modified as necessary in order to ensure that they continue to work 

correctly with VibroSight 3.1.0. 

Typically, such VibroSight data management procedures include batch files using 

the vibrosightdatacopy.exe, vibrosightextractsummary.exe and/or 

vibrosightdatapurge.exe commands with command-line options that are run 

by Windows Task Scheduler. 

 

 

As a special case, data can be copied from a running VibroSight historical data folder (*.vshdf) to a 

VibroSight historical data archive (*.vshda) using incremental copies so that that future data is also 

copied, which allows the size of the copied data repository to be larger than the size of the “active” 

data repository in order to improve overall system performance. 

NOTE: Copying a running VibroSight historical data folder (*.vshdf) incrementally allows 

the copied VibroSight historical data archive (*.vshda) to be larger than the 

“active” data repository being used by the VibroSight Server. 

This is possible as incremental copies include the planned/scheduled copying of 

regular blocks (time periods) of future data. (In contrast, non-incremental copies 

copy a block (time period) of existing data only.) 

Reducing the required size of a VibroSight historical data folder (*.vshdf) in this 

way optimises the storage and retrieval of data (disk cache access) and improves 

overall system performance. 

 

To copy a running historical data folder incrementally: 

 Run the VibroSight System Manager Data repositories Copy command as usual. 

 When prompted to Select the time range you want to copy data from, the Last or This controls 

can be used to specify the data to be copied using a relative time range, or the From and To 

controls can be used to specify data to be copied using an absolute time range. 

 Select the Incremental copy control and use the Period control to be configure the incremental 

time period to use to copy the data, including future data (in minutes or hours). 
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VibroSight automatically calculates, schedules and runs the number of Copy commands using 

incremental copies that are required for the specified time range. 

 Configure the other Copy command parameters as usual. 

When configuration of the Copy command is finished, VibroSight System Manger immediately runs 

the copy commands for the existing data and schedules the copy commands for the future data. 

When all of the copy commands using incremental copies have finished running, the VibroSight 

historical data archive (*.vshda) becomes available. Alternatively, if the the copy commands using 

incremental copies are cancelled, the partial VibroSight historical data archive (*.vshda) can be 

saved. 

See also 2.4 VibroSight Server user interface Data management tab. 

 

 

 VibroSight Vision 

2.6 Projects and data sources 

When VibroSight Vision opens an existing project, it now loads the project-related information before 

connecting to the data source. 

(Previously, VibroSight Vision always attempted to connect to the data source first, which could 

introduce a timeout delay of 15 s if the data source was not available.) 

 

2.7 Machinery view and Hardware view search bar 

The search bar at the top of the Machinery View and Hardware View windows now retains focus after 

a search item is deleted. 

(Previously, this search bar would lose focus after a search item was deleted, which required that the 

search bar was clicked again before another search term could be entered.) 
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Hydro air-gap monitoring 

2.8 Air-gap measuring systems with current loop outputs 

To use the Hydro air-gap monitoring package, VibroSight Configurator is used to configure VM600 

XMV16 and XMVS16 monitoring cards for the measurement chain being used, such as the LS 12x 

and ILS 73x air-gap measuring systems from Meggitt Sensing Systems Vibro-Meter® product line. 

When using a LS 12x and ILS 73x air-gap measuring system, the dynamic input channels of VM600 

XMV16 and XMVS16 cards can now be configured to use the current loop output (4 to 20 mA) from an 

ILS 73x by setting the dynamic input channel parameters, as follows: 

Physical quantity: Airgap 

Input range (AC+DC): 50 mA 

Signal transmission mode: Current 

Coupling: AC+DC 

Sensitivity: Depending on the application 

Offset: Depending on the application. 

When configured for a current input signal, the VibroSight software now always uses the maximum 

current loop signal value of 20 mA to calculate the signal thresholds for pole detection. 

(Previously, the VibroSight software used the configured Input range (AC+DC) value of 50 or 

100 mA, so the signal thresholds for pole detection were not correct for current loop output 

(4 to 20 mA) signals.) 

 

2.9 Pole numbering 

VibroSight implements the Hydro air-gap monitoring package at the VibroSight Server level, that is, it 

is post-processing performed by the VibroSight Server on the principal mode waveforms received from 

the Dynamic Processing Blocks. 

When using hydro air-gap monitoring, in the Hardware view, at the VibroSight Server node level, an 

Air-Gap Processing Block is used to configure the hydro machine parameters, including pole 

numbering, as follows: 

Poles: The number of poles on the rotor of the machine. 

(Pole pairs is updated automatically depending on the poles.) 

Line frequency: The utility (mains power line) frequency of the machine. 

(Nominal speed is updated automatically depending on the poles and line frequency.) 

Nominal airgap: The typical expected distance between the rotor and stator that will be used as a 

reference value. 

Numbering direction: The individual rotor poles are automatically numbered – after the 1/rev pulse – 

starting from 1 and increasing in the configured direction: Counter-clockwise or Clockwise (counter-

clockwise is the default). Note: The direction is decided viewing the machine from above and 

independently of the direction of rotation of the machine. 

Angle notch: By default, the 1/rev pulse produced by the timing reference mark (notch) on the rotor 

shaft is located halfway between the first and the last poles. This parameter can be changed if a 

different pole numbering scheme is required. 

(Previously, the VibroSight software always used Numbering direction: Counter-clockwise, so the 

pole numbering direction was not configurable (that is, pole numbering was fixed).) 
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2.10 Max gap related measurements 

In addition to the existing measurements calculated by the Hydro air-gap monitoring package, 

Max gap related measurements are now also available, as follows: 

Measurements from individual (stator) transducers: 

 Rotor shape  Rotor signature 

 Gap Pn  Min gap 

 Max gap  Average gap 

 Rotor eccentricity  Rotor ellipticity 

 Rotor circularity.  

Measurements available individual (generator) layers: 

 Layer rotor signature  Layer gap Pn 

 Layer min gap  Layer max gap 

 Layer avg gap  Layer rotor eccentricity 

 Layer rotor ellipticity  Layer rotor circularity 

 Layer stator shape  Layer stator eccentricity 

 Layer stator ellipticity  Layer stator circularity. 

 

2.11 Long Waveform plot for rotor shapes and rotor signatures 

In VibroSight Vision, the Long Waveform plot can now be used to display rotor shapes and rotor 

signatures in order to provide an additional way to display and analyse these measurements from the 

Hydro air-gap monitoring package. 

Basically, the Long Waveform plot joins together all of the individual rotor shapes or rotor signatures 

available for an individual (stator) transducer or individual (generator) layer in order to display them as 

a continuous long-duration waveform. 

NOTE: The Long Waveform plot displays a single long waveform against time for the 

selected Time Range. The single long waveform consists of all of the individual 

waveforms for the selected Time Range, joined together. 

In contrast, the Waveform plot displays a series of individual waveforms against 

time for the selected Time Range. The individual waveforms display either 0 to 8 

revolutions of the measurement or the whole acquired waveform, depending on the 

plot properties. 

 

To add a Long Waveform plot, either: 

 Click the  Long Waveform plot icon on the VibroSight Vision toolbar. 

 Use the File > Add new plot > Long Waveform plot VibroSight Vision menu command. 
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 Use the Add new plot > Long Waveform plot command in the VibroSight Vision Project Explorer 

tool window and (right-click on a View and use the shortcut menu that appears). 

 

To add measurement data to a Long Waveform plot: 

 Select a rotor shape or a rotor signature measurement in the Hardware view or Machinery view 

and drag it to the Long Waveform plot. (A Time Range must also be selected before VibroSight 

Vision can display a plot.) 

NOTE: Currently, the Long Waveform plot can only display waveforms acquired using the 

fixed frequency sampling mode (that is, waveforms acquired using the order 

tracked sampling mode cannot be displayed). 

 

 

2.12 Consistency check message 

The hydro air-gap monitoring application specific package is implemented at the VibroSight Server 

level, that is, it is post-processing performed by the VibroSight Server on the principal mode 

waveforms received from the dynamic processing blocks. 

The dynamic processing blocks used for hydro air-gap monitoring applications typically do not have 

any other measurements (extractions) defined for them, with the result that the VibroSight 

Configurator consistency check displays the warning message “The processing block currently has no 

enabled extractions defined” for such dynamic processing blocks even though the configuration is 

perfectly correct. According, this consistency message has been removed. 

 

 

 

VM600 XMx16 cards 

2.13 Scaled average qualifier (rectifier) 

For the dynamic processing blocks of VM600 XMx16 cards, a new Scaled average qualifier (rectifier) 

is now available for use with time domain data extractions. 

The new Scaled average qualifier is calculated as follows: 

Scaled average value = ( True RMS value / pi ) * 2 * sqrt(2) 
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3 Solved problems and bug fixes 

General 

3.1 Improvements and bug fixes 

General stability improvements across the VibroSight 3.1.0 software. 

 

3.2 Hydro air-gap monitoring: Incorrect calculation of Layer avg gap 

For the hydro air-gap monitoring application specific package, the air-gap processing block’s 

calculation of the Layer avg gap was incorrect, as it was returning a value based on the Min gaps from 

the individual probes used by the layer (when it should have been based on the Avg gaps). 
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4 Known issues 

4.1 Display of timestamps in VibroSight Vision 

In VibroSight Vision, when the timestamps (date and time) are configured to be displayed as Site time 

or Local computer time and the site time or local computer time is subsequently changed on the 

relevant computer (for example, using Windows > Control Panel > Date and Time), this change is not 

reflected in the VibroSight Vision user interface until the user clicks on the Timestamp displayed in 

the VibroSight Vision status bar. 

 

4.2 VibroSight Server and Host Service restart required after changes to 
network adapter 

If the configuration of a network adapter is changed (for example, enabled or disabled, connected or 

disconnected) on a computer running VibroSight, then the VibroSight Servers and Host Services 

running on the computer must be restarted in order for the network adapter to be recognized by the 

VibroSight discovery mechanism. 

 

4.3 Length limitation of VibroSight Server instance names 

Since VibroSight 2.9.6, VibroSight Server instance names are limited to 18 characters, whereas up to 

27 characters were allowed in previous versions. This constraint is enforced during the creation of new 

server instances with VibroSight 2.9.6 or later. 

NOTE: VibroSight allows only alphanumeric characters (A to Z, a to z, 0 to 9), the 

hyphen-minus character ( - ) and the underscore character ( _ ) to be used for 

VibroSight Server names. 

 

However, existing server instances may be non-compliant (too long) and no longer run after an 

upgrade of the VibroSight software. In such cases, the file names used for the VibroSight Server 

database file (*.vssrvdb or *.db) and the VibroSight Server configuration file (*.vssrvcfg or 

*.config) should be updated (and manually edited in the VibroSight configuration file) to be 

18 characters or less. Changes may also be required in any VibroSight software that references the 

server instance name, such as VibroSight Vision projects. 

Where used, the automated database copies append a timestamp (_yyyyMMddHHmmss) to the 

Server instance name which reduces the number of file name characters that remain available for 

VibroSight Server instance names to three. Alternatively, the server instance name can be shorted 

after the database copy is complete. 

Also, depending on the VibroSight Server database file names used and any truncation performed by 

VibroSight, it is possible that servers are created with names that contain non-allowed characters 

(such as spaces), with the result that these servers will not be accessible by VibroSight software 

clients. Similarly, duplicate VibroSight Server names are also possible. 
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NOTE: Choose appropriate VibroSight Server names in order to avoid name conflicts 

arising due to truncation and/or additional databases being created during 

automatic data management. 

This is particularly important for systems with automated data management and 

system backup procedures that use script files containing database commands 

(such as copy and backup) that can automatically generate VibroSight Server 

database files. 

 

4.4 VibroSight client connections to local and remote VibroSight Servers are 
mutually exclusive 

When a VibroSight Server is running on a (local) computer, a VibroSight client, such as VibroSight 

Configurator or VibroSight Vision running on the same (local) computer cannot connect to a VibroSight 

Server running on a different (remote) computer. 

 

4.5 VibroSight Servers listen to a single IP address 

A VibroSight Server uses one specific IP address for connections to VibroSight clients and all 

communications is directed through this VibroSight Server IP address. This IP address can be set to 

any of the available network adapters or logical addresses on the host computer running the 

VibroSight Server. On a computer with a single network adapter, the IP address of the single network 

adapter is used by default. 

In typical applications, the network adapter of the host computer running the VibroSight Server is 

connected to a dedicated control (industrial) Ethernet network that contains the VibroSight-compatible 

hardware such as VM600 XMx16 cards and VibroSmart devices. 

However, as a VibroSight Server uses one specific IP address (network adapter), this prevents 

concurrent connections from VibroSight clients running on other separate networks, such as a 

business (corporate) Ethernet network. 

See also 4.11 VibroSight Server communication errors. 

 

4.6 Display of timestamps in VibroSight clients other than VibroSight Vision 

Although VibroSight Vision now supports the display of timestamps (date and time) as either Site time, 

UTC time or Local computer time, all other VibroSight client software modules continue to display 

timestamps in local computer time only (that is, the date and time according to the local clock of the 

computer running the VibroSight software module). 

 

4.7 Display of devices in VibroSight System Manager 

In the System Explorer window of VibroSight System Manager, the Devices tree-view does not always 

update correctly to show all of the devices (VM600 cards and VibroSmart devices) available on the 

network. 



     

   
 

 

     

 

     
 24 / 51 Release Notes VIBROSIGHT-RN/E (660-010-013-219A) 

Release 3.1.0 – March 2017 
 

     
 

In particular, this has been seen when changing the firmware of a device, and can persist even after a 

refresh (using the Refresh toolbar button or View > Refresh). 

If this behaviour is seen, the recommended workaround is to: 

 Wait a few minutes and refresh again. 

 Restart VibroSight System Manager. 

 

4.8 VibroSight Mimic backwards compatibility 

VibroSight 2.10.0 contained significant improvements and changes, including a separate VibroSight 

Mimic client software module for mimics (that were previously available in VibroSight Vision). As a 

result, VibroSight Vision mimics created with VibroSight 2.9.7 or earlier are not compatible with 

VibroSight 2.10.0 or later. 

VibroSight 2.11.0 contained significant improvements and changes to the VibroSight Mimic client 

software module. As a result, VibroSight Vision mimics created with VibroSight 2.10.1 or earlier are 

not compatible with VibroSight 2.11.0 or later. 

VibroSight 2.11.5 contained significant improvements to the VibroSight Mimic project framework to 

include version information, in order to improve the compatibility between projects created with 

different versions of VibroSight Mimic and eliminate the requirement for the recreation of Mimics. 

Starting with VibroSight 2.11.5, Mimic projects automatically detect any changes in the VibroSight 

Mimic software that affect project compatibility, inform the user and update the project as required. 

NOTE: VibroSight 2.11.5 is also able to open and work with Mimic projects created with 

VibroSight 2.11.0 or later, if the corresponding database had been updated as 

required. 

 

NOTE: When updating existing machinery monitoring projects created with 

VibroSight 2.12.x to VibroSight 3.1.0, a new data repository created by copying a 

VibroSight database (*.vssrvdb) to a VibroSight historical data folder (*.vshdf) 

must use the same server file name as the existing server in order for existing 

VibroSight Mimics to maintain links with the data repository and continue to work 

(without manual corrections). 

In addition, the VibroSight Server using the new the new data repository must be 

running before the existing VibroSight Mimics are run for the first time, after the 

update. See also 2.5 Data repositories Copy command. 

 

4.9 VibroSight OPC Clients not recovering 

When a VibroSight OPC Client is being used to import information from an external OPC server into a 

VibroSight system and the external OPC server becomes unavailable, the VibroSight OPC Client may 

not always recover automatically when the OPC server becomes available again. 

This is typically characterised by the VibroSight OPC Client continuing to show connection error 

messages even when OPC server is available and can result in permanent loss of the imported data if 

not noticed. 



     

 
 

   

     

 

     
 Release Notes VIBROSIGHT-RN/E (660-010-013-219A) 

Release 3.1.0 – March 2017 25 / 51  

     
 

NOTE: The external OPC data can be permanently lost if it is not imported into VibroSight 

as expected. 

Any VibroSight system feature or configuration element relying on the imported 

OPC data will not behave as expected, for example, alarms, machinery operating 

conditions and data logging rules. 

 

If this behaviour is seen, the recommended workaround is to: 

 Stop and restart the VibroSight OPC Client from either the VibroSight Server 

(Data > Acquisition > OPC Device Driver) or VibroSight System Manager. 

 Stop and restart the VibroSight Server, if required. 

 

4.10 Duplicate events 

For VibroSight systems using VM600 XMx16 cards, VibroSight Event Viewer retrieves all of the event 

information available from the data buffers on the cards. 

For VibroSight systems using VibroSmart modules, VibroSight Event Viewer retrieves the event 

information available from the current time only (no buffered events). 

Accordingly, for a VibroSight system using VM600 XMx16 cards, there is the possibility of duplicate 

events being listed in the Event Viewer, particularly for VibroSight systems being operated without an 

NTP server (where events are not recognised as duplicates due to time drift). 

 

4.11 VibroSight Server communication errors 

Under rare circumstances, when a computer running VibroSight clients has two network adapters 

(cards) installed, communications errors with a VibroSight Server are possible. 

See also 4.5 VibroSight Servers listen to a single IP address. 

 

4.12 VibroSight Server status indicators 

The status indicators (performance counter monitors) on the Status tab of the new VibroSight Server 

are not correctly displayed and updated when an NVIDIA WMI driver is installed on the same 

computer as the VibroSight Server. 

NOTE: The NVIDIA Enterprise Management Toolkit (NVWMI) is a graphics and display 

management and control technology that interfaces to Microsoft’s Windows 

Management Instrumentation (WMI) infrastructure, specific to NVIDIA graphics 

processing units (GPUs). 

 

This is because NVIDIA WMI prevents the Microsoft .NET Framework from obtaining the required 

counter values from the underlying operating system / computer. 
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4.13 XMx16 card pre-logging 

For an XMx16 card pair, if Dynamic Input Channel 16 is used as an input to a Dynamic Processing 

Block that is used as an input to a Dual Shaft Relative Processing Block which is configured to provide 

an Orbit and/or Full Spectrum output, then any pre-logging configured for the principal mode 

Waveform and/or Spectrum of Dynamic Input Channel 16 will not actually log any of the data from the 

same pre-logging scope. 

 

4.14 Problems creating new VibroSight OPC Servers 

Users who have upgraded from an earlier version of VibroSight to a later version (for example, from 

VibroSight 2.x.x or 3.0.0 to VibroSight 3.1.0) can experience problems when creating new VibroSight 

OPC Servers. 

Such problems are typically characterised by the OPC Server Create command in VibroSight System 

Manager displaying an error message such as 

“The type initializer for ‘ch.VibroMeter.Xms.OpcServer.Utils.OpcServerUtils’ 

threw an exception”. 

This typically occurs because an earlier version of the OpcServer.config file required by VibroSight 

OPC Servers is being used by the later installation of VibroSight, which can happen in one of two 

ways: 

 When a later version of VibroSight 3.x.x is installed on a computer that was running an earlier 

version of VibroSight 2.x.x, the VibroSight installer automatically checks existing VibroSight folders 

(such as C:\ProgramData\Meggitt\VibroSight 2) in order to copy relevant system and/or user 

preference files across to the new VibroSight folders (such as 

C:\ProgramData\Meggitt\VibroSight), including an earlier OpcServer.config file. 

 When VibroSight 3.1.0 is installed on a computer that was running VibroSight 3.0.0, the creation of 

a VibroSight OPC installer using VibroSight 3.0.0 automatically created an earlier 

OpcServer.config file. 

As shown below, the first few lines of a typical OpcServer.config file contains version specific 

information that is incompatible with later versions of VibroSight: 

<?xml version="1.0" encoding="utf-8"?> 

<configuration> 

  <configSections> 

    <section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Version=2.0.0.0, Culture=neutral, 

PublicKeyToken=2db2a2387bac0a0a" /> 

  </configSections> 

… 

</configuration> 
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So for users who have upgraded from an earlier version of VibroSight to a later version, if problems 

are experienced when creating new VibroSight OPC Servers, the workaround is to: 

 

1. Use an XML-compatible text editor program to edit the OpcServer.config file and remove the 

version specific information. That is, change the line containing the section name 

from: 

<section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Version=2.0.0.0, Culture=neutral, 

PublicKeyToken=2db2a2387bac0a0a" /> 

to: 

<section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Culture=neutral, PublicKeyToken=2db2a2387bac0a0a" /> 

 

2. Restart the computer. 

    Note: The computer must be restarted to ensure that the edited version of the OpcServer.config 

    file is used (and not some other version from cache memory). 

 

3. Use the OPC Server Create command in VibroSight System as required. 
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5 Compatibility 

As part of the VibroSight software installation process, the VibroSight installer will automatically check 

to see if the required Microsoft .NET Framework (see section 5.1.2), Microsoft Visual C++ 

Redistributable Package (see section 5.1.3) and OPC Core Components Redistributable 

(see section 5.1.4) are pre-installed. 

The required Microsoft .NET Framework and Microsoft Visual C++ Redistributable Package must be 

manually installed on the computer before VibroSight can be installed. If the required Microsoft .NET 

Framework and Microsoft Visual C++ Redistributable Package are not pre-installed, then the 

VibroSight installer will detect this and exit the installation. 

If not already installed, the required OPC Core Components Redistributable software is automatically 

installed on the computer by the VibroSight installer. 

NOTE: Refer to the latest version of the  Getting started with VibroSight installation 

guide or the  VibroSight software data sheet for further information on 

VibroSight’s prerequisites and compatibility. 

 

5.1 VibroSight software 

VibroSight 3.1.0 is a minor level release and replaces VibroSight 3.0.0. 

Compatibility with existing VibroSight data repositories (databases) is achieved using a specific data 

migration process from any existing databases based on Sybase SQL Anywhere (*.vssrvdb) to data 

repositories based on the VibroSight historical data repositories (VibroSight historical data folders 

(*.vshdf) for operation with a VibroSight Server (live data) and VibroSight historical data archives 

(*.vshda) for operation with historical data). 

Therefore, it is important to note that: 

 New machinery monitoring projects created with VibroSight 3.1.0 will automatically use VibroSight 

historical data repositories. 

 Existing machinery monitoring projects created with versions of VibroSight earlier than 

VibroSight 3.0.0 must be manually migrated from Sybase SQL Anywhere databases to VibroSight 

historical data repositories before they can be used with VibroSight 3.1.0. 

NOTE: The manual migration of an existing machinery monitoring project to 

VibroSight 3.1.0 is described in detail in the “Data migration” section of the latest 

 Getting started with VibroSight installation guide. 

 

 



     

 
 

   

     

 

     
 Release Notes VIBROSIGHT-RN/E (660-010-013-219A) 

Release 3.1.0 – March 2017 29 / 51  

     
 

5.1.1 Microsoft Windows operating systems 

VibroSight 3.1.0 is compatible with 32-bit versions and 64-bit versions of Microsoft ® Windows ® 

operating systems. 

NOTE: Starting with VibroSight 3.0.0, VibroSight software is now available as 64-bit 

software for 64-bit Windows and 32-bit software for 32-bit Windows. 

The 64-bit version of VibroSight can be installed on 64-bit Windows computers 

only. The 32-bit version of VibroSight can be installed on 32-bit Windows 

computers only. Only a single version of VibroSight can be installed and exist on a 

computer at any one time 

 

See the appendix of this document for detailed information on VibroSight software and Windows 

operating system compatibility. 

 

5.1.2 Microsoft .NET Framework 

For most Windows operating systems, VibroSight 3.1.0 requires that the Microsoft .NET 

Framework 4.6 or later is installed. 

NOTE: VibroSight 3.1.0 requires Microsoft .NET Framework 4.6. 

 

If the required Microsoft .NET Framework is not pre-installed, then the VibroSight installer will detect 

this and exit the installation. 

See the appendix of this document for detailed information on VibroSight software’s Microsoft .NET 

Framework requirements. 

 

5.1.3 Microsoft Visual C++ Redistributable Package 

VibroSight 3.1.0 requires that the Microsoft Visual C++ Redistributable Package for Visual Studio 2015 

is installed, in order to install and register the Visual C++ libraries used by VibroSight. 

NOTE: The 64-bit version of the Microsoft Visual C++ Redistributable Package (“Microsoft 

Visual C++ 2015 Redistributable (x64)”) must be installed on 64-bit Windows 

computers. 

The 32-bit version of the Microsoft Visual C++ Redistributable Package (“Microsoft 

Visual C++ 2015 Redistributable (x86)”) must be installed on 32-bit Windows 

computers. 

 

If the required Microsoft Visual C++ Redistributable Package is not pre-installed, then the VibroSight 

installer will detect this and exit the installation. 
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5.1.4 OPC Core Components Redistributable 

VibroSight 3.1.0 requires that the OPC Core Components Redistributable is installed, in order to 

configure and run VibroSight OPC Clients and VibroSight OPC Servers correctly: the redistributable 

must be installed on OPC client computers in order to allow connections to remote OPC servers and it 

must be installed on OPC server computers in order to allow OPC clients to browse for running OPC 

servers. 

NOTE: The 64-bit version of the OPC Core Components Redistributable (“OPC Core 

Components Redistributable (x64) 106.0”) must be installed on 64-bit Windows 

computers. 

The 32-bit version of the OPC Core Components Redistributable (“OPC Core 

Components Redistributable (x86) 106.0”) must be installed on 32-bit Windows 

computers. 

 

If the required OPC Core Components Redistributable is not pre-installed, then the VibroSight installer 

will detect this and automatically install it as part of the VibroSight software installation. 

 

5.1.5 Sybase SQL Anywhere 11 software 

Starting with VibroSight 3.0.0, the VibroSight historical data repositories (VibroSight historical data 

folders (*.vshdf) for operation with a VibroSight Server (live data) and VibroSight historical data 

archives (*.vshda) for operation with historical data) are exclusively used for the required data 

repositories. 

A VibroSight database based on Sybase SQL Anywhere (*.vssrvdb) can no longer be used as a 

data repository. Accordingly, the Sybase SQL Anywhere 11 database software is no longer included 

and distributed as part of the VibroSight software. 

NOTE: VibroSight 3.0.0 or later exclusively uses data repositories based on the VibroSight 

historical data system. 

VibroSight 2.12.7 used data repositories based on Sybase SQL Anywhere 

databases and introduced initial support for working with data repositories based 

on the VibroSight historical data repositories for data analysis. 

VibroSight 2.12.6 or earlier exclusively used data repositories based on Sybase 

SQL Anywhere databases. 

 

NOTE: The manual migration of an existing machinery monitoring project to 

VibroSight 3.1.0 is described in detail in the “Data migration” section of the latest 

 Getting started with VibroSight installation guide. 
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5.1.6 VM600 CMS software 

The VM600 CMS software from Meggitt Sensing Systems uses Sybase SQL Anywhere 8. Both 

Sybase SQL Anywhere 8 (VM600 CMS) and Sybase SQL Anywhere 11 (VibroSight) can be installed 

on the same computer. 

However, while SQL Anywhere 8 and SQL Anywhere 11 can be installed on the same computer and 

run at the same time for standard database operations, certain administrative tasks are mutually 

exclusive and may block one another. 

More specifically, all operations that refer to Sybase SQL (a command-line Interactive SQL utility) in 

the background could be directed to the wrong version of Sybase SQL Anywhere. For example, this 

impacts all user operations and system operations involving the creation, copying and updating of 

databases. 

NOTE: It is recommended to install and use VibroSight 3.1.0 or earlier on a computer that 

does not have the VM600 CMS software installed. 

 

5.1.7 SIMATIC Step 7 software 

The SIMATIC Step 7 software from Siemens typically uses Sybase SQL Anywhere 9. Both Sybase 

SQL Anywhere 9 (SIMATIC Step 7) and Sybase SQL Anywhere 11 (VibroSight) can be installed on 

the same computer. 

However, while SQL Anywhere 9 and SQL Anywhere 11 can be installed on the same computer, they 

cannot run at the same time. 

More specifically, if SIMATIC Step 7 and VibroSight are both installed, certain administrative tasks, 

such as all user operations and system operations involving the creation, copying and updating of 

databases, may not work correctly. If this behaviour is seen, the recommended workaround is to 

manually change or remove the SQLANY environmental variable in order to allow VibroSight to work 

correctly. 

Note: The SQLANY environment variable is used to contain the directory where Sybase SQL 

Anywhere is installed. 

NOTE: It is recommended to install and use VibroSight 3.1.0 or earlier on a computer that 

does not have the SIMATIC Step 7 software installed. 

 

5.1.8 Dell Backup and Recovery software 

Some Dell™ computers running versions of Dell Backup and Recovery software can experience 

problems running the VibroSight software, characterised by the VibroSight software not running or 

running incorrectly. This is because the Dell Backup and Recovery software can use a version of 

SQLite and associated libraries (DLLs) that prevent the VibroSight Host Service from running 

correctly. 

For example, VibroSight clients can stop running (crash), VibroSight clients can be unable to connect 

to data sources and/or VibroSight System manager may not display all of the commands expected to 

be available in the Actions window. 
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If this behaviour is seen, the recommended workaround is to uninstall the Dell Backup and Recovery 

software. 

NOTE: It is recommended to install and use VibroSight 3.1.0 or earlier on a computer that 

does not have the Dell Backup and Recovery software installed. 

 

 

5.2 VM600 cards 

5.2.1 Firmware 

There are no firmware updates for VM600 cards corresponding to VibroSight 3.1.0. 

The latest firmware for the CPUR remains: 

 Base System: base-system-640-014-001-001.tgz 

 Applications:  applications-640-015-001-001.tgz. 

The latest firmware for the XMC16, XMV16 and XMVS16 remains: 

 Base System: base-system-640-003-001-014.tgz 

 Applications:  applications-640-010-001-014.tgz. 

Therefore, for current versions of the VM600 cards, firmware upgrades are not required. 

 

 

5.3 VibroSmart devices 

5.3.1 Firmware 

There are no firmware updates for VibroSmart modules and devices corresponding to 

VibroSight 3.1.0. 

The latest firmware for the VSI010 module remains: 

 642-002-000-009.xmsifw. 

The latest firmware for the VSN010 device remains: 

 642-004-000-011.redboxfw. 

The latest firmware for the VSV300 module remains: 

 642-001-000-014.xtranfw. 

Therefore, for current versions of the VibroSmart modules and devices, firmware upgrades are not 

required. 
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6 Upgrade procedure 

This section describes the procedure for upgrading a VibroSight system from a previous version. 

Perform the steps in the given sequence in order to complete a system upgrade. 

NOTE: It is strongly recommended to verify the version of firmware running in the related 

hardware (XMx16 cards and VibroSmart modules and devices) before starting a 

VibroSight system upgrade, in order to establish if any firmware updates are also 

required. 

See 6.2.3 Updating the firmware using VibroSight System Manager. 

 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart is available before updating the firmware of any of the VibroSmart 

modules used in the distributed monitoring system. See 6.2.3 Updating the 

firmware using VibroSight System Manager. 

 

6.1 VibroSight software user settings 

The VibroSight Software generates and uses some files on the hard disk of the computer running 

VibroSight to keep track of user-configurable settings, so that these settings are remembered and 

applied for the VibroSight installation. 

These settings files have an .xmssettings file name extension and on a computer running 

Windows 7, can be found here: 

C:\Users\username\AppData\Roaming\Meggitt\VibroSight, where username is the Windows 

account name. 

For example, the VibroSightVision.xmssettings file records the user-configurable default 

settings for VibroSight Vision, such as default settings for plots. 

NOTE: VibroSight software updates and upgrades do not replace these settings files, so: 

• For a computer on which VibroSight was previously installed, an update, upgrade 

or a re-installation of VibroSight will continue to use the previous defaults recorded 

in the .xmssettings files. 

• For a computer on which VibroSight was not previously installed, the installation 

of VibroSight will generate and use new .xmssettings files, which use the latest 

VibroSight software defaults. 

If a settings file is deleted for any reason, VibroSight will generate and use a new 

settings file, which uses the latest VibroSight software defaults. 
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6.2 Updating VibroSight-compatible hardware 

Appropriate files and tools are included in the installation package to allow VM600 cards (XMx16) and 

VibroSmart devices (VSI010, VSN010 and VSV300) to be updated to the latest firmware, in order to 

take advantage of improvements to the VibroSight software. 

Updating the firmware VM600 cards or VibroSmart devices is a special task that can, if used 

unintentionally or incorrectly, lead to malfunctioning of the device and affect proper function of data 

acquisition. 

During the firmware update of a device, the card or module being updated cannot provide its normal 

machinery monitoring functions because its outputs (alarms and relays) can go to undetermined 

states, irrespective of how they have been configured. 

For VibroSmart modules, the machinery being monitored is not protected for the duration of a firmware 

update and the restart (reboot) that is triggered automatically after the firmware update (which can 

take up to 5 minutes). 

NOTE: It is highly recommended that firmware updates are only performed in accordance 

with the operating procedures for the machinery being monitored and that 

appropriate precautions are taken at the control system level (such as DCS 

or PLC). 

For example, alarms and relay outputs should be ignored (bypassed or inhibited) in 

order to avoid false trips of the machinery being monitored. 

 

6.2.1 VM600 card firmware 

The latest VM600 card firmware files are copied to a directory on your computer as part of the 

VibroSight software installation process. 

NOTE: For example, the default firmware directory for VM600 cards is: 

C:\Program Files\Meggitt\VibroSight\Firmware\VM600 

 

The firmware files for a VM600 card can be found in the appropriate subfolder and identified by their 

.tgz file name extension. For example, the XMV16 subfolder contains the applications and base 

system firmware for use by XMV16 cards. Any additional firmware updates received from Meggitt 

Sensing Systems should also be stored in these directories. 

Table 1 shows the compatibility between VibroSight software and VM600 CPUR card hardware (that 

is, CPUR card firmware). 

Table 2 shows the compatibility between VibroSight software and VM600 XMx16 card hardware (that 

is, XMC16, XMV16 and XMVS16 card firmware). 

NOTE: It is strongly recommended to use the most recent version of the VM600 CPUR 

card firmware and VM600 XMx16 card firmware that is compatible with the version 

of VibroSight software being used. 
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Table 1: VibroSight software and VM600 CPUR card firmware compatibility 

 VM600 CPUR firmware. See note 1 

VibroSight software version 

CD part number 

Base-system (*.tgz) 

640-014-001-001 

Applications (*.tgz) 

640-015-001-001 

2.12.7 

609-004-000-036 
 

See note 2
 

3.0.0 

609-004-000-037 
 

3.1.0 

609-004-000-038 
 

 

Notes for Table 1 

1. VM600 CPUR card firmware is packaged and distributed as a .tgz file (a compressed archive file format) with PNRs such as 

640-014-001-xxx for the Base System and 640-015-001-xxx for the (Applications) Firmware. In these PNRs, the xxx-xxx-001-

xxx denotes the firmware is packaged in the tgz file format. 

After the .tgz file is unpacked by VibroSight System Manager and the firmware is uploaded to a VM600 CPUR card, the dialog 

box displayed by the VibroSight System Manager’s Change Firmware command shows the current version of firmware using 

PNRs such as 640-014-000-xxx for the Base System and 640-015-000-xxx for the Firmware, which correspond to the actual 

unpacked firmware that is running on the card. 

 

2. This is the first official release of VM600 CPUR card firmware and includes features such as the management of XMx16 card 

configurations for applications such as control systems and the implementation of the PROFIBUS protocol for the fieldbus 

interfaces. A firmware upgrade is required in order to run VibroSight 2.12.7 or later. 
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Table 2: VibroSight software and VM600 XMx16 card firmware compatibility 

 VM600 XMx16 firmware. See note 1 

VibroSight 

software version 

CD part number 

Base-system (*.tgz) 

640-003- 

001-011 

640-003- 

001-012 

640-003- 

001-013 

640-003- 

001-014 

Applications (*.tgz) 

640-010- 

001-010 

640-010- 

001-011 

640-010- 

001-012 

640-010- 

001-013 

640-010- 

001-014 

2.12.0 

609-004-000-027 
 

See note 2
 

    

2.12.1 

609-004-000-028 
  

See note 3
 

   

2.12.2 

609-004-000-029 
  

   

2.12.3 

609-004-000-030 
  

   

2.12.4 

609-004-000-032 
  

   

2.12.5 

609-004-000-033 
   

See note 4
 

  

2.12.6 

609-004-000-034 
   

  

2.12.7 

609-004-000-036 
    

See note 5
  

3.0.0 

609-004-000-037 
     

See note 6
 

3.1.0 

609-004-000-038 
     

 

Notes for Table 2 (see the next page)  
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Notes for Table 2 

1. VM600 XMx16 card firmware is packaged and distributed as a .tgz file (a compressed archive file format) with PNRs such as 

640-003-001-xxx for the Base System and 640-010-001-xxx for the (Applications) Firmware. In these PNRs, the xxx-xxx-001-

xxx denotes the firmware is packaged in the tgz file format. 

After the .tgz file is unpacked by VibroSight System Manager and the firmware is uploaded to a VM600 XMx16 card, the dialog 

box displayed by the VibroSight System Manager’s Change Firmware command shows the current version of firmware using 

PNRs such as 640-010-000-xxx for the Firmware and 640-003-000-xxx for the Base System, which correspond to the actual 

unpacked firmware that is running on the card. 

 

2. This version of VM600 XMx16 card firmware introduces support for hydro air-gap monitoring. 

 

3. This version of VM600 XMx16 card firmware introduces support for 1 s time-boxed peak-hold processing (that is, spectral 

data aggregation). 

 

4. This version of VM600 XMx16 card firmware implements improved multi-rate digital resamplers (sample rate converters). 

A firmware upgrade is recommended but not required in order to run VibroSight 2.12.5 or 2.12.6. 

 

5. This version of VM600 XMx16 card firmware improves support for faster live data: 100 ms card update rate and up to 100 ms 

VibroSight Vision refresh rate. It also allows a VM600 XMx16 card to be managed by a VM600 CPUR card (“rack controller”), 

eliminating the XMx16 card’s requirement for a VibroSight Server. A firmware upgrade is required in order to run 

VibroSight 2.12.7. 

 

6. This version of VM600 XMx16 card firmware adds support for customer-specific functionality that is enabled by a customer-

specific VibroSight software licence. A firmware upgrade is required in order to run VibroSight 3.0.0 or later. 
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6.2.2 VibroSmart device firmware 

The latest VibroSmart device firmware files are copied to a directory on your computer as part of the 

VibroSight software installation process. 

NOTE: The default firmware directory for VibroSmart devices is: 

C:\Program Files\Meggitt\VibroSight\Firmware\VibroSmart 

 

The firmware files for a VibroSmart device can be found in the appropriate subfolder and identified by 

their .*fw file name extension. For example, the VSV300 subfolder contains the firmware for use by 

VSV300 modules. Any additional firmware updates received from Meggitt Sensing Systems should 

also be stored in these directories. 

Table 3 shows the compatibility between VibroSight software and the VibroSmart VSI010 module 

firmware. 

Table 4 shows the compatibility between VibroSight software and the VibroSmart VSN010 device 

firmware. 

Table 5 shows the compatibility between VibroSight software and the VibroSmart VSV300 module 

firmware. 

 

NOTE: It is strongly recommended to use the most recent version of the VibroSmart 

firmware that is compatible with the version of VibroSight software being used. 
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Table 3: VibroSight software and VibroSmart VSI010 module firmware compatibility 

 VSI010 firmware (*.xmsifw). See note 1 

VibroSight 

software version 

CD part number 

642-002 

-000-006 

642-002- 

000-007 

642-002- 

000-008 

642-002- 

000-009 

2.12.0 

609-004-000-027 


 See note 2
 

   

2.12.1 

609-004-000-028 
 

 See note 2
 

  

2.12.2 

609-004-000-029 
  

  

2.12.3 

609-004-000-030 
  

 See note 2
 

 

2.12.4 

609-004-000-032 
   

 

2.12.5 

609-004-000-033 
   

 

2.12.6 

609-004-000-034 
   

 See note 2
 

2.12.7 

609-004-000-036 
    

3.0.0 

609-004-000-037 
    

3.1.0 

609-004-000-038 
    

 

Notes for Table 3 

1. VibroSmart VSI010 module firmware is distributed as a single .xmsifw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSI010 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-

time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 

addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 
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Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSI010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSN010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 4: VibroSight software and VibroSmart VSN010 device firmware compatibility 

 VSN010 firmware (*.redboxfw). See note 1 

VibroSight 

software 

version 

CD part number 

642-004- 

000-008 

642-004- 

000-009 

642-004- 

000-010 

642-004- 

000-011 

2.12.0 

609-004-000-027 


 See note 2
 

   

2.12.1 

609-004-000-028 
 

 See note 2
 

  

2.12.2 

609-004-000-029 
  

  

2.12.3 

609-004-000-030 
  

 See note 2
 

 

2.12.4 

609-004-000-032 
   

 

2.12.5 

609-004-000-033 
   

 

2.12.6 

609-004-000-034 
   

 See note 2
 

2.12.7 

609-004-000-036 
    

3.0.0 

609-004-000-037 
    

3.1.0 

609-004-000-038 
    

 

Notes for Table 4 

1. VibroSmart VSN010 device firmware is distributed as a single .redboxfw file (a proprietary file format) with a PNR such as 

642-xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSN010 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-

time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 

addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 
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device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSN010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 5: VibroSight software and VibroSmart VSV300 module firmware compatibility 

 VSV300 firmware (*.xtranfw). See note 1 

VibroSight 

software version 

CD part number 

642-001-000-

010 

642-001-

000-011 

642-001-

000-012 

642-001-

000-013 

642-001-

000-014 

2.12.0 

609-004-000-027 


 See note 2
 

    

2.12.1 

609-004-000-028 
 

 See note 2
 

   

2.12.2 

609-004-000-029 
  

   

2.12.3 

609-004-000-030 
  

 See note 2
 

  

2.12.4 

609-004-000-032 
   

  

2.12.5 

609-004-000-033 
   

 See note 2
 

 

2.12.6 

609-004-000-034 
    

 See note 2
 

2.12.7 

609-004-000-036 
     

3.0.0 

609-004-000-037 
     

3.1.0 

609-004-000-038 
     

 

Notes for Table 5 

1. VibroSmart VSV300 device firmware is distributed as a single .xtranfw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSV300 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-

time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 

addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 
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Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSV300 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSN010 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 

  



     

 
 

   

     

 

     
 Release Notes VIBROSIGHT-RN/E (660-010-013-219A) 

Release 3.1.0 – March 2017 45 / 51  

     
 

6.2.3 Updating the firmware using VibroSight System Manager 

When performing VibroSight software upgrades, it is strongly recommended to systematically upgrade 

the firmware of VM600 XMx16 cards and VibroSmart devices to the latest compatible version. 

Failure to perform a necessary VibroSight-compatible VM600 card firmware update may lead to 

incoherent system behaviour and affect the proper functioning of data acquisition in a system. It is only 

in systems where the firmware running on the XMx16 cards and VibroSmart devices already 

corresponds to the latest available version that no firmware update is required. Therefore, it is strongly 

recommended to verify the version of firmware running on the hardware before starting a VibroSight 

system upgrade, in order to establish if a firmware update is also required. 

NOTE: Changing the firmware of the VibroSight hardware is a special administrative task 

that can – if performed unintentionally – affect the proper functioning of data 

acquisition in a system. 

It is therefore strongly recommended to change the firmware of the VibroSight 

hardware only when it is necessary. For example, when the devices must be 

updated to be compatible with a VibroSight software upgrade. 

 

For VibroSmart modules, each module can be selected and its firmware updated individually. 

Alternatively, multiple modules of the same type (for example, VSV3x0) can be updated to the same 

version of firmware at the same time. 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart is available before updating the firmware of any of the VibroSmart 

modules used in the distributed monitoring system. 

For example, using the currently installed version of VibroSight (that is, before any 

updates to the VibroSight software corresponding to updates to VibroSmart 

modules), VibroSight Configurator should be used to obtain a copy of the 

configuration as follows:  

For a VibroSmart using a VibroSight Server, the File > Open > Server / Database 

command can be used to read the configuration from the VibroSight Server. 

For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” 

VibroSmart), the File > Open > Device command can be used to read the 

configuration directly from the VibroSmart modules. 

Then the File > Save As > File command should be used to store a copy of the 

configuration for the VibroSmart distributed monitoring system. 

 

Update the firmware on a VibroSight device using the  Change Firmware tool (from VibroSight 

System Manager’s Maintenance tools): 

1. Ensure that the computer running the VibroSight software is on the same network as the 

hardware (XMx16 card or VibroSmart module or device) to be updated. 

2. Start VibroSight System Manager and navigate to the Devices tree structure in the System 

Explorer window. 
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The Devices tree lists all of the VibroSight compatible hardware that VibroSight can see on the 

network. If there are no XMx16 cards or VibroSmart devices in the tree structure or some cards 

are missing, verify your network connections. 

3. Select the card or device that requires its firmware to be changed. 

The Actions tool window updates to show the available tools. 

To change multiple VibroSmart to use the same version of firmware at the same time, use 

CTRL+click or SHIFT+click to select multiple devices from the Devices tree-view. (Then, when 

the Change Firmware command is run, all of the devices that were selected will be updated at 

the same time.) 

4. Click  Change Firmware in the Maintenance tools group of the Actions window. 

The Change Firmware dialog box appears. 

5. Click the Add button and select the new firmware files for the card or new firmware file for the 

device. 

 NOTE: The Change Firmware dialog box automatically opens the firmware folder 

corresponding to the VibroSight-compatible VM600 card or VibroSmart device 

selected. 

.tgz files are for VM600 cards and .*fw files are for VibroSmart devices. 

 

6. Click the Finish button to start the firmware upgrade process. 

For XMx16 cards and VibroSmart devices, the firmware upgrade process can take up to 

5 minutes, during which: 

 The IP address beside the device’s serial number in the Devices tree structure can 

disappear. 

 The LEDs on the front panel of the device can change to reflect the status of the upgrade. 

7. Repeat steps 3 to 6 for each device that requires a firmware update. 

 NOTE: Although the firmware for each VibroSight device must be changed individually 

using the  Change Firmware tool, as each device updates its firmware 

independently of the VibroSight software (once the process has started), firmware 

updates can be performed on several devices in parallel. 

 

8. After the firmware upgrade, verify that the VibroSight system is acquiring data from the cards. 

 NOTE: Refer also to the Changing the firmware topics in the  VibroSight help. 

 

The  Change Firmware tool can be used to load a VibroSight device with any version of 

firmware. It is therefore possible to change a device’s firmware to any previously available version, as 

well as the latest update. 
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This feature can be useful in certain situations, for example, swapping spare VibroSight hardware 

between different VM600 racks or VibroSmart distributed monitoring systems, where systems are 

operating with different versions of VibroSight. 

 

6.3 Final checks 

After upgrading the VibroSight software, the following checks are recommended to ensure that 

VibroSight has not been inadvertently modified and that it continues to operate as expected: 

 Use VibroSight Configurator to run a consistency check on the configuration in order to ensure 

that the configuration has not been modified by any changes to the VibroSight software, 

internal database structure and firmware for the hardware (VM600 cards and VibroSmart 

modules). 

 Use the VibroSight Server window to check that the data acquisition, data post-processing and 

data logging settings are as expected. 

In VibroSight Server, under Device drivers, use the appropriate controls to enable 

communications with the VibroSight-compatible hardware, and under Server features, use 

the appropriate controls to enable the required post processing, for example, data logging. 
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7 Customer support 

7.1 Contacting us 

Meggitt Sensing Systems worldwide customer support network offers a range of support including 

Technical support and Sales and repairs support. For customer support, please contact your local 

Meggitt Sensing Systems representative. Alternatively, contact our main office: 

Customer support 

Meggitt SA 

Route de Moncor 4 

PO Box 1616 

CH-1701 Fribourg 

Switzerland 

 

Telephone: +41 (0) 26 407 11 11 

Email: energysupport@ch.meggitt.com 

Web: www.meggittsensingsystems.com 

 

7.2 Technical support 

Meggitt Sensing Systems technical support team provide both pre-sales and post-sales technical 

support, including: 

 General advice 

 Technical advice 

 Troubleshooting 

 Site visits. 

 

7.3 Sales and repairs support 

Meggitt Sensing Systems sales team provide both pre-sales and post-sales support, including advice 

on: 

 New products 

 Spare parts 

 Repairs. 

 

mailto:energysupport@ch.meggitt.com
http://www.meggittsensingsystems.com/
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Appendix 
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VibroSight software and Windows operating system compatibility 

 

 

Windows 7 Windows 8.1 Windows 10 

VibroSight software compatible? 

Yes 

(but not recommended for new 

installations as Microsoft support for 

Windows 7 ends in January 2020).  

Yes 
Yes 

(recommended for new installations) 

 

 

VibroSight software and Windows Server operating system compatibility 

 

 

Windows Server 2008 R2 Windows Server 2012 Windows Server 2016 

VibroSight software compatible? 

Yes 

(but not recommended for new 

installations as Microsoft support for 

Windows Server 2008 R2 ends in 

January 2020) 

Yes 

(recommended for new installations) 
To be announced 
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VibroSight software and Microsoft .NET Framework requirements 

VibroSight software version Microsoft. NET Framework requirements 

VibroSight 2.9.1 or earlier .NET Framework 3.5 SP1 

VibroSight 2.9.2 and 2.9.3 .NET Framework 4 (Standalone Installer) 

VibroSight 2.9.4 or later .NET Framework 4.5 

VibroSight 2.12.0 or later .NET Framework 4.5 and .NET Framework 2.0 
See note

 

VibroSight 3.0.0 or later .NET Framework 4.6 

Note: Since Microsoft .NET Framework 3.5 also includes .NET Framework 2.0 and .NET Framework 3.0, installing Microsoft .NET Framework 3.5 SP1 is the recommended 

solution for most computers (rather than installing Microsoft .NET Framework 2.0). 
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