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IMPORTANT NOTICE 

All statements, technical information and recommendations in this document which relate to the 

products supplied by Meggitt Sensing Systems are based on information believed to be reliable, but 

unless otherwise expressly agreed in writing with Meggitt SA, the accuracy or completeness of such 

data is not guaranteed. Before using this product, you must evaluate it and determine if it is suitable 

for your intended application. Unless otherwise expressly agreed in writing with Meggitt SA, you 

assume all risks and liability associated with such use. Meggitt Sensing Systems takes no 

responsibility for any statements related to the product which are not contained in a current English 

language Meggitt Sensing Systems publication, nor for any statements contained in extracts, 

summaries, translations or any other documents not authored and produced by Meggitt Sensing 

Systems. 

 

 

 

EXPORT CONTROL 

The information contained in this document may be subject to export control regulations of the 

European Community, USA or other countries. Each recipient of this document is responsible for 

ensuring that the transfer or use of any information contained in this document complies with all 

relevant export control regulations. ECN N /A. 
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PREFACE 

 

About these release notes 

This document provides important information about the VibroSight 
®
 software from Meggitt Sensing 

Systems. It is applicable to all VibroSight-based condition monitoring systems using the versions of 

software described by this document, namely: 

 VibroSight software version 3.2.0 (CD part number 609-004-000-039). 

This document contains information about changes to the software since the previously released 

version (VibroSight 3.1.0), such as new features and improvements, solved problems and bug fixes, 

and hardware and software compatibility. 

For more general information on the actual software, or the entire condition monitoring system (CMS), 

refer to the following Meggitt Sensing Systems (MSS) documentation: 

 VibroSight software data sheet 

        (MSS document ref. 660-020-005-218A) 

 Getting started with VibroSight installation guide 

        (MSS document ref. 660-010-006-219A) 

 VibroSight help 

 XMV16 / XIO16T extended vibration monitoring card pair data sheet 

        (MSS document ref. 660-020-010-208A) 

 VibroSight application notes and technical notes. 

 

Users who are familiar with VibroSight may also find it useful to refer to the release notes included in 

earlier versions of the software: 

 VibroSight 2.9.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.1 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.2 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.4 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.5 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.6 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.9.7 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.0 (MSS document ref. VIBROSIGHT-RN/E) 

 VibroSight 2.10.1 (MSS document ref. 660-010-013-201A) 

 VibroSight 2.11.0 (MSS document ref. 660-010-013-203A) 

 VibroSight 2.11.1 (MSS document ref. 660-010-013-204A) 

 VibroSight 2.11.2 (MSS document ref. 660-010-013-205A) 
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 VibroSight 2.11.3 (MSS document ref. 660-010-013-206A) 

 VibroSight 2.11.4 (MSS document ref. 660-010-013-207A) 

 VibroSight 2.11.5 (MSS document ref. 660-010-013-208A) 

 VibroSight 2.11.6 (MSS document ref. 660-010-013-209A) 

 VibroSight 2.12.0 (MSS document ref. 660-010-013-210A) 

 VibroSight 2.12.1 (MSS document ref. 660-010-013-211A) 

 VibroSight 2.12.2 (MSS document ref. 660-010-013-212A) 

 VibroSight 2.12.3 (MSS document ref. 660-010-013-213A) 

 VibroSight 2.12.4 (MSS document ref. 660-010-013-214A) 

 VibroSight 2.12.5 (MSS document ref. 660-010-013-215A) 

 VibroSight 2.12.6 (MSS document ref. 660-010-013-216A) 

 VibroSight 2.12.7 (MSS document ref. 660-010-013-217A) 

 VibroSight 3.0.0 (MSS document ref. 660-010-013-218A) 

 VibroSight 3.1.0 (MSS document ref. 660-010-013-219A). 

 

Structure of the release notes 

This document presents information in the following order: general items first, then in terms of the 

software modules that constitute VibroSight, such as  Configurator,  Event Viewer,  Mimic, 

 Scope,  Server,  System Manager and  Vision. 

You should read those sections that are most relevant to you and then keep the document for future 

reference. 

 

Version identifiers 

A complete VibroSight software version number has four components that provide the following 

information: 

 Major release identifier: x.x.x.x 

 Minor release identifier: x.x.x.x 

 Update release identifier: x.x.x.x 

 Maintenance (build) release identifier: x.x.x.x 

For each scheduled release of VibroSight, at least one of the first three digits changes (x.x.x.x). 

For unscheduled releases, that are occasionally required to solve urgent problems, only the fourth 

digit changes (x.x.x.x). 

The version identifiers for installed software appear in the Help About box (obtained using 

Help > About … in any VibroSight software module).  
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Terminology 

To distinguish between the different Meggitt Sensing System products that can be used with the 

VibroSight software, the following terminology is used in this document: 

 VM600 card – to refer to the VibroSight-software compatible cards that are installed in a VM600 

rack. The currently available VM600 cards that are designed for operation with the VibroSight 

software are the XMx16 card pairs (XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T) and the new CPUR/IOCR card pair. 

Where CPUx card is used in this document, it refers to CPUM and CPUR cards, and where 

IOCx card is used in this document, it refers to IOCN and IOCR cards, unless otherwise stated. 

Where XMx16 card is used in this document, it refers to XMC16 / XIO16T, XMV16 / XIO16T and 

XMVS16 / XIO16T cards, unless otherwise stated. 

 VibroSmart module or VibroSmart device – to refer to VibroSight-software compatible modules 

or devices that are used in a distributed monitoring system. The currently available VibroSmart 

modules and devices that are designed for operation with the VibroSight software are the 

VSI010, VSN010 and VSV300. 

Where VibroSmart module is used in this document, it refers to the VSI010 and VSV300 

modules, unless otherwise stated. 

Where VibroSmart device is used in this document, it can refer to the VSN010 device only, or to 

the VSI010 and VSV300 modules and the VSN010 device, unless otherwise stated. 
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1 Licensing 

In general, the licence required to enable purchased product options remains unchanged between 

update and/or maintenance level releases, for example, from version 2.12.6 to version 2.12.7. 

However, a new licence is always required for upgrades between major level releases, for example, 

from version 2.x.x to version 3.x.x. 

NOTE: VibroSight 3.2.0 is a minor level release and a new licence key file is not required 

for upgrades from VibroSight 3.1.0. 

However, a new licence key file is required for upgrades from VibroSight 2.x.x. 

 

To obtain a new VibroSight licence key file or for further information on licence keys, contact Meggitt 

Sensing Systems customer support. See 7 Customer support. 

 

 

2 Features 

 VibroSight Configurator 

2.1 Changes to activating a configuration on a VibroSight Server 

VibroSight Configurator has been updated to improve how VibroSight Server configurations can be: 

 Uploaded and activated on (applied to) a VibroSight Server or VibroSight device(s). 

 Downloaded from (reverted to) a VibroSight Server. 

 

A new File > Apply changes to running configuration menu command is now used to upload and 

apply (activate) the latest (saved) version of the VibroSight Server configuration to the associated 

VibroSight Server or VibroSight device(s). This command is also available from an equivalent Apply 

changes to running configuration toolbar button. 

(These Apply changes to running configuration commands replace the File > Activate menu 

command and the equivalent Activate toolbar button that were previously available.) 

 

A new File > Revert to running configuration command is used to download the configuration 

running on the associated VibroSight Server to VibroSight Configurator, replacing (overwriting) the 

currently open VibroSight Server configuration. 

Note: The File > Revert to running configuration command is supported by VibroSight Servers only, 

that is, it is not supported by VibroSight device(s)). 

(This Revert to running configuration command can replace the use of the 

File > Open > Server / Database menu command that was previously used for an equivalent 

operation.) 

 



     

   
 

 

     

 

     
 10 / 53 Release Notes VIBROSIGHT-RN/E (660-010-013-220A) 

Release 3.2.0 – July 2017 
 

     
 

In addition, when working on a VibroSight Server configuration, the VibroSight Configurator status bar 

(bottom) displays information about the currently open configuration and its relationship with the 

associated VibroSight Server, as follows: 

The “Running configuration” text is used to provide configuration information on the version of the 

VibroSight Server configuration running on the associated VibroSight Server. This configuration 

information is equivalent to the running configuration information displayed on the VibroSight Server 

user interface. 

 

VibroSight Configurator examples: 

When a VibroSight Server configuration is initially saved as a file (*.vscfg), using the 

File > Save As > File command, no configuration information is displayed on the VibroSight 

Configurator status bar. 

When a VibroSight Server configuration is initially saved as a VibroSight Server (*.vshdf), using the 

File > Save As > Server / Database command, updated configuration information is displayed on the 

status bar, for example: 

Running configuration: R0 | There are pending changes to upload 

Note: After a new VibroSight Server configuration is initially saved as a VibroSight Server, there is a 

relationship between the currently open configuration the associated VibroSight Server. Initially, the 

“pending changes to upload” text is used to indicate that the VibroSight Server configuration must be 

activated using an Apply changes to running configuration command in order to make the 

VibroSight Server run the configuration. 

When the VibroSight Server configuration is then activated, using an Apply changes to running 

configuration command, updated configuration information is displayed on the status bar, for 

example: 

Running configuration: R0 | No pending changes to upload 

Note: The “no pending changes to upload” text is used to indicate that the configuration displayed in 

VibroSight Configurator is the same as the configuration running on the VibroSight Server. 

 

If the VibroSight Server configuration is then edited and saved, updated configuration information is 

displayed on the status bar, for example: 

Running configuration: R0 | There are pending changes to upload 

Note: The “pending changes to upload” text is used to indicate that the configuration displayed in 

VibroSight Configurator is not the same as the configuration running on the VibroSight Server. 

And if the edited VibroSight Server configuration is then activated, using an Apply changes to 

running configuration command, updated configuration information is displayed on the status bar, 

for example: 

Running configuration: R1 | No pending changes to upload 

Note: The “running configuration“ text has incremented in order to indicate that an updated version of 

the VibroSight Server configuration is now running on the VibroSight Server. And as before, the “no 

pending changes to upload” text is used to indicate that the configuration displayed in VibroSight 

Configurator is now the same as the configuration running on the VibroSight Server. 
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But if the changes made to the edited VibroSight Server configuration are not required, then the 

Revert to running configuration command can be used to download the running (active) 

configuration from the VibroSight Server, replacing (overwriting) the currently open VibroSight Server 

configuration, for example: 

Running configuration: R1 | No pending changes to upload 

 

 

2.2 Changes to configurations containing a VM600 CPUR card 

When a VibroSight Server configuration contains a VM600 rack and a CPUR rack controller and 

communications interface card (PNR 600-026-000-xxx) and an Apply changes to running 

configuration command is run in order to upload and activate (apply) the configuration to a VibroSight 

Server, the CPUR card itself will only be reconfigured: 

 If the configuration of any VM600 XMx16 cards that are being managed by the CPUR card have 

changed. 

 Or if the VM600 CPUR card’s own configuration has changed. 

That is, before activating a configuration containing a VM600 CPUR card, VibroSight Configurator 

reads back the current active configuration running on a CPUR card and compares it with the 

configuration to be activated, so that it will only reconfigure the CPUR if it is necessary. 

In addition, if it is necessary to reconfigure a VM600 CPUR card, VibroSight Configurator will prompt 

the user with a CPUR activation confirmation message, warning them that the CPUR card will be 

reconfigured (which temporarily interrupts the operation of the CPUR card) and requiring confirmation 

(OK) before continuing with the reconfiguration. 

In this way, the operation of the VM600 CPUR card is only ever interrupted when it is necessary and 

when the user is aware of the interruption. This change increases system availability to any third-party 

systems such as a DCS or PLC, which is particularly important when the CPUR card is part of a 

control loop for monitoring and/or protection applications, for example, machinery protection 

applications using a VM600 CPUR card as a communications interface for VM600 MPC4 machinery 

protection cards. 

(Previously, for a VibroSight Server configuration containing a VM600 CPUR card, the CPUR card 

was always reconfigured when activating the configuration.) 

 

Also related to this change, it should be noted that the configuration of any VM600 XMx16 cards that 

are being managed by a CPUR card can now only be read back via the associated VibroSight Server. 

That is, the configuration of XMx16 cards managed by a CPUR card can no longer be read back 

directly from the cards themselves (as such XMx16 cards are not the “master” of their configurations). 

If VibroSight software such as VibroSight Vision or VibroSight Configurator is used to read back a 

configuration from a VM600 XMx16 card that is being managed by a CPUR card, then the software 

will display an “empty configuration”. 

 

 



     

   
 

 

     

 

     
 12 / 53 Release Notes VIBROSIGHT-RN/E (660-010-013-220A) 

Release 3.2.0 – July 2017 
 

     
 

2.3 Machine states (machine operating conditions) and transient machine 
states 

VibroSight Configurator has been updated to improve how machine states (machine operating 

conditions) are configured and handled. 

NOTE: VibroSight Configurator now uses the term “machine states” to be consistent with 

VibroSight Vision, replacing the use of “machine operating conditions”. 

 

VibroSight Configurator now supports two types of machine state for use throughout a monitoring and 

protection system, as follows: 

 Machine state – Individual machine states used to configure and detect the typical machine 

states associated with the steady-state operation of a machine. 

Note: Machine states, previously known as machine operating conditions, provide the same 

functionality as before. 

 Transient machine states –Transient machine states used to configure and detect the typical 

machine states associated with the transitory operation of a machine, that is, run-ups, run-

downs, aborted run-ups and aborted run-downs. 

Note: Transient machine states are a new type of machine state that provide new functionality 

that supports the analysis of transient conditions. 

 

Both types of machine state are configured in the Machinery view of VibroSight Configurator, at the 

Machine unit level, under either the Configuration root or a Facility unit level. 

In the Machinery view, right-click on the Configuration root node or a Facility unit node, then click 

New machine unit. 

Note: When a Machine unit is added to the configuration, a Machine states node (subfolder) is 

automatically added under the machine unit. 

In the Machinery view, right-click on the Machine states node, then click New machine state or 

New transient machine states as appropriate. 

 

Machine state 

To configure an individual Machine state, select it in the Machinery view, then configure the 

parameters for the machine state in the main working area (centre), including Name, State and Color. 

Note: The colour configured for an individual machine state is associated with the machine state 

throughout VibroSight, for example, to be used in VibroSight Vision plots. 

For example, to configure a simple machine state: 

Right-click in the Condition data entry area and click Add data condition on the shortcut menu that 

appears. 

A template line for a data condition is added in the data entry box. 

Click (anywhere) on the data condition template line to enter the required information for the condition: 

select the data entity, relational operator, quantity and units from the drop-down boxes and enter any 

required data values. 

The template line for the data condition displays the updated condition. 
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For example, to configure a more complex machine state:  

Right-click in the Condition data entry area and click Add group on the shortcut menu that appears. 

By default, an AND group is added in the data entry box. 

Right click on the group and select one of the other logical groups on the shortcut menu that appears 

in order to change the logical operation of the group. 

Right-click on the group and and click Add data condition. 

A template line for a data condition is added to the (logical) group at a lower-level in the tree structure. 

Alternatively, right-click on the group and click Add group. 

Another AND group is added to the (logical) group at a lower-level in the tree structure. Right click on 

the group to change the logical operation of the group. 

Similarly, Add point alarm state condition and Add machine state condition can be used to add 

and configure machine states based on individual alarms and machine states. 

NOTE: Repeatedly using the Add group, Add data condition, Add point alarm state 

condition and Add machine state condition commands allows a tree structure of 

(logically) combined conditions to be created. Any number of data conditions and 

subgroups can be added to a group in a tree structure to create a complex 

combined conditional machine state. 

 

Transient machine states 

Transient machine states are automatically generated based on the analysis of one Measurement (a 

single data entity) configured with an amplitude profile defined by an upper limit and a lower limit, as 

follows: 

 A Run-up transient machine state occurs when the measurement value enters the amplitude 

range by crossing the lower limit and leaves it by crossing the upper limit. 

That is, value < lower limit followed by value > upper limit. 

 An Aborted run-up transient machine state occurs when the measurement value enters the 

amplitude range by crossing the lower limit and leaves it by crossing the lower limit in the 

opposite direction (before crossing the upper limit). 

That is, value < lower limit followed by value > lower limit followed by value < lower limit. 

 A Run-down transient machine state occurs when the measurement value enters the amplitude 

range by crossing the upper limit and leaves it by crossing the lower limit. 

That is, value > upper limit followed by value < lower limit. 

 An Aborted run-down transient machine state occurs when the measurement value enters the 

amplitude range by crossing the upper limit and leaves it crossing the upper limit in the 

opposite direction (before crossing the lower limit). 

That is, value > upper limit followed by value < upper limit followed by value > upper limit. 

To configure the Transient machine states, select it in the Machinery view, then configure the 

parameters for the transient machine states in the main working area (centre), including Name, State 

and Measurement. 

Note: The measurement typically used to configure transient machine states is speed, although other 

parameters can be used, such as process control system values imported into the VibroSight system. 
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For the measurement, configure the values and units (… limits) to define the upper limit and the lower 

limit of the amplitude profile. And configure the colour and name for each transient machine state 

(Run-up, Aborted run-up, Run-down, Aborted run-down are default names for the Transient machine 

states and can be changed if required). 

Note: The colour configured for an individual transient machine state is associated with the transient 

machine state throughout VibroSight, for example, to be used in VibroSight Vision plots. 

 

Examples 

If the measurement value was below the lower limit and then rises above it, the transient machine 

state is initially detected by VibroSight as a Run-up. If the value continues to rise beyond the upper 

limit, VibroSight will classify the transient machine state as a Run-up. However, if the value reverses 

and falls below the lower limit, VibroSight will retro-actively classify the transient machine state as an 

Aborted run-up. 

If the measurement value was above the upper limit and then falls below it, the transient machine 

state is initially detected by VibroSight as a Run-down. If the value continues to fall beyond the lower 

limit, VibroSight will classify the transient machine state as a Run-down. However, if the value 

reverses and rises above the upper limit, VibroSight will retro-actively classify the transient machine 

state as an Aborted run-down. 

 

It is important to note that the Aborted run-up and Aborted run-down transient machine states are not 

available for use by data logging rules using conditions (machine state conditions). This allows 

Aborted run-ups and Aborted run-downs to be more specifically excluded from a VibroSight data 

repository if required. 

 

 

2.4 New consistency check 

The Consistency checker has been improved to include a new check for the configuration of Basic 

Math Processing Block data entities. 

The Consistency checker now checks Basic Math Processing Block mathematical expressions to see 

if the variables (extracted data entities) used in an expression use the same data update rate (that is, 

the Standard update rate for VM600 cards and/or VibroSmart modules). 

If a mathematical expression uses variables that do not have the same data update rate, then the 

Consistency checker will not block the configuration but it will display a warning message such as: 

Computation issues with Scalar Data Entity can happen with input data 

coming from different devices or processings if they are not synchronized 

(same data rate). 

NOTE: VibroSight requires that the optional Mathematical outputs application specific 

package is licensed in order to configure and use basic math processing. 
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2.5 Multi-edit mode 

The behaviour and usability of VibroSight Configurator in multi-edit mode (View > Multi edit mode) 

has been improved, as follows: 

 The width of the columns now automatically adjust in order to optimise the display of data. 

 Problems selecting multiple rows and editing parameters (Properties) have been corrected. 

 Problems double-clicking certain parameters have been corrected. 

 Alarms are now supported. 

 Events are now supported. 

 Duration counters are now supported. 

 Modbus is now supported. 

 OPC is now supported. 

 Combustion monitoring is now supported. 

For example, combustion monitoring post-processing block parameters such as Spectra, 

Band aggregation extractions and Peak hold spectra processing. 

NOTE: VibroSight requires that the optional Combustion monitoring application specific 

package is licensed in order to configure and use combustion monitoring 

processing. 
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 VibroSight Server 

2.6 Changing the name of a VibroSight Server 

When a VibroSight Server is initially created, it is given a name (Server instance name) that is 

subsequently used to uniquely identify that VibroSight Server. 

After a VibroSight Server after it has been created, it is now possible to change its name in the 

following way: 

1. In VibroSight Server, click Tools > Options. 

2. In the VibroSight Server Options window that is displayed, under Environment, select 

General. 

3. Edit the Server instance name text box, then click OK to apply the new name to the VibroSight 

Server. 

Note: Changing the name of a VibroSight Server requires that the VibroSight Server 

temporarily stops. 

NOTE: VibroSight Server instance names are limited to 18 characters, so the Server 

instance name text box is limited to 18 characters. 

VibroSight allows only alphanumeric characters (A to Z, a to z, 0 to 9), the hyphen-

minus character ( - ) and the underscore character ( _ ) to be used for VibroSight 

Server names. 

It is recommended to choose appropriate VibroSight Server names in order to 

avoid name conflicts arising due to truncation and/or additional databases being 

created during automatic data management. 

 

4. The VibroSight Server will automatically stop (which temporarily interrupts the operation of the 

server), change its name, then restart using the new name. 

 

If a VibroSight software client such as VibroSight Vision or VibroSight System Manager is connected 

to a VibroSight Server when its name (Server instance name) is changed, communications between 

the client and the server will temporarily be interrupted when the VibroSight Server changes its name. 

However, the VibroSight software clients will automatically reconnect to the restarted VibroSight 

Server using the new name, allowing operation to continue as before. For example, live data will 

resume display in VibroSight Vision and VibroSight Mimic. 

The ability to rename a VibroSight Server in this way makes it easier to use one VibroSight Server as 

the basis for other VibroSight Servers, for example, where the monitoring system configurations are 

very similar. 

(Previously, after a VibroSight Server was created, it was not possible to change its name (Server 

instance name).) 
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2.7 Changes to the configuration information displayed by VibroSight Server 

The configuration information displayed by VibroSight Server has been changed to use 

Running Configuration (previously, Config. revision was used.) 

See also 2.1 Changes to activating a configuration on a VibroSight Server. 

 

 

 VibroSight Vision 

2.8 Plot measurement identifiers (channel identification) 

The behaviour of all plots has been changed in order to support the display of measurement identifiers 

(paths) in the plot legend in one of two ways: 

Full hardware or machinery view path – Displays the full identifier (path) for each measurement 

using either: 

 The Facility unit, Machine unit, Shaft, Stage / Bearing plane, and Point names from the 

hierarchical tree-structure information configured in the Machinery view. 

 The VM600 rack / VibroSmart measurement block, VM600 card / VibroSmart module, and 

processing block names from the hierarchical tree-structure information configured in the 

Hardware view. 

Channel name only – Displays a short identifier (path) for each measurement using either: 

 The Point name from the hierarchical tree-structure information configured in the Machinery 

view. 

 The processing block name from the hierarchical tree-structure information configured in the 

Hardware view. 

In addition, there is an Auto option (the default option) that automatically selects and applies either the 

Full hardware or machinery view path or Channel name only option in order to optimise the display 

of data. More specifically, the Channel name only option is used if all Point names or processing 

block names are different, otherwise the Full hardware or machinery view path option is used. 

 

NOTE: For the measurements in a plot, the plot legend: 

• Displays the common part of the measurement identifiers (paths) in the legend 

title (top) using the format Legend | … > … . 

• Displays the unique parts of the measurement identifiers (paths) in the individual 

legend entries (rows= using the format … > … . 
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A new VibroSight Vision option, available from the Tools > Options menu, is used to select between 

Auto, Full hardware or machinery view path or Channel name only: 

1. In VibroSight Vision, click Tools > Options menu command. 

The Options window for VibroSight Vision is displayed. 

2. Select General from the tree-structure view (left). 

3. Under Channel identification (right), use the Channel identification control to select the type 

of identifier (path) to be used for plots. 

4. Click OK to apply any changes and close the Options window. 

NOTE: The ability to display a measurement identifier (path) in these different ways will be 

extended to the other VibroSight Vision plot types in the future. 

 

(Previously, plots only supported the display of measurement identifiers (paths) in a single way, 

equivalent to the new Full hardware or machinery view path option.) 

 

 

2.9 Table plot layout 

The behaviour of the Table plot has been changed in order to support the display of measurements 

(static data) in one of two ways: 

 Arrange by columns – Displays the measurements on a predominantly column-by-column 

basis, that is, multiple columns of multiple measurements (extracted data) grouped per 

processing block, with a single row per processing block. This typically results in a “landscape” 

view of measurements (wider than it is long). 

 Arrange by rows – Displays the measurements on a predominantly row-by-row basis, that is, 

the one, two or three columns of a single measurement (extracted data) per processing block, 

with multiple rows per processing block. This typically results in a “portrait” view of 

measurements (longer than it is wide). 

In addition, there is an Autolayout option (the default option) that automatically selects and applies 

either the Arrange by columns or Arrange by rows option in order to optimise the display of data by 

minimising “empty” table cells. More specifically, the Arrange by columns option is used if more than 

50% of the individual table cells are used, otherwise the Arrange by rows option is used. 

A new plot control, available at the bottom of the plot, is used to select between Autolayout, Arrange 

by columns or Arrange by rows. 

(Previously, the Table plot only supported the display of measurements in a single way, equivalent to 

the new Arrange by columns option.) 
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2.10 Table plot and duration counters 

A duration counter can be configured for a measurement in order to measure for how long the 

measurement is beyond a particular threshold level. Multiple duration counters with different 

thresholds can be configured per measurement (extracted data entity) and multiple measurements 

can be configured per processing block associated with an input channel. 

Accordingly, the behaviour of the Table plot has been changed in order to automatically adapt to and 

display duration counters in one of two ways: 

 For duration counters with a common measurement (data entity) path – Duration counters are 

displayed in multiple columns ordered by threshold, with a single row per data entity path. 

 For duration counters with a common input channel path – Duration counters are displayed in 

multiple columns ordered by data entity, with a single row per input channel path. 

The Table plot control used to select between Autolayout, Arrange by columns or Arrange by rows 

does not affect the display of duration counters. See also 2.8 Plot measurement identifiers (channel 

identification). 

(Previously, the Table plot did not adapt well to the display of duration counters, with the result that 

they could be difficult to read, depending on the number of duration counters in the table plot.) 

 

2.11 Table plot units and qualifiers 

The behaviour of the Table plot has been changed such that when Arrange by columns is selected 

(or Autolayout selects Arrange by columns), if the units and qualifiers (rectifiers) are the same for all 

of the measurements in a column, then the units and qualifiers (rectifiers) are displayed in the column 

header/title, rather than in the individual table cells. 

NOTE: Although this change affects most units and qualifiers (rectifiers), some units such 

as ° (degrees) and % (percentage) continue to be displayed in individual table 

cells. 

 

(Previously, all units and qualifiers (rectifiers) were always displayed in the individual table cells.) 
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2.12 New Corbit plot 

A new plot type – the Corbit plot (cascaded orbit) – has been added to the catalogue of plots available 

in VibroSight Vision. 

The Corbit plot provides an additional way to display and analyse orbits and filtered orbits from 

measurement devices such as the VM600 XMx16 cards and the VibroSmart VSV300 module. 

Basically, the Corbit plot is a 3D plot that displays multiple individual orbits on the same plot as a 

function of time or speed (comparable to how the Waterfall/Cascade plot is a 3D plot that displays 

multiple individual spectra on the same plot as a function of time or speed). 

NOTE: The Corbit plot displays multiple orbits on the same 3D plot as a function of time or 

speed. A Corbit plot typically consists of many individual orbits or filtered orbits 

superimposed one on top of another for the selected Time Range. 

The Orbit plot displays a series of individual orbits or filtered orbits, optionally with 

their waveforms, on the same 2D plot as a function of time or revolutions for the 

selected Time Range. 

 

To add a Corbit plot, either: 

 Click the  Corbit plot icon on the VibroSight Vision toolbar. 

 Use the File > Add new plot > Corbit plot VibroSight Vision menu command. 

 Use the Add new plot > Corbit plot command in the VibroSight Vision Project Explorer tool 

window and (right-click on a View and use the shortcut menu that appears). 

 

To add measurement data to a Corbit plot: 

 Select an Orbit measurement (standard or filtered) in the Hardware view or Machinery view and 

drag it to the Corbit plot. (A Time Range must also be selected before VibroSight Vision can 

display a plot.) 

NOTE: Each Corbit plot can display multiple orbits for the same Orbit measurement 

(standard or filtered) on a single 3D plot. 

Each Corbit plot can also multiple orbits for multiple Orbit measurements (standard 

and/or filtered) on multiple 3D plots using the plot grid/layout control, available at 

the bottom of the plot. For example, grids of 1 x 1, 1 x 2, 2 x 1, 2 x 2, … corbits. 

 

For a Corbit plot, the main cursor in the plot legend uses “amplitude @ angle” to give the maximum 

amplitude and the associated angle for the selected (highlighted) orbit. 
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When working with a Corbit plot: 

 Use the UP ARROW and DOWN ARROW keys to move the cursor and navigate through the 

orbits that make up the Corbit plot (with respect to Time or Speed). 

 Use the LEFT ARROW and RIGHT ARROW keys to move the cursor and navigate through the 

individual measurements that make up an orbit. 

 Use CTRL + LEFT ARROW to move the cursor to the earliest visible data item in Time. 

 Use CTRL + RIGHT ARROW to move the cursor to the latest visible data item in Time. 

 Left-click and drag the pointer in the plot to change the viewing angle (rotate/orbit the plot in three 

dimensions). 

 Right-click and drag the pointer in the plot to move the plot in the plot document. 

 Rotate the mouse wheel forwards/backwards to zoom in/out. 

 Use the ESC key to restore the viewing angle, positioning and zoom level in the plot to their 

default values. 

 As ever, right-click in the plot to access shortcut menus such as Plot properties, 

Hide/Show legend and Export plot data. 

 

NOTE: Whenever a plot is updated in VibroSight Vision (for example, creating a new plot, 

changing the time range settings or zooming an existing plot), VibroSight 

automatically processes (“filters”) the measurement data using super-fast 

algorithms in order to optimally select the measurement data points required to 

accurately display the data in the plot. 

 

Application tips and tricks 

The Corbit plot can be used to quickly see and examine the overall envelope (shape) of an orbit to see 

how it changes against time or speed, for example, to examine a particular bearing. A Corbit plot can 

also display multiple orbits for multiple Orbit measurements, for example, in order to allow bearings to 

be investigated in more detail or compared. (Note: When a Corbit plot is used to display multiple 

corbits, the corbits are synchronised such that navigation and display changes made to one corbit are 

applied to the corbits in the plot.) 

The particular data of interest can then be analysed in more detail by using other plot types. 

Accordingly, a useful way of working with Corbit plots is in combination with Orbit plots, using cursor 

synchronisation between the plots. For example, navigating through the Orbit plot and selecting an 

orbit, automatically highlights the relevant orbit in the Corbit plot. 
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2.13 Data export from plots 

The export of data from plots has been updated to include support for the following: 

 Full data export (static data and/or dynamic data) of all VibroSight Vision plot types, including 

spectra, to Microsoft 
®
 Excel 

®
 or the comma-separated values file format (*.csv). 

NOTE: Data export to Excel supports a maximum of 1 048 576 lines with Excel 2007 or 

later. 

If the data being exported exceeds the maximum number of lines, VibroSight 

Vision will display a warning to indicate that not all lines have been exported due to 

Excel limitations. 

 

 Data export of waveforms to the waveform audio file format (*.wav). 

This new feature is primarily intended for the playback of waveforms as input signals for 

development and test purposes. 

The VibroSight Vision data export tool now supports the following data export options: 

 Interpolate data and Data resolution. 

For example, the Data resolution option allows more data to be exported than is currently 

loaded into VibroSight Vision. 

 The ability to edit the time range and/or the data selected to the exported. 

 The use of file name prefixes and folders to help organise the exported data files. 

 

In addition, the same VibroSight Vision data export tool is now accessed via the menu bar 

(Tools > Export) and from a plot (right-click, then Export plot data). 
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3 Solved problems and bug fixes 

General 

3.1 Improvements and bug fixes 

General stability improvements across the VibroSight 3.2.0 software. 

 

3.2 Data and/or machine states not logged to the data repository 

Machinery monitoring systems running VibroSight software version 3.x.x that used a data repository 

(database) for data logging were affected by a problem whereby certain system operations 

unexpectedly prevented data and/or machine states (machine operating conditions) from being logged 

to the data repository: 

The problem could be triggered by two different VibroSight operations: 

 In VibroSight Server – by stopping and starting the data logging functionality of a running 

VibroSight Server (using the Data Logging Manager disable/enable control). 

 In VibroSight Configurator – by activating a new VibroSight Server configuration (using the 

Activate control). 

However, after the issue happens, as soon there is one single machine state change, the data and/or 

machine states related to that machine are again correctly logged to the data repository. 

For further information on this problem, refer to the service bulletin on VibroSight software and Data 

and/or machine states not logged to the data repository (VibroSight software-001, May 2017). 
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4 Known issues 

4.1 Display of timestamps in VibroSight Vision 

In VibroSight Vision, when the timestamps (date and time) are configured to be displayed as Site time 

or Local computer time and the site time or local computer time is subsequently changed on the 

relevant computer (for example, using Windows > Control Panel > Date and Time), this change is not 

reflected in the VibroSight Vision user interface until the user clicks on the Timestamp displayed in 

the VibroSight Vision status bar. 

 

4.2 VibroSight Server and Host Service restart required after changes to 
network adapter 

If the configuration of a network adapter is changed (for example, enabled or disabled, connected or 

disconnected) on a computer running VibroSight, then the VibroSight Servers and Host Services 

running on the computer must be restarted in order for the network adapter to be recognized by the 

VibroSight discovery mechanism. 

 

4.3 Length limitation of VibroSight Server instance names 

Since VibroSight 2.9.6, VibroSight Server instance names are limited to 18 characters, whereas up to 

27 characters were allowed in previous versions. This constraint is enforced during the creation of new 

server instances with VibroSight 2.9.6 or later. 

NOTE: VibroSight allows only alphanumeric characters (A to Z, a to z, 0 to 9), the 

hyphen-minus character ( - ) and the underscore character ( _ ) to be used for 

VibroSight Server names. 

 

However, existing server instances may be non-compliant (too long) and no longer run after an 

upgrade of the VibroSight software. In such cases, the file names used for the VibroSight Server 

database file (*.vssrvdb or *.db) and the VibroSight Server configuration file (*.vssrvcfg or 

*.config) should be updated (and manually edited in the VibroSight configuration file) to be 

18 characters or less. Changes may also be required in any VibroSight software that references the 

server instance name, such as VibroSight Vision projects. 

Where used, the automated database copies append a timestamp (_yyyyMMddHHmmss) to the 

Server instance name which reduces the number of file name characters that remain available for 

VibroSight Server instance names to three. Alternatively, the server instance name can be shorted 

after the database copy is complete. 

Also, depending on the VibroSight Server database file names used and any truncation performed by 

VibroSight, it is possible that servers are created with names that contain non-allowed characters 

(such as spaces), with the result that these servers will not be accessible by VibroSight software 

clients. Similarly, duplicate VibroSight Server names are also possible. 
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NOTE: Choose appropriate VibroSight Server names in order to avoid name conflicts 

arising due to truncation and/or additional databases being created during 

automatic data management. 

This is particularly important for systems with automated data management and 

system backup procedures that use script files containing database commands 

(such as copy and backup) that can automatically generate VibroSight Server 

database files. 

 

4.4 VibroSight client connections to local and remote VibroSight Servers are 
mutually exclusive 

When a VibroSight Server is running on a (local) computer, a VibroSight client, such as VibroSight 

Configurator or VibroSight Vision running on the same (local) computer cannot connect to a VibroSight 

Server running on a different (remote) computer. 

 

4.5 VibroSight Servers listen to a single IP address 

A VibroSight Server uses one specific IP address for connections to VibroSight clients and all 

communications is directed through this VibroSight Server IP address. This IP address can be set to 

any of the available network adapters or logical addresses on the host computer running the 

VibroSight Server. On a computer with a single network adapter, the IP address of the single network 

adapter is used by default. 

In typical applications, the network adapter of the host computer running the VibroSight Server is 

connected to a dedicated control (industrial) Ethernet network that contains the VibroSight-compatible 

hardware such as VM600 XMx16 cards and VibroSmart devices. 

However, as a VibroSight Server uses one specific IP address (network adapter), this prevents 

concurrent connections from VibroSight clients running on other separate networks, such as a 

business (corporate) Ethernet network. 

See also 4.11 VibroSight Server communication errors. 

 

4.6 Display of timestamps in VibroSight clients other than VibroSight Vision 

Although VibroSight Vision now supports the display of timestamps (date and time) as either Site time, 

UTC time or Local computer time, all other VibroSight client software modules continue to display 

timestamps in local computer time only (that is, the date and time according to the local clock of the 

computer running the VibroSight software module). 

 

4.7 Display of devices in VibroSight System Manager 

In the System Explorer window of VibroSight System Manager, the Devices tree-view does not always 

update correctly to show all of the devices (VM600 cards and VibroSmart devices) available on the 

network. 
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In particular, this has been seen when changing the firmware of a device, and can persist even after a 

refresh (using the Refresh toolbar button or View > Refresh). 

If this behaviour is seen, the recommended workaround is to: 

 Wait a few minutes and refresh again. 

 Restart VibroSight System Manager. 

 

4.8 VibroSight Mimic backwards compatibility 

VibroSight 2.10.0 contained significant improvements and changes, including a separate VibroSight 

Mimic client software module for mimics (that were previously available in VibroSight Vision). As a 

result, VibroSight Vision mimics created with VibroSight 2.9.7 or earlier are not compatible with 

VibroSight 2.10.0 or later. 

VibroSight 2.11.0 contained significant improvements and changes to the VibroSight Mimic client 

software module. As a result, VibroSight Vision mimics created with VibroSight 2.10.1 or earlier are 

not compatible with VibroSight 2.11.0 or later. 

VibroSight 2.11.5 contained significant improvements to the VibroSight Mimic project framework to 

include version information, in order to improve the compatibility between projects created with 

different versions of VibroSight Mimic and eliminate the requirement for the recreation of Mimics. 

Starting with VibroSight 2.11.5, Mimic projects automatically detect any changes in the VibroSight 

Mimic software that affect project compatibility, inform the user and update the project as required. 

NOTE: VibroSight 2.11.5 is also able to open and work with Mimic projects created with 

VibroSight 2.11.0 or later, if the corresponding database had been updated as 

required. 

 

NOTE: When updating existing machinery monitoring projects created with 

VibroSight 2.12.x to VibroSight 3.2.0, a new data repository created by copying a 

VibroSight database (*.vssrvdb) to a VibroSight historical data folder (*.vshdf) 

must use the same server file name as the existing server in order for existing 

VibroSight Mimics to maintain links with the data repository and continue to work 

(without manual corrections). 

In addition, the VibroSight Server using the new the new data repository must be 

running before the existing VibroSight Mimics are run for the first time, after the 

update. 

 

4.9 VibroSight OPC Clients not recovering 

When a VibroSight OPC Client is being used to import information from an external OPC server into a 

VibroSight system and the external OPC server becomes unavailable, the VibroSight OPC Client may 

not always recover automatically when the OPC server becomes available again. 
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This is typically characterised by the VibroSight OPC Client continuing to show connection error 

messages even when OPC server is available and can result in permanent loss of the imported data if 

not noticed. 

NOTE: The external OPC data can be permanently lost if it is not imported into VibroSight 

as expected. 

Any VibroSight system feature or configuration element relying on the imported 

OPC data will not behave as expected, for example, alarms, machinery operating 

conditions and data logging rules. 

 

If this behaviour is seen, the recommended workaround is to: 

 Stop and restart the VibroSight OPC Client from either the VibroSight Server 

(Data > Acquisition > OPC Device Driver) or VibroSight System Manager. 

 Stop and restart the VibroSight Server, if required. 

 

4.10 Duplicate events 

For VibroSight systems using VM600 XMx16 cards, VibroSight Event Viewer retrieves all of the event 

information available from the data buffers on the cards. 

For VibroSight systems using VibroSmart modules, VibroSight Event Viewer retrieves the event 

information available from the current time only (no buffered events). 

Accordingly, for a VibroSight system using VM600 XMx16 cards, there is the possibility of duplicate 

events being listed in the Event Viewer, particularly for VibroSight systems being operated without an 

NTP server (where events are not recognised as duplicates due to time drift). 

 

4.11 VibroSight Server communication errors 

Under rare circumstances, when a computer running VibroSight clients has two network adapters 

(cards) installed, communications errors with a VibroSight Server are possible. 

See also 4.5 VibroSight Servers listen to a single IP address. 

 

4.12 VibroSight Server status indicators 

The status indicators (performance counter monitors) on the Status tab of the new VibroSight Server 

are not correctly displayed and updated when an NVIDIA WMI driver is installed on the same 

computer as the VibroSight Server. 

NOTE: The NVIDIA Enterprise Management Toolkit (NVWMI) is a graphics and display 

management and control technology that interfaces to Microsoft’s Windows 

Management Instrumentation (WMI) infrastructure, specific to NVIDIA graphics 

processing units (GPUs). 
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This is because NVIDIA WMI prevents the Microsoft .NET Framework from obtaining the required 

counter values from the underlying operating system / computer. 

 

4.13 XMx16 card pre-logging 

For an XMx16 card pair, if Dynamic Input Channel 16 is used as an input to a Dynamic Processing 

Block that is used as an input to a Dual Shaft Relative Processing Block which is configured to provide 

an Orbit and/or Full Spectrum output, then any pre-logging configured for the principal mode 

Waveform and/or Spectrum of Dynamic Input Channel 16 will not actually log any of the data from the 

same pre-logging scope. 

 

4.14 Problems creating new VibroSight OPC Servers 

Users who have upgraded from an earlier version of VibroSight to a later version (for example, from 

VibroSight 2.x.x or 3.0.0 to VibroSight 3.1.0) can experience problems when creating new VibroSight 

OPC Servers. 

Such problems are typically characterised by the OPC Server Create command in VibroSight System 

Manager displaying an error message such as 

“The type initializer for ‘ch.VibroMeter.Xms.OpcServer.Utils.OpcServerUtils’ 

threw an exception”. 

This typically occurs because an earlier version of the OpcServer.config file required by VibroSight 

OPC Servers is being used by the later installation of VibroSight, which can happen in one of two 

ways: 

 When a later version of VibroSight 3.x.x is installed on a computer that was running an earlier 

version of VibroSight 2.x.x, the VibroSight installer automatically checks existing VibroSight folders 

(such as C:\ProgramData\Meggitt\VibroSight 2) in order to copy relevant system and/or user 

preference files across to the new VibroSight folders (such as 

C:\ProgramData\Meggitt\VibroSight), including an earlier OpcServer.config file. 

 When VibroSight 3.1.0 is installed on a computer that was running VibroSight 3.0.0, the creation of 

a VibroSight OPC installer using VibroSight 3.0.0 automatically created an earlier 

OpcServer.config file. 

As shown below, the first few lines of a typical OpcServer.config file contains version specific 

information that is incompatible with later versions of VibroSight: 

<?xml version="1.0" encoding="utf-8"?> 

<configuration> 

  <configSections> 

    <section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Version=2.0.0.0, Culture=neutral, 

PublicKeyToken=2db2a2387bac0a0a" /> 

  </configSections> 

… 

</configuration> 

 



     

 
 

   

     

 

     
 Release Notes VIBROSIGHT-RN/E (660-010-013-220A) 

Release 3.2.0 – July 2017 29 / 53  

     
 

So for users who have upgraded from an earlier version of VibroSight to a later version, if problems 

are experienced when creating new VibroSight OPC Servers, the workaround is to: 

 

1. Use an XML-compatible text editor program to edit the OpcServer.config file and remove the 

version specific information. That is, change the line containing the section name 

from: 

<section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Version=2.0.0.0, Culture=neutral, 

PublicKeyToken=2db2a2387bac0a0a" /> 

to: 

<section name="opcServersConfiguration" 

type="ch.VibroMeter.Xms.OpcServer.Utils.OpcServersSystemConfiguration, 

XmsOpcServerUtils, Culture=neutral, PublicKeyToken=2db2a2387bac0a0a" /> 

 

2. Restart the computer. 

    Note: The computer must be restarted to ensure that the edited version of the OpcServer.config 

    file is used (and not some other version from cache memory). 

 

3. Use the OPC Server Create command in VibroSight System as required. 

 

NOTE: The manual migration of existing VibroSight OPC Servers to VibroSight 3.x.x is 

described in detail in the “VibroSight OPC Server migration” section of the latest 

 Getting started with VibroSight installation guide. 
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5 Compatibility 

As part of the VibroSight software installation process, the VibroSight installer will automatically check 

to see if the required Microsoft .NET Framework (see section 5.1.2), Microsoft Visual C++ 

Redistributable Package (see section 5.1.3) and OPC Core Components Redistributable 

(see section 5.1.4) are pre-installed. 

The required Microsoft .NET Framework and Microsoft Visual C++ Redistributable Package must be 

manually installed on the computer before VibroSight can be installed. If the required Microsoft .NET 

Framework and Microsoft Visual C++ Redistributable Package are not pre-installed, then the 

VibroSight installer will detect this and exit the installation. 

If not already installed, the required OPC Core Components Redistributable software is automatically 

installed on the computer by the VibroSight installer. 

NOTE: Refer to the latest version of the  Getting started with VibroSight installation 

guide or the  VibroSight software data sheet for further information on 

VibroSight’s prerequisites and compatibility. 

 

5.1 VibroSight software 

VibroSight 3.2.0 is a minor level release and replaces VibroSight 3.1.0. 

Compatibility with existing VibroSight data repositories (databases) is achieved using a specific data 

migration process from any existing databases based on Sybase SQL Anywhere (*.vssrvdb) to data 

repositories based on the VibroSight historical data repositories (VibroSight historical data folders 

(*.vshdf) for operation with a VibroSight Server (live data) and VibroSight historical data archives 

(*.vshda) for operation with historical data). 

Compatibility with existing VibroSight machinery monitoring projects using VibroSight OPC Servers 

that were created using VibroSight 2.12.7 or earlier is achieved using a specific VibroSight OPC 

Server migration process for these VibroSight OPC Servers. 

Therefore, it is important to note that: 

 New machinery monitoring projects created with VibroSight 3.x.x will automatically use VibroSight 

historical data repositories. 

 Existing machinery monitoring projects created with versions of VibroSight earlier than 

VibroSight 3.0.0 must be manually migrated from Sybase SQL Anywhere databases to VibroSight 

historical data repositories before they can be used with VibroSight 3.x.x. 

 Existing machinery monitoring projects using VibroSight OPC Servers that were created with 

versions of VibroSight earlier than VibroSight  2.12.7 must manually migrate their VibroSight OPC 

Servers before they can be used with VibroSight 3.x.x. 

It is very important to note that migrating a VibroSight OPC Server from VibroSight 2.12.7 or 

earlier to VibroSight 3.x.x requires that certain steps must be performed using the existing version 

of VibroSight (that is, VibroSight 2.12.7 or earlier) BEFORE it is removed (uninstalled). 
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NOTE: The manual migration of an existing machinery monitoring project to 

VibroSight 3.x.x is described in detail in the “Data migration” and “VibroSight OPC 

Server migration” sections of the latest  Getting started with VibroSight 

installation guide. 

 

5.1.1 Microsoft Windows operating systems 

VibroSight 3.x.x is compatible with 32-bit versions and 64-bit versions of Microsoft 
®
 Windows 

®
 

operating systems. 

NOTE: Starting with VibroSight 3.0.0, VibroSight software is now available as 64-bit 

software for 64-bit Windows and 32-bit software for 32-bit Windows. 

The 64-bit version of VibroSight can be installed on 64-bit Windows computers 

only. The 32-bit version of VibroSight can be installed on 32-bit Windows 

computers only. Only a single version of VibroSight can be installed and exist on a 

computer at any one time 

 

See the appendix of this document for detailed information on VibroSight software and Windows 

operating system compatibility. 

 

5.1.2 Microsoft .NET Framework 

For most Windows operating systems, VibroSight 3.x.x or later requires that the Microsoft .NET 

Framework 4.6 or later is installed. 

NOTE: VibroSight 3.x.x requires Microsoft .NET Framework 4.6. 

 

If the required Microsoft .NET Framework is not pre-installed, then the VibroSight installer will detect 

this and exit the installation. 

See the appendix of this document for detailed information on VibroSight software’s Microsoft .NET 

Framework requirements. 

 

5.1.3 Microsoft Visual C++ Redistributable Package 

VibroSight 3.x.x requires that the Microsoft Visual C++ Redistributable Package for Visual Studio 2015 

is installed, in order to install and register the Visual C++ libraries used by VibroSight. 

NOTE: The 64-bit version of the Microsoft Visual C++ Redistributable Package (“Microsoft 

Visual C++ 2015 Redistributable (x64)”) must be installed on 64-bit Windows 

computers. 

The 32-bit version of the Microsoft Visual C++ Redistributable Package (“Microsoft 

Visual C++ 2015 Redistributable (x86)”) must be installed on 32-bit Windows 

computers. 
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If the required Microsoft Visual C++ Redistributable Package is not pre-installed, then the VibroSight 

installer will detect this and exit the installation. 

 

5.1.4 OPC Core Components Redistributable 

VibroSight 3.x.x requires that the OPC Core Components Redistributable is installed, in order to 

configure and run VibroSight OPC Clients and VibroSight OPC Servers correctly: the redistributable 

must be installed on OPC client computers in order to allow connections to remote OPC servers and it 

must be installed on OPC server computers in order to allow OPC clients to browse for running OPC 

servers. 

NOTE: The 64-bit version of the OPC Core Components Redistributable (“OPC Core 

Components Redistributable (x64) 106.0”) must be installed on 64-bit Windows 

computers. 

The 32-bit version of the OPC Core Components Redistributable (“OPC Core 

Components Redistributable (x86) 106.0”) must be installed on 32-bit Windows 

computers. 

 

If the required OPC Core Components Redistributable is not pre-installed, then the VibroSight installer 

will detect this and automatically install it as part of the VibroSight software installation. 

 

5.1.5 Sybase SQL Anywhere 11 software 

Starting with VibroSight 3.0.0, the VibroSight historical data repositories (VibroSight historical data 

folders (*.vshdf) for operation with a VibroSight Server (live data) and VibroSight historical data 

archives (*.vshda) for operation with historical data) are exclusively used for the required data 

repositories. 

A VibroSight database based on Sybase SQL Anywhere (*.vssrvdb) can no longer be used as a 

data repository. Accordingly, the Sybase SQL Anywhere 11 database software is no longer included 

and distributed as part of the VibroSight software. 

NOTE: VibroSight 3.x.x exclusively uses data repositories based on the VibroSight 

historical data system. 

VibroSight 2.12.7 used data repositories based on Sybase SQL Anywhere 

databases and introduced initial support for working with data repositories based 

on the VibroSight historical data repositories for data analysis. 

VibroSight 2.12.6 or earlier exclusively used data repositories based on Sybase 

SQL Anywhere databases. 

 

NOTE: The manual migration of an existing machinery monitoring project to 

VibroSight 3.x.x is described in detail in the “Data migration” section of the latest 

 Getting started with VibroSight installation guide. 
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5.1.6 VM600 CMS software 

The VM600 CMS software from Meggitt Sensing Systems uses Sybase SQL Anywhere 8. Both 

Sybase SQL Anywhere 8 (VM600 CMS) and Sybase SQL Anywhere 11 (VibroSight) can be installed 

on the same computer. 

However, while SQL Anywhere 8 and SQL Anywhere 11 can be installed on the same computer and 

run at the same time for standard database operations, certain administrative tasks are mutually 

exclusive and may block one another. 

More specifically, all operations that refer to Sybase SQL (a command-line Interactive SQL utility) in 

the background could be directed to the wrong version of Sybase SQL Anywhere. For example, this 

impacts all user operations and system operations involving the creation, copying and updating of 

databases. 

NOTE: It is recommended to install and use VibroSight 3.x.x or earlier on a computer that 

does not have VM600 CMS software installed. 

 

5.1.7 SIMATIC Step 7 software 

The SIMATIC Step 7 software from Siemens typically uses Sybase SQL Anywhere 9. Both Sybase 

SQL Anywhere 9 (SIMATIC Step 7) and Sybase SQL Anywhere 11 (VibroSight) can be installed on 

the same computer. 

However, while SQL Anywhere 9 and SQL Anywhere 11 can be installed on the same computer, they 

cannot run at the same time. 

More specifically, if SIMATIC Step 7 and VibroSight are both installed, certain administrative tasks, 

such as all user operations and system operations involving the creation, copying and updating of 

databases, may not work correctly. If this behaviour is seen, the recommended workaround is to 

manually change or remove the SQLANY environmental variable in order to allow VibroSight to work 

correctly. 

Note: The SQLANY environment variable is used to contain the directory where Sybase SQL 

Anywhere is installed. 

NOTE: It is recommended to install and use VibroSight 3.x.x or earlier on a computer that 

does not have SIMATIC Step 7 software installed. 

 

5.1.8 Dell Backup and Recovery software 

Some Dell™ computers running versions of Dell Backup and Recovery software can experience 

problems running the VibroSight software, characterised by the VibroSight software not running or 

running incorrectly. This is because the Dell Backup and Recovery software can use a version of 

SQLite and associated libraries (DLLs) that prevent the VibroSight Host Service from running 

correctly. 

For example, VibroSight clients can stop running (crash), VibroSight clients can be unable to connect 

to data sources and/or VibroSight System manager may not display all of the commands expected to 

be available in the Actions window. 
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If this behaviour is seen, the recommended workaround is to uninstall the Dell Backup and Recovery 

software. 

NOTE: It is recommended to install and use VibroSight 3.x.x or earlier on a computer that 

does not have Dell Backup and Recovery software installed. 

 

 

5.2 VM600 cards 

5.2.1 Firmware 

There are no firmware updates for VM600 cards corresponding to VibroSight 3.2.0. 

The latest firmware for the CPUR remains: 

 Base System: base-system-640-014-001-001.tgz 

 Applications:  applications-640-015-001-001.tgz. 

The latest firmware for the XMC16, XMV16 and XMVS16 remains: 

 Base System: base-system-640-003-001-014.tgz 

 Applications:  applications-640-010-001-014.tgz. 

Therefore, for current versions of VM600 cards, firmware upgrades are not required. 

 

 

5.3 VibroSmart devices 

5.3.1 Firmware 

There are no firmware updates for VibroSmart modules and devices corresponding to 

VibroSight 3.2.0. 

The latest firmware for the VSI010 module remains: 

 642-002-000-009.xmsifw. 

The latest firmware for the VSN010 device remains: 

 642-004-000-011.redboxfw. 

The latest firmware for the VSV300 module remains: 

 642-001-000-014.xtranfw. 

Therefore, for current versions of VibroSmart modules and devices, firmware upgrades are not 

required. 
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6 Upgrade procedure 

This section describes the procedure for upgrading a VibroSight system from a previous version. 

Perform the steps in the given sequence in order to complete a system upgrade. 

NOTE: It is strongly recommended to verify the version of firmware running in the related 

hardware (XMx16 cards and VibroSmart modules and devices) before starting a 

VibroSight system upgrade, in order to establish if any firmware updates are also 

required. 

See 6.2.3 Updating the firmware using VibroSight System Manager. 

 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart is available before updating the firmware of any of the VibroSmart 

modules used in the distributed monitoring system. See 6.2.3 Updating the 

firmware using VibroSight System Manager. 

 

6.1 VibroSight software user settings 

The VibroSight Software generates and uses some files on the hard disk of the computer running 

VibroSight to keep track of user-configurable settings, so that these settings are remembered and 

applied for the VibroSight installation. 

These settings files have an .xmssettings file name extension and on a computer running 

Windows 7, can be found here: 

C:\Users\username\AppData\Roaming\Meggitt\VibroSight, where username is the Windows 

account name. 

For example, the VibroSightVision.xmssettings file records the user-configurable default 

settings for VibroSight Vision, such as default settings for plots. 

NOTE: VibroSight software updates and upgrades do not replace these settings files, so: 

• For a computer on which VibroSight was previously installed, an update, upgrade 

or a re-installation of VibroSight will continue to use the previous defaults recorded 

in the .xmssettings files. 

• For a computer on which VibroSight was not previously installed, the installation 

of VibroSight will generate and use new .xmssettings files, which use the latest 

VibroSight software defaults. 

If a settings file is deleted for any reason, VibroSight will generate and use a new 

settings file, which uses the latest VibroSight software defaults. 
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6.2 Updating VibroSight-compatible hardware 

Appropriate files and tools are included in the installation package to allow VM600 cards (XMx16) and 

VibroSmart devices (VSI010, VSN010 and VSV300) to be updated to the latest firmware, in order to 

take advantage of improvements to the VibroSight software. 

Updating the firmware VM600 cards or VibroSmart devices is a special task that can, if used 

unintentionally or incorrectly, lead to malfunctioning of the device and affect proper function of data 

acquisition. 

During the firmware update of a device, the card or module being updated cannot provide its normal 

machinery monitoring functions because its outputs (alarms and relays) can go to undetermined 

states, irrespective of how they have been configured. 

For VibroSmart modules, the machinery being monitored is not protected for the duration of a firmware 

update and the restart (reboot) that is triggered automatically after the firmware update (which can 

take up to 5 minutes). 

NOTE: It is highly recommended that firmware updates are only performed in accordance 

with the operating procedures for the machinery being monitored and that 

appropriate precautions are taken at the control system level (such as DCS 

or PLC). 

For example, alarms and relay outputs should be ignored (bypassed or inhibited) in 

order to avoid false trips of the machinery being monitored. 

 

6.2.1 VM600 card firmware 

The latest VM600 card firmware files are copied to a directory on your computer as part of the 

VibroSight software installation process. 

NOTE: For example, the default firmware directory for VM600 cards is: 

C:\Program Files\Meggitt\VibroSight\Firmware\VM600 

 

The firmware files for a VM600 card can be found in the appropriate subfolder and identified by their 

.tgz file name extension. For example, the XMV16 subfolder contains the applications and base 

system firmware for use by XMV16 cards. Any additional firmware updates received from Meggitt 

Sensing Systems should also be stored in these directories. 

Table 1 shows the compatibility between VibroSight software and VM600 CPUR card hardware (that 

is, CPUR card firmware). 

Table 2 shows the compatibility between VibroSight software and VM600 XMx16 card hardware (that 

is, XMC16, XMV16 and XMVS16 card firmware). 

NOTE: It is strongly recommended to use the most recent version of the VM600 CPUR 

card firmware and VM600 XMx16 card firmware that is compatible with the version 

of VibroSight software being used. 
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Table 1: VibroSight software and VM600 CPUR card firmware compatibility 

 VM600 CPUR firmware. See note 1 

VibroSight software version 

CD part number 

Base-system (*.tgz) 

640-014-001-001 

Applications (*.tgz) 

640-015-001-001 

2.12.7 

609-004-000-036 
 

See note 2
 

3.0.0 

609-004-000-037 
 

3.1.0 

609-004-000-038 
 

3.2.0 

609-004-000-039 
 

 

Notes for Table 1 

1. VM600 CPUR card firmware is packaged and distributed as a .tgz file (a compressed archive file format) with PNRs such as 

640-014-001-xxx for the Base System and 640-015-001-xxx for the (Applications) Firmware. In these PNRs, the xxx-xxx-001-

xxx denotes the firmware is packaged in the tgz file format. 

After the .tgz file is unpacked by VibroSight System Manager and the firmware is uploaded to a VM600 CPUR card, the dialog 

box displayed by the VibroSight System Manager’s Change Firmware command shows the current version of firmware using 

PNRs such as 640-014-000-xxx for the Base System and 640-015-000-xxx for the Firmware, which correspond to the actual 

unpacked firmware that is running on the card. 

 

2. This is the first official release of VM600 CPUR card firmware and includes features such as the management of XMx16 card 

configurations for applications such as control systems and the implementation of the PROFIBUS protocol for the fieldbus 

interfaces. A firmware upgrade is required in order to run VibroSight 2.12.7 or later. 
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Table 2: VibroSight software and VM600 XMx16 card firmware compatibility 

 VM600 XMx16 firmware. See note 1 

VibroSight 

software version 

CD part number 

Base-system (*.tgz) 

640-003- 

001-011 

640-003- 

001-012 

640-003- 

001-013 

640-003- 

001-014 

Applications (*.tgz) 

640-010- 

001-010 

640-010- 

001-011 

640-010- 

001-012 

640-010- 

001-013 

640-010- 

001-014 

2.12.0 

609-004-000-027 
 

See note 2
 

    

2.12.1 

609-004-000-028 
  

See note 3
 

   

2.12.2 

609-004-000-029 
  

   

2.12.3 

609-004-000-030 
  

   

2.12.4 

609-004-000-032 
  

   

2.12.5 

609-004-000-033 
   

See note 4
 

  

2.12.6 

609-004-000-034 
   

  

2.12.7 

609-004-000-036 
    

See note 5
  

3.0.0 

609-004-000-037 
     

See note 6
 

3.1.0 

609-004-000-038 
     

3.2.0 

609-004-000-039 
     

 

Notes for Table 2 (see the next page)  
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Notes for Table 2 

1. VM600 XMx16 card firmware is packaged and distributed as a .tgz file (a compressed archive file format) with PNRs such as 

640-003-001-xxx for the Base System and 640-010-001-xxx for the (Applications) Firmware. In these PNRs, the xxx-xxx-001-

xxx denotes the firmware is packaged in the tgz file format. 

After the .tgz file is unpacked by VibroSight System Manager and the firmware is uploaded to a VM600 XMx16 card, the dialog 

box displayed by the VibroSight System Manager’s Change Firmware command shows the current version of firmware using 

PNRs such as 640-010-000-xxx for the Firmware and 640-003-000-xxx for the Base System, which correspond to the actual 

unpacked firmware that is running on the card. 

 

2. This version of VM600 XMx16 card firmware introduces support for hydro air-gap monitoring. 

 

3. This version of VM600 XMx16 card firmware introduces support for 1 s time-boxed peak-hold processing (that is, spectral 

data aggregation). 

 

4. This version of VM600 XMx16 card firmware implements improved multi-rate digital resamplers (sample rate converters). 

A firmware upgrade is recommended but not required in order to run VibroSight 2.12.5 or 2.12.6. 

 

5. This version of VM600 XMx16 card firmware improves support for faster live data: 100 ms card update rate and up to 100 ms 

VibroSight Vision refresh rate. It also allows a VM600 XMx16 card to be managed by a VM600 CPUR card (“rack controller”), 

eliminating the XMx16 card’s requirement for a VibroSight Server. A firmware upgrade is required in order to run 

VibroSight 2.12.7. 

 

6. This version of VM600 XMx16 card firmware adds support for customer-specific functionality that is enabled by a customer-

specific VibroSight software licence. A firmware upgrade is required in order to run VibroSight 3.0.0 or later. 
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6.2.2 VibroSmart device firmware 

The latest VibroSmart device firmware files are copied to a directory on your computer as part of the 

VibroSight software installation process. 

NOTE: The default firmware directory for VibroSmart devices is: 

C:\Program Files\Meggitt\VibroSight\Firmware\VibroSmart 

 

The firmware files for a VibroSmart device can be found in the appropriate subfolder and identified by 

their .*fw file name extension. For example, the VSV300 subfolder contains the firmware for use by 

VSV300 modules. Any additional firmware updates received from Meggitt Sensing Systems should 

also be stored in these directories. 

Table 3 shows the compatibility between VibroSight software and the VibroSmart VSI010 module 

firmware. 

Table 4 shows the compatibility between VibroSight software and the VibroSmart VSN010 device 

firmware. 

Table 5 shows the compatibility between VibroSight software and the VibroSmart VSV300 module 

firmware. 

 

NOTE: It is strongly recommended to use the most recent version of the VibroSmart 

firmware that is compatible with the version of VibroSight software being used. 
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Table 3: VibroSight software and VibroSmart VSI010 module firmware compatibility 

 VSI010 firmware (*.xmsifw). See note 1 

VibroSight 

software version 

CD part number 

642-002 

-000-006 

642-002- 

000-007 

642-002- 

000-008 

642-002- 

000-009 

2.12.0 

609-004-000-027 


 See note 2
 

   

2.12.1 

609-004-000-028 
 

 See note 2
 

  

2.12.2 

609-004-000-029 
  

  

2.12.3 

609-004-000-030 
  

 See note 2
 

 

2.12.4 

609-004-000-032 
   

 

2.12.5 

609-004-000-033 
   

 

2.12.6 

609-004-000-034 
   

 See note 2
 

2.12.7 

609-004-000-036 
    

3.0.0 

609-004-000-037 
    

3.1.0 

609-004-000-038 
    

3.2.0 

609-004-000-039 
    

 

Notes for Table 3 

1. VibroSmart VSI010 module firmware is distributed as a single .xmsifw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSI010 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-

time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 
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addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSI010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSN010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 4: VibroSight software and VibroSmart VSN010 device firmware compatibility 

 VSN010 firmware (*.redboxfw). See note 1 

VibroSight 

software 

version 

CD part number 

642-004- 

000-008 

642-004- 

000-009 

642-004- 

000-010 

642-004- 

000-011 

2.12.0 

609-004-000-027 


 See note 2
 

   

2.12.1 

609-004-000-028 
 

 See note 2
 

  

2.12.2 

609-004-000-029 
  

  

2.12.3 

609-004-000-030 
  

 See note 2
 

 

2.12.4 

609-004-000-032 
   

 

2.12.5 

609-004-000-033 
   

 

2.12.6 

609-004-000-034 
   

 See note 2
 

2.12.7 

609-004-000-036 
    

3.0.0 

609-004-000-037 
    

3.1.0 

609-004-000-038 
    

3.2.0 

609-004-000-039 
    

 

Notes for Table 4 

1. VibroSmart VSN010 device firmware is distributed as a single .redboxfw file (a proprietary file format) with a PNR such as 

642-xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSN010 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-
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time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 

addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSN010 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSV300 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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Table 5: VibroSight software and VibroSmart VSV300 module firmware compatibility 

 VSV300 firmware (*.xtranfw). See note 1 

VibroSight 

software version 

CD part number 

642-001-000-

010 

642-001-

000-011 

642-001-

000-012 

642-001-

000-013 

642-001-

000-014 

2.12.0 

609-004-000-027 


 See note 2
 

    

2.12.1 

609-004-000-028 
 

 See note 2
 

   

2.12.2 

609-004-000-029 
  

   

2.12.3 

609-004-000-030 
  

 See note 2
 

  

2.12.4 

609-004-000-032 
   

  

2.12.5 

609-004-000-033 
   

 See note 2
 

 

2.12.6 

609-004-000-034 
    

 See note 2
 

2.12.7 

609-004-000-036 
     

3.0.0 

609-004-000-037 
     

3.1.0 

609-004-000-038 
     

3.2.0 

609-004-000-039 
     

 

Notes for Table 5 

1. VibroSmart VSV300 device firmware is distributed as a single .xtranfw file (a proprietary file format) with a PNR such as 642-

xxx-000-xxx. In these PNRs, the xxx-xxx-000-xxx denotes that the firmware is not packaged (compressed or archived). 

VibroSight System Manager always uses and displays information about VibroSmart device firmware using PNRs such as 642-

xxx-000-xxx, which correspond to the actual firmware that is running on the device. 

 

2. Updating to this version of VibroSmart VSV300 firmware requires a specific process: 

Notes: 

For a VibroSmart consisting of different types of device, the devices should be updated in the following order: first VSN010 real-

time Ethernet switches, then VSV300 vibration monitoring modules and finally VSI010 communications interface modules. In 
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addition, VibroSight System Manager should be exited (closed) and restarted after updating the firmware for each type of 

device, before continuing. And after updating the firmware, the configuration on the VibroSmart devices should be re-activated 

and the VibroSmart devices should be restarted. 

Procedure: 

(1) Ensure that a copy of the configuration for the VibroSmart is available before updating any device firmware. For example, 

using the currently installed version of VibroSight (that is, before any updates to the VibroSight software corresponding to 

updates to VibroSmart devices), VibroSight Configurator can be used to obtain a copy of the configuration as follows: 

• For a VibroSmart using a VibroSight Server, the File > Open > Server / Database command can be used to read the 

configuration from the VibroSight Server. 

• For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” VibroSmart), the File > Open > Device command can 

be used to read the configuration directly from the VibroSmart modules. 

Then the File > Save As > File command can be used to store a copy of the configuration for the VibroSmart. 

 (2) Start VibroSight System Manager, select the device or devices of the same type to be updated (for example, VSV300 

modules) and run the Change Firmware command. 

When updating multiple VibroSmart devices of the same type to use the same firmware, CTRL+click or SHIFT+click can be 

used to select multiple devices in the Devices tree structure of the System Explorer window. This way, when the Change 

Firmware command is run, all of devices that were selected will be updated at the same time. Otherwise, each device must be 

selected and updated individually. 

(3) When the VibroSmart Module(s) Firmware Upgrade window displays a “Firmware upgrade terminated. The firmware has 

been upgraded successfully …” message, click the Finish button to continue. 

If after 10 minutes, the VibroSmart Module(s) Firmware Upgrade window does not display a successful message, click the 

Cancel button to close the window and continue. 

Then exit (close) VibroSight System Manager. 

(4) Restart VibroSight System Manager and verify that the correct version of firmware is reported for each device that was 

updated. (When a device is selected in the System Explorer window, this information is available in the main window (centre) 

under Module PNR. It is also available in the VibroSmart Module(s) Firmware Upgrade window when a device is selected and 

the Change Firmware command is run). 

If a device does not report the correct version of firmware, rerun the Change Firmware command for this device. 

Then exit (close) VibroSight System Manager. 

(5) Repeat steps (2), (3) and (4) for each type of device to be updated (for example, VSI010 and VSN010 modules). 

(6) Start VibroSight Configurator, open the configuration for the VibroSmart (see step (1)), then activate the configuration. (If 

required, VibroSight Configurator will automatically update the configuration to the latest version and inform the user.) 

Then exit (close) VibroSight Configurator. 

(7) Turn the power supply to the VibroSmart off and wait for a few seconds. Then turn the power supply back on and verify that 

the system operates as expected. 

During this firmware update process, the behaviour of the LEDs on the front panel of the VibroSmart devices can be 

inconsistent and should be ignored. Normal LED behaviour resumes after the firmware update is complete (after step (7)). 
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6.2.3 Updating the firmware using VibroSight System Manager 

When performing VibroSight software upgrades, it is strongly recommended to systematically upgrade 

the firmware of VM600 XMx16 cards and VibroSmart devices to the latest compatible version. 

Failure to perform a necessary VibroSight-compatible VM600 card firmware update may lead to 

incoherent system behaviour and affect the proper functioning of data acquisition in a system. It is only 

in systems where the firmware running on the XMx16 cards and VibroSmart devices already 

corresponds to the latest available version that no firmware update is required. Therefore, it is strongly 

recommended to verify the version of firmware running on the hardware before starting a VibroSight 

system upgrade, in order to establish if a firmware update is also required. 

NOTE: Changing the firmware of the VibroSight hardware is a special administrative task 

that can – if performed unintentionally – affect the proper functioning of data 

acquisition in a system. 

It is therefore strongly recommended to change the firmware of the VibroSight 

hardware only when it is necessary. For example, when the devices must be 

updated to be compatible with a VibroSight software upgrade. 

 

For VibroSmart modules, each module can be selected and its firmware updated individually. 

Alternatively, multiple modules of the same type (for example, VSV3x0) can be updated to the same 

version of firmware at the same time. 

NOTE: It is strongly recommended to ensure that a copy of the configuration for a 

VibroSmart is available before updating the firmware of any of the VibroSmart 

modules used in the distributed monitoring system. 

For example, using the currently installed version of VibroSight (that is, before any 

updates to the VibroSight software corresponding to updates to VibroSmart 

modules), VibroSight Configurator should be used to obtain a copy of the 

configuration as follows:  

For a VibroSmart using a VibroSight Server, the File > Open > Server / Database 

command can be used to read the configuration from the VibroSight Server. 

For a VibroSmart not using a VibroSight Server (that is, a “stand-alone” 

VibroSmart), the File > Open > Device command can be used to read the 

configuration directly from the VibroSmart modules. 

Then the File > Save As > File command should be used to store a copy of the 

configuration for the VibroSmart distributed monitoring system. 

 

Update the firmware on a VibroSight device using the  Change Firmware tool (from VibroSight 

System Manager’s Maintenance tools): 

1. Ensure that the computer running the VibroSight software is on the same network as the 

hardware (XMx16 card or VibroSmart module or device) to be updated. 

2. Start VibroSight System Manager and navigate to the Devices tree structure in the System 

Explorer window. 
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The Devices tree lists all of the VibroSight compatible hardware that VibroSight can see on the 

network. If there are no XMx16 cards or VibroSmart devices in the tree structure or some cards 

are missing, verify your network connections. 

3. Select the card or device that requires its firmware to be changed. 

The Actions tool window updates to show the available tools. 

To change multiple VibroSmart to use the same version of firmware at the same time, use 

CTRL+click or SHIFT+click to select multiple devices from the Devices tree-view. (Then, when 

the Change Firmware command is run, all of the devices that were selected will be updated at 

the same time.) 

4. Click  Change Firmware in the Maintenance tools group of the Actions window. 

The Change Firmware dialog box appears. 

5. Click the Add button and select the new firmware files for the card or new firmware file for the 

device. 

 NOTE: The Change Firmware dialog box automatically opens the firmware folder 

corresponding to the VibroSight-compatible VM600 card or VibroSmart device 

selected. 

.tgz files are for VM600 cards and .*fw files are for VibroSmart devices. 

 

6. Click the Finish button to start the firmware upgrade process. 

For XMx16 cards and VibroSmart devices, the firmware upgrade process can take up to 

5 minutes, during which: 

 The IP address beside the device’s serial number in the Devices tree structure can 

disappear. 

 The LEDs on the front panel of the device can change to reflect the status of the upgrade. 

7. Repeat steps 3 to 6 for each device that requires a firmware update. 

 NOTE: Although the firmware for each VibroSight device must be changed individually 

using the  Change Firmware tool, as each device updates its firmware 

independently of the VibroSight software (once the process has started), firmware 

updates can be performed on several devices in parallel. 

 

8. After the firmware upgrade, verify that the VibroSight system is acquiring data from the cards. 

 NOTE: Refer also to the Changing the firmware topics in the  VibroSight help. 

 

The  Change Firmware tool can be used to load a VibroSight device with any version of 

firmware. It is therefore possible to change a device’s firmware to any previously available version, as 

well as the latest update. 
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This feature can be useful in certain situations, for example, swapping spare VibroSight hardware 

between different VM600 racks or VibroSmart distributed monitoring systems, where systems are 

operating with different versions of VibroSight. 

 

6.3 Final checks 

After upgrading the VibroSight software, the following checks are recommended to ensure that 

VibroSight has not been inadvertently modified and that it continues to operate as expected: 

 Use VibroSight Configurator to run a consistency check on the configuration in order to ensure 

that the configuration has not been modified by any changes to the VibroSight software, 

internal database structure and firmware for the hardware (VM600 cards and VibroSmart 

modules). 

 Use the VibroSight Server window to check that the data acquisition, data post-processing and 

data logging settings are as expected. 

In VibroSight Server, under Device drivers, use the appropriate controls to enable 

communications with the VibroSight-compatible hardware, and under Server features, use 

the appropriate controls to enable the required post processing, for example, data logging. 
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7 Customer support 

7.1 Contacting us 

Meggitt Sensing Systems worldwide customer support network offers a range of support including 

Technical support and Sales and repairs support. For customer support, please contact your local 

Meggitt Sensing Systems representative. Alternatively, contact our main office: 

Customer support 

Meggitt SA 

Route de Moncor 4 

PO Box 1616 

CH-1701 Fribourg 

Switzerland 

 

Telephone: +41 (0) 26 407 11 11 

Email: energysupport@ch.meggitt.com 

Web: www.meggittsensing.com 

 

7.2 Technical support 

Meggitt Sensing Systems technical support team provide both pre-sales and post-sales technical 

support, including: 

 General advice 

 Technical advice 

 Troubleshooting 

 Site visits. 

 

7.3 Sales and repairs support 

Meggitt Sensing Systems sales team provide both pre-sales and post-sales support, including advice 

on: 

 New products 

 Spare parts 

 Repairs. 

 

mailto:energysupport@ch.meggitt.com
http://www.meggittsensingsystems.com/
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Appendix 
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VibroSight software and Windows operating system compatibility 

 

 

Windows 7 Windows 8.1 Windows 10 

VibroSight software compatible? 

Yes 

(but not recommended for new 

installations as Microsoft support for 

Windows 7 ends in January 2020).  

Yes 
Yes 

(recommended for new installations) 

 

 

VibroSight software and Windows Server operating system compatibility 

 

 

Windows Server 2008 R2 Windows Server 2012 Windows Server 2016 

VibroSight software compatible? 

Yes 

(but not recommended for new 

installations as Microsoft support for 

Windows Server 2008 R2 ends in 

January 2020) 

Yes 

(recommended for new installations) 
To be announced 
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VibroSight software and Microsoft .NET Framework requirements 

VibroSight software version Microsoft. NET Framework requirements 

VibroSight 2.9.1 or earlier .NET Framework 3.5 SP1 

VibroSight 2.9.2 and 2.9.3 .NET Framework 4 (Standalone Installer) 

VibroSight 2.9.4 or later .NET Framework 4.5 

VibroSight 2.12.0 or later .NET Framework 4.5 and .NET Framework 2.0 
See note

 

VibroSight 3.0.0 or later .NET Framework 4.6 

Note: Since Microsoft .NET Framework 3.5 also includes .NET Framework 2.0 and .NET Framework 3.0, installing Microsoft .NET Framework 3.5 SP1 is the recommended 

solution for most computers (rather than installing Microsoft .NET Framework 2.0). 
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